bugGNU Octave - Bugs: bug #43950, print command does not work in...

 
 

bug #43950: print command does not work in MXE-octave 4.1.0+

Submitted by:  Avinoam Kalma <avinoam>
Submitted on:  Wed 07 Jan 2015 10:03:28 PM UTC  
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Invalid Assigned to:  None
Originator Name:  Avinoam Open/Closed:  Closed
Release:  dev Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Tue 13 Jan 2015 09:50:03 PM UTC, comment #13: 

Closing as invalid.

Qt printing is currently not working per https://savannah.gnu.org/bugs/index.php?42537

John Donoghue <lostbard>
Project Member
Tue 13 Jan 2015 09:22:23 PM UTC, comment #12: 

I thought that fltk is the default in the GUI version.
Setting graphics toolkit to fltk, the print works!

Thanks :-)

This bug report can be closed.

Avinoam Kalma <avinoam>
Project Member
Tue 13 Jan 2015 09:14:57 PM UTC, comment #11: 

The commandline defaults to fltk.

In the GUI you need to set it.

graphics_toolkit ('fltk')
surf(peaks)
print -dps t1.ps

John Donoghue <lostbard>
Project Member
Tue 13 Jan 2015 08:49:18 PM UTC, comment #10: 

Hi,

trying again to build MXE-octave with  default-octave tarball
and fixing manually the problems in audiodevinfo.cc the build succeded.

BUT... print command still doesn't work for me.

surf (peaks)
print -dps a.ps

works in cli version, but not in GUI version.
with gnuplot it works in both cli & GUI.

Any hints?

Avinoam Kalma <avinoam>
Project Member
Tue 13 Jan 2015 05:27:54 PM UTC, comment #9: 

You can either checkout the latest sources of octave default branch, do the bootstrap, make, etc as for compiling a native Linux build and then run 'make dist' which will create a octave-4.1.0+.tar.gz file for you that can be copied over to the mxe-octave pkg directory and then recompile in mxe-octave.

Or

You should be able to get the audio changes patch from [1] and rename it to src/default-octave-1-audiofixes.patch and compile in mxe-octave and the patch will be applied to your current default-octave tarball as part of the build process.

You will have to remove the patch at a later time when the default-octave tarball has been updated.

[1] https://savannah.gnu.org/bugs/?43964

John Donoghue <lostbard>
Project Member
Tue 13 Jan 2015 03:34:02 PM UTC, comment #8: 

How do I compile MXE-octave with latest octave default branch?

Avinoam Kalma <avinoam>
Project Member
Tue 13 Jan 2015 01:35:56 PM UTC, comment #7: 

I can print ok with 4.1.0 using a latest octave default branch instead of using the current tarball that make-update-checksum-default-octave.

You also need to set the graphics toolkit to fltk, as it does not print using the qt toolkit.

John Donoghue <lostbard>
Project Member
Mon 12 Jan 2015 10:31:56 PM UTC, comment #6: 

Hi,

I am using the following script to build the installer

cd mxe-octave
hg  pull
hg  update
PATH=`pwd`/usr/bin:$PATH
autoconf
make update-checksum-default-octave
./configure --enable-octave=default
make nsis-installer

Compilation fails because the default-octave version is before
fixing bug 43964

Avinoam Kalma <avinoam>
Project Member
Mon 12 Jan 2015 04:57:19 PM UTC, comment #5: 

Did you use the NSIS installer from MXE octave for version 4.1.0+.  This will install to a path without spaces which fixes both point 2 and point 5 for me.  I can print FLTK plot out of the GUI without problem using the ghostscript that is shipped with Octave.

Rik <rik5>
Project Administrator
Sun 11 Jan 2015 11:01:20 PM UTC, comment #4: 

The situation is this:
1. ver. 3.8.2 does not have epstool.exe (bug 43620.
2. Installing Octave in path with spaces cause troubles (changeset 3728:8c11c5a1a939 Prevent octave install to path with spaces)
2. using print in ver 3.8.2 writes warning on epstool
3. If I add esptool to ver 3.8.2 it works fine (-dps, -dpsc,
-deps, -despc) both in fltk & gnuplot, and both in gui & cli versions. The only problem is
bug 43975 you have submitted
4. Using print in ver 4.1.0  cli works the same
5. Using print in ver 4.1.0 GUI version does not produce output for fltk, but produce output file for gnuplot

Avinoam Kalma <avinoam>
Project Member
Fri 09 Jan 2015 05:39:52 PM UTC, comment #3: 

Running octave-cli.exe from a cmd prompt in Windows XP I get:

octave:5> print -dps junk.ps
warning: print.m: epstool binary is not available.
Some output formats are not available.
warning: called from
    __print_parse_opts__ at line 384 column 9
    print at line 292 column 8
'C:\Documents' is not recognized as an internal or external command,

This looks a problem where ghostscript is installed in a path that contains spaces.  I made a directory "C:\gs" and moved gs.exe from the Octave bin directory to this new folder.  Next I added the directory C:\ to the front of my PATH variable and then spawned a new cmd shell.  With those changes I can print just fine.

Rik <rik5>
Project Administrator
Fri 09 Jan 2015 06:15:14 AM UTC, comment #2: 

There is no warning message, but there is no output file.

Avinoam Kalma <avinoam>
Project Member
Fri 09 Jan 2015 05:48:26 AM UTC, comment #1: 

Is there any sort of warning message?  Does the command succeed, but there is no output file?

Rik <rik5>
Project Administrator
Wed 07 Jan 2015 10:03:28 PM UTC, original submission:  

Hi,

following discussion in bug 43620:
print command does not work in MXE-octave ver 4.1.0+
for example:

graphics_toolkit "fltk"
surf (peaks)
print -dps a.ps

the print command works with gnuplot.
In ver 3.8.2 the same command works with both fltk & gnuplot.

Thanks,

Avinoam

Avinoam Kalma <avinoam>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by lostbard (Posted a comment)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by avinoam (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-01-13 lostbard StatusWorks For Me => Invalid
        Open/ClosedOpen => Closed
    2015-01-12 rik5 StatusConfirmed => Works For Me
    2015-01-09 rik5 StatusNone => Confirmed

    Back to the top


    Powered by Savane 3.5