bugGNU Octave - Bugs: bug #41487, general 1.3.4 backwards...

 
 

bug #41487: general 1.3.4 backwards compatibility

Submitted by:  Clemens Buchacher <drizzd>
Submitted on:  Thu 06 Feb 2014 07:37:05 PM UTC  
 
Category: Octave Forge PackageSeverity: 3 - Normal
Priority: 5 - NormalItem Group: Build Failure
Status: FixedAssigned to: None
Originator Name: Clemens BuchacherOpen/Closed: Closed
Release: 3.6.4Operating System: GNU/Linux

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri 14 Feb 2014 05:27:55 PM UTC, comment #5:

Maybe a 1.3.5 version could in be place that simply changes the dependency version. If anyone wants to and is able to prepare it, please do so and I'll release it.

Carnë Draug <carandraug>
Project Member
Fri 14 Feb 2014 11:57:07 AM UTC, comment #4:

I had the same problem:

octave:2> pkg install -forge general
unpackfields.cc: In function âoctave_value_list Funpackfields(const octave_value_list&, int)â:
unpackfields.cc:92: error: âassignâ is not a member of âsymbol_tableâ
unpackfields.cc:117: error: âassignâ is not a member of âsymbol_tableâ
make: *** [unpackfields.oct] Error 1
'make' returned the following error: make: Entering directory `/tmp/oct-FCWhy4/general/src'
/usr/bin/mkoctfile-3.4.3 mark_for_deletion.cc
/usr/bin/mkoctfile-3.4.3 packfields.cc
/usr/bin/mkoctfile-3.4.3 SHA1.cc
/usr/bin/mkoctfile-3.4.3 unpackfields.cc
make: Leaving directory `/tmp/oct-FCWhy4/general/src'
error: called from `pkg>configure_make' in file /usr/share/octave/3.4.3/m/pkg/pkg.m near line 1338, column 9
error: called from:
error: /usr/share/octave/3.4.3/m/pkg/pkg.m at line 789, column 5
error: /usr/share/octave/3.4.3/m/pkg/pkg.m at line 361, column 9
octave:2>

Anonymous
Fri 07 Feb 2014 12:17:38 PM UTC, comment #3:

By the way, I changed the dependency line to 3.8.0 with r12547.

I'm closing this bug, but will reopen if anyone wants to fix it "properly".

Carnë Draug <carandraug>
Project Member
Fri 07 Feb 2014 12:16:05 PM UTC, comment #2:

The dependency line was incorrect. The new general package is dependent on Octave 3.8.0.

Aside having removed several function which had been moved to parallel (and already released), the only changes had been fixes to syntax deprecated in 3.8.0.

One of them, symbol_table::varref(), must be symbol_table::assign() which was only implemented in 3.8.0. There was no version where both coexisted. Either we had a version that give warnings with recent version, or one that does not install on old versions.

With the general package being unmaintained, I would prefer to avoid using autoconf to make it work in both versions. Specially since this version is mostly for 3.8.0 users, others might as well install 1.3.2. But if anyone think it is important and provides a patch, I'll gladly apply it.

Carnë Draug <carandraug>
Project Member
Thu 06 Feb 2014 08:08:25 PM UTC, comment #1:

To clarify: For me it builds fine with 3.8.0.

Clemens Buchacher <drizzd>
Thu 06 Feb 2014 07:37:05 PM UTC, original submission:

Hi,

An Arch user is reporting a build failure with general 1.3.4, octave 3.6.4. The DESCRIPTION file states Depends: octave (>= 3.4.3). Maybe this incompatibility is not intentional?

Original report from: https://aur.archlinux.org/packages/octave-general/

Regards,
Clemens

Clemens Buchacher <drizzd>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Digest:
   bug dependencies.

 

Carbon-Copy List
  • -unavailable- added by drizzd (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue 14 Oct 2014 04:08:34 PM UTCcarandraugDependencies-=>bugs #43415 is dependent
    Fri 07 Feb 2014 12:17:38 PM UTCcarandraugStatusNone=>Fixed
      Open/ClosedOpen=>Closed

    Back to the top


    Powered by Savane 3.1-cleanup