bugGNU Octave - Bugs: bug #65520, Financial pkg install for Octave...

 
 

bug #65520: Financial pkg install for Octave 9.1 fails

Submitter:  Matt <mdb561>
Submitted:  Wed 27 Mar 2024 12:58:51 AM UTC
   
 
Category:  Octave Package Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Unexpected Error or Warning
Status:  None Assigned to:  None
Originator Name:  Matt Open/Closed:  * Open
Release:  * 9.1.0 Operating System:  * Mac OS
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment Rich Markup
   

Wed 27 Mar 2024 04:22:26 AM UTC, comment #2: 

I just made to separate patch files (one for each function file) to help a bit further.  Most likely the patches need update before they are applied, I am pretty ignorant of how to do this properly. I assume this could be all included in a single patch file.

(file #55890, file #55891)

Andreas Bertsatos <pr0m1th3as>
Wed 27 Mar 2024 04:09:49 AM UTC, comment #1: 

Yes, .+ is not a valid syntax in Octave 9.1. Since you are installing it locally, make the required changes in the tarball and install it.

Apart from the error you spotted, the same issue persists in another places as well.

>> pkg install financial-0.5.3.tar.gz

error: parse error near line 127 of file /home/promitheas/.local/share/octave/api-v59/packages/financial-0.5.3/candle.m

  syntax error

>>>   wicks = HighPrices .- LowPrices;

                          ^
This also applies to line 128 in the same file!

After making these changes, it installed successfully in Octave 9.1. Unfortunately, I don't have permission to push these changes into octave forge. Perhaps a core dev can do this, since I don't know whether the original maintainers are still involved. It has been quite a while since the last release of the financial package (2018-10-22)




Andreas Bertsatos <pr0m1th3as>
Wed 27 Mar 2024 12:58:51 AM UTC, original submission:  

"pkg install financial" package for Octave 9.1 fails and returns error, as follows:

>> pkg install -local -forge financial

error: parse error near line 64 of file /Users/mattblake/.local/share/octave/api-v59/packages/financial-0.5.3/bolling.m

  syntax error

>>>     h = plot (x, asset, x, avg, x, avg .+ [-s, s], "-r");

                                                                 ^
error: called from
    doc_cache_create>create_cache at line 116 column 20
    gen_doc_cache_in_dir>@<anonymous> at line 150 column 20
    doc_cache_create>gen_doc_cache_in_dir at line 151 column 9
    doc_cache_create at line 62 column 12
    install>generate_lookfor_cache at line 836 column 5
    install at line 241 column 7
    pkg at line 619 column 9

>>


****
The error caret^ points up to the "+" sign.  Did I read that the ".+" operator no longer permitted?

Matt <mdb561>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #55890:  bolling_patch.diff added by pr0m1th3as (378B - text/x-patch)
file #55891:  candle_patch.diff added by pr0m1th3as (513B - text/x-patch)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by pr0m1th3as (Posted a comment)
  • -email is unavailable- added by mdb561 (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only group members can vote.

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2024-03-27 pr0m1th3as Attached File- Added bolling_patch.diff, #55890
        Attached File- Added candle_patch.diff, #55891

    Back to the top

    Powered by Savane 3.13-4b48.
    Corresponding source code