bugGNU Octave - Bugs: bug #59390, BIST for axes...

 
 

bug #59390: BIST for axes "tightinset" intermittently fails

Submitted by:  Markus Mützel <mmuetzel>
Submitted on:  Sun 01 Nov 2020 12:52:44 PM UTC  
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  None Assigned to:  None
Originator Name:  Open/Closed:  Open
Release:  dev Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 01 Nov 2020 03:37:26 PM UTC, comment #1: 

FWIW, if I execute (copy/paste into a terminal) the test with a visible figure it fails badly because the figure position is not correctly reset (it is twice as big as the default). Something similar to bug #56110, where indeed asynchronous set events coming from the GUI thread sometimes lead to unexpected results.

On the other hand, when the figure is invisible I cannot see a reason for the GUI thread to come into play. I added a few print statements to see when the GUI posts graphics events to the event queue: all seems idle (as expected) when the figure is invisible.

Pantxo Diribarne <pantxo>
Project Member
Sun 01 Nov 2020 12:52:44 PM UTC, original submission:  

The BIST for "tightinset" intermittently fails on the buildbots, e.g.:
http://buildbot.octave.org:8010/#/builders/35/builds/86/steps/7/logs/stdio

Relevant part from the log:

>>>>> processing /scratch/buildbot/workers/jwe-debian-x86_64-2/stable-gcc-lto-debian/build/libinterp/corefcn/graphics.cc-tst
***** testif HAVE_OPENGL, HAVE_QT; have_window_system () && any (strcmp ("qt", available_graphics_toolkits ()))
hf = figure ("visible", "off");
graphics_toolkit (hf, "qt");
fpos = get (hf, "position");
unwind_protect
   plot (rand (3));
   position = get (gca, "position");
   outerposition = get (gca, "outerposition");
   looseinset = get (gca, "looseinset");
   tightinset = get (gca, "tightinset");
   set (hf, "position", [fpos(1:2), 2*fpos(3:4)]);
   set (hf, "position", fpos);
   assert (get (gca, "outerposition"), outerposition, 0.001);
   assert (get (gca, "position"), position, 0.001);
   assert (get (gca, "looseinset"), looseinset, 0.001);
   assert (get (gca, "tightinset"), tightinset, 0.001);
unwind_protect_cleanup
   close (hf);
end_unwind_protect
!!!!! test failed
ASSERT errors for:  assert (get (gca, "tightinset"),tightinset,0.001)
  Location  |  Observed  |  Expected  |  Reason
    (1)        0.055357     0.044643     Abs err 0.010714 exceeds tol 0.001 by 0.01

This might be caused by a concurrency issue between the interpreter and GUI threads.

I haven't found a dedicated bug report.

Markus Mützel <mmuetzel>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by pantxo (Posted a comment)
  • -email is unavailable- added by mmuetzel (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    No changes have been made to this item

    Back to the top


    Powered by Savane 3.5