bugGNU Octave - Bugs: bug #59372, [octave forge] (control) lsim...

 
 

bug #59372: [octave forge] (control) lsim function gives incorrect results

Submitted by:  None
Submitted on:  Wed 28 Oct 2020 03:19:55 AM UTC  
 
Category:  Octave Forge Package Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  None Assigned to:  None
Originator Name:  Nidish Narayanaa Balaji Originator Email:  -email is unavailable-
Open/Closed:  Open Release:  5.2.0
Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 28 Oct 2020 08:42:12 PM UTC, comment #3: 

Attachment was missing ...


Torsten Lilge <ttl>
Project Member
Wed 28 Oct 2020 08:41:24 PM UTC, comment #2: 

This seems to be fixed in the control package from the current hg repo. The attached figure shows the simulation result with this version.

Torsten Lilge <ttl>
Project Member
Wed 28 Oct 2020 07:12:48 AM UTC, comment #1: 

Maybe related to bug #51242 or bug #58538 .

Displaying pictures.



Kai Torben Ohlhus <siko1056>
Project Member
Wed 28 Oct 2020 03:19:55 AM UTC, original submission:  

I was working on a linear dynamics problem and tried to use lsim from the control package for time transient simulation. My results were wierd, and after paying more attention, I discovered that octave's lsim function seems to result in the wrong results.

As demonstration, I'm attaching a simple sdof simulation code that can be executed in both octave as well as matlab to lead to completely different results.

The attached figures compare the results from lsim, ode45, and my hand written implementation of average acceleration (code not included).

This seems almost too simple to be wrong in octave.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #50146:  octaveplot.png added by None (66KiB - image/png)
file #50147:  matlabplot.png added by None (42KiB - image/png)
file #50148:  controlbugrep_lsim.m added by None (520B - text/x-objcsrc)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by siko1056 (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2020-10-28 ttl Attached File- => Added controlbugrep_current_control_package.png, #50156
    2020-10-28 siko1056 CategoryLibraries => Octave Forge Package
        Summarylsim function from octave gives incorrect results (matlab lsim is fine) => [octave forge] (control) lsim function gives incorrect results
    2020-10-28 None Attached File- => Added octaveplot.png, #50146
        Attached File- => Added matlabplot.png, #50147
        Attached File- => Added controlbugrep_lsim.m, #50148

    Back to the top


    Powered by Savane 3.5