bugGNU Octave - Bugs: bug #58667, [octave forge] (control) Some...

 
 

bug #58667: [octave forge] (control) Some scripts in the control package need to be updated

Submitted by:  董瑞军 <drj>
Submitted on:  Sun 28 Jun 2020 09:27:31 AM UTC  
 
Category:  Octave Forge Package Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Other
Status:  Invalid Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  5.2.0 Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Mon 06 Jul 2020 11:03:51 AM UTC, comment #9: 

Thank you for trying to reproduce the error.

It is difficult to guess what went wrong the time when it didn't work for you.

Since neither of you and me can reproduce the error, I'm closing this report as invalid.
But still, if you can recreate the bug, please feel free to comment here again or open a new bug report.

Markus Mützel <mmuetzel>
Project Member
Mon 06 Jul 2020 05:02:20 AM UTC, comment #8: 

Hope this helps. I uninstalled and reinstalled Octave-5.2.0. This is my restallation record.
1. Run octave-5.2.0_1-w64-installer.
2. A message appears, indicating that the installer cannot find the Java Runtime Environment on my system. Continue installation? Choose yes.
3. After several times of Next, change the destination folder from C:\Octave\Octave-5.2.0 to E:\Octave\Octave-5.2.0. Then click install.
4. After the installation is complete, run GNU Octave.
5. Run the following command:

z=[         0      -0.0013
    0.0010    0.0479
    0.0020    0.1877
    0.0030    0.4118
    0.0040    0.7060
    0.0050    1.0640
    0.0060    1.4912
    0.0070    1.9666
    0.0080    2.4932
    0.0090    3.0664
    0.0100    3.6786
    0.0110    4.3286
    0.0120    5.0134
    0.0130    5.7267
    0.0140    6.4674
    0.0150    7.2320
    0.0160    8.0178
    0.0170    8.8276
    0.0180    9.6546
    0.0190   10.4962
    0.0200   11.3544
]
data=iddata(z(:,2),ones(21,1),.001);sys=tfest(data,2,0)

6. Get the following error message:

error: 'is_matrix' undefined near line 50 column 9
error: called from
    _iddata_dim_>__experiment_dim__ at line 50 column 3
    _iddata_dim_ at line 29 column 12
    iddata at line 124 column 13

7. Run pkg load control. This time the above problem was solved.
8. However, the following command history reminds me that in my first installation, running pkg load control also went wrong which I cannot reproduce it now. I had to manually add the path and modify is_matrix to ismatrix in the iddata_dim script to make iddata available.

z=[         0      -0.0013
    0.0010    0.0479
    0.0020    0.1877
    0.0030    0.4118
    0.0040    0.7060
    0.0050    1.0640
    0.0060    1.4912
    0.0070    1.9666
    0.0080    2.4932
    0.0090    3.0664
    0.0100    3.6786
    0.0110    4.3286
    0.0120    5.0134
    0.0130    5.7267
    0.0140    6.4674
    0.0150    7.2320
    0.0160    8.0178
    0.0170    8.8276
    0.0180    9.6546
    0.0190   10.4962
    0.0200   11.3544
]
data=iddata(z(:,2),ones(21,1),.001);sys=tfest(data,2,0)
pkg list
help control
help iddata
pkg load control
help iddata
pkg load control
pkg load control
pkg load control
pkg load control
# Octave 5.2.0, Fri Jun 26 13:39:18 2020 GMT <unknown@DESKTOP-FTOST1T>
pkg load control
pkg load ./share/octave/packages/control-3.2.0
pkg load ./share/octave/packages/control-3.2.0
pkg load ./share/octave/packages/control-3.2.0
pkg load E:/Octave/Octave-5.2.0/mingw64/share/octave/packages/control-3.2.0
pkg load E:\Octave\Octave-5.2.0\mingw64\share\octave\packages\control-3.2.0
pkg load control
pkg load control
# Octave 5.2.0, Fri Jun 26 13:57:18 2020 GMT <unknown@DESKTOP-FTOST1T>
pkg load control
# Octave 5.2.0, Fri Jun 26 13:58:22 2020 GMT <unknown@DESKTOP-FTOST1T>
pkg load control
pkg load control
help iddata
help pkg
help control
iddata
help tf
pkg rebuild  all
help control
help tf
help iddata
quit
# Octave 5.2.0, Fri Jun 26 14:08:17 2020 GMT <unknown@DESKTOP-FTOST1T>
pkg load control
help tf
tf
iddata
help control
list control
help help
help --list
help --list
help
help iddata
z=[         0      -0.0013
    0.0010    0.0479
    0.0020    0.1877
    0.0030    0.4118
    0.0040    0.7060
    0.0050    1.0640
    0.0060    1.4912
    0.0070    1.9666
    0.0080    2.4932
    0.0090    3.0664
    0.0100    3.6786
    0.0110    4.3286
    0.0120    5.0134
    0.0130    5.7267
    0.0140    6.4674
    0.0150    7.2320
    0.0160    8.0178
    0.0170    8.8276
    0.0180    9.6546
    0.0190   10.4962
    0.0200   11.3544
]
data=iddata(z(:,2),ones(21,1),.001);
z(:,2)
ones(21,1)
.001
data=iddata(z(:,2),ones(21,1),.001);
pkg load control
data=iddata(z(:,2),ones(21,1),.001);
help is_matrix
path
pkg load control
path
help path
path('E:\Octave\Octave-5.2.0\mingw64\share\octave\packages\control-3.2.0')
path
restoredefaultpath
path
help addpath
addpath('E:\Octave\Octave-5.2.0\mingw64\share\octave\packages\control-3.2.0')
path
data=iddata(z(:,2),ones(21,1),.001);
help where
help which
which  is_matrix
data=iddata(z(:,2),ones(21,1),.001);
help ismatrix
data=iddata(z(:,2),ones(21,1),.001);
data=iddata(z(:,2),ones(21,1),.001);
data=iddata(z(:,2),ones(21,1),.001);
help ismatrix
help iddata
help
help path
path
help iddata
which help
z
data=iddata(z(:,2),ones(21,1),.001);
data=iddata(z(:,2),ones(21,1),.001);
which is_real_scalar
help isrea
help isreal
help isscalar
data=iddata(z(:,2),ones(21,1),.001);
data=iddata(z(:,2),ones(21,1),.001);
sys=tfest(data,2,0)
help control
sys=arx(data,2)
which arx
sys=arx(data,2)
sys=arx(data,2)
sys=arx(data,2)
sys
quit
# Octave 5.2.0, Fri Jun 26 15:31:00 2020 GMT <unknown@DESKTOP-FTOST1T>
FI_D_19_00063_2
pkg rebuild all
FI_D_19_00063_2
pkg load control
FI_D_19_00063_2
help tf
help tf
help absorbdelay
# Octave 5.2.0, Sun Jun 28 16:12:25 2020 GMT <unknown@DESKTOP-FTOST1T>
# Octave 5.2.0, Sat Jul 04 16:45:41 2020 GMT <unknown@DESKTOP-FTOST1T>

董瑞军 <drj>
Sat 04 Jul 2020 08:18:46 AM UTC, comment #7: 

I'm not able to reproduce this bug by installing Octave on my local drive "E:".
Running the following passed all tests:

pkg load control
runtests E:\Octave\Octave-5.2.0\mingw64\share\octave\packages\control-3.2.0

Are you aware of anything that might have caused this bug on the affected system?

Could you show the commands that led up to the error and the exact error message?

Markus Mützel <mmuetzel>
Project Member
Sat 04 Jul 2020 12:09:51 AM UTC, comment #6: 

"E:" is a local drive.
"E:" is not formatted with a different file system.
The path on E: did not include any spaces or non-ASCII characters.

董瑞军 <drj>
Fri 03 Jul 2020 09:30:19 AM UTC, comment #5: 

Thank you for reporting back.

Is "E:" a network drive or a local drive?
Is "E:" formatted with a different file system?
Did the path on E: include any spaces or non-ASCII characters?

Markus Mützel <mmuetzel>
Project Member
Fri 03 Jul 2020 07:55:50 AM UTC, comment #4: 

If the default directory is C: /..., then I changed it to e: /...

董瑞军 <drj>
Tue 30 Jun 2020 10:25:53 AM UTC, comment #3: 

Thank you for reporting back.
May I ask where Octave was installed on the affected computer?

Markus Mützel <mmuetzel>
Project Member
Tue 30 Jun 2020 08:32:28 AM UTC, comment #2: 

comment #1:

> The version of Octave that is packaged for Windows already includes a lot of Octave Forge packages. The control package is among those included (see e.g. [1]).
>
> You don't need to re-install it from forge. Just load the package with "pkg load control".
>
> Anyway, can you show the steps you used to install "control"?
> Which exact commands are triggering the error for you?
> Can you also please copy the exact error messages you are seeing and paste them here?
>
> [1]: https://wiki.octave.org/Octave_for_Microsoft_Windows#Packages


Thank you. These errors seem to be caused by non-default installation directory. I have installed Octave 5.2.0 with the default directory on another computer and everything is fine this time.

董瑞军 <drj>
Sun 28 Jun 2020 12:38:29 PM UTC, comment #1: 

The version of Octave that is packaged for Windows already includes a lot of Octave Forge packages. The control package is among those included (see e.g. [1]).

You don't need to re-install it from forge. Just load the package with "pkg load control".

Anyway, can you show the steps you used to install "control"?
Which exact commands are triggering the error for you?
Can you also please copy the exact error messages you are seeing and paste them here?

[1]: https://wiki.octave.org/Octave_for_Microsoft_Windows#Packages

Markus Mützel <mmuetzel>
Project Member
Sun 28 Jun 2020 09:27:31 AM UTC, original submission:  

I installed Octave 5.2.0 and control package 3.2.0. It seems that some scripts in the control package use outdated functions, such as "is_real_scalar", "is_real_matrix". This caused some errors.

董瑞军 <drj>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mmuetzel (Posted a comment)
  • -email is unavailable- added by drj (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2020-07-06 mmuetzel StatusNeed Info => Invalid
        Open/ClosedOpen => Closed
    2020-06-28 mmuetzel StatusNone => Need Info
        SummarySome scripts in the control package need to be updated => [octave forge] (control) Some scripts in the control package need to be updated

    Back to the top


    Powered by Savane 3.5