bugGNU Octave - Bugs: bug #58380, Font weirdly overlaps itself on...

 
 

bug #58380: Font weirdly overlaps itself on editor screen

Submitted by:  None
Submitted on:  Sat 16 May 2020 11:33:53 PM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  Invalid Assigned to:  None
Originator Name:  Yohann Vila Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  5.2.0
Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 03 Jun 2020 06:29:02 AM UTC, comment #3: 

Thank you for the feedback. I am closing the bug as invalid. We can re-open it any time when you see the issue again.

Torsten Lilge <ttl>
Project Member
Mon 01 Jun 2020 12:02:58 PM UTC, comment #2: 

I can't reproduce the bug anymore. I used to work on the other screen for a while now.

FYI The default font I have is "Courier New" and everything is set to use the default in the Octave tab.

I don't remember if I have changed some font settings to solve this , so I tried to uninstall Octave, remove C:/Users/myuser/.config/octave and C:/Users/myuser/.octave_hist, tried to reposition the window on the wrong small laptop screen, and restart Octave, but still no more bug.

(and default font still Courier new)

Do you want to close this as not-reproducible until I can get more context?

Anonymous
Sun 31 May 2020 07:21:54 PM UTC, comment #1: 

It looks like the edit area (qscintilla) would compute the character positions based on a font with variable width. Which font is selected for the default style for octave files (preferences, editor tab at the bottom)?

Torsten Lilge <ttl>
Project Member
Sat 16 May 2020 11:33:53 PM UTC, original submission:  

I use 2 screens.

The display on the editor window looks weird when I open an existing file, it seems that some characters are overlapping.

(see first screenshot)

A way to fix this is to move the octave window to the other screen (window does some re-scaling, and the font looks right now), and then if I move the window back to its original position, the display stays correct without overlapping glitch.
(see second screenshot)

Another way that fix the issue is to go to the style menu where you can change the font, and click "apply" without changing anything. It freezes a bit (a few seconds), then display is fine.

Setup :

Windows 10

Laptop with a 1920*1080 (native) resolution, extended with another screen (same resolution, but the secondary monitor is physically quite wider, like 40% more).

Laptop is primary display, screen is secondary.

also, I noticed that on windows display settings, the "Scale and layout" option is set to 125% for the primary, whereas the secondary screen is at 100%.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #49095:  2020-05-17@01_23_37-Octave.png added by None (142KiB - image/png)
file #49096:  2020-05-17@01_25_00-Octave.png added by None (135KiB - image/png)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    06:29 ttl StatusNeed Info => Invalid
        Open/ClosedOpen => Closed
    2020-05-31 ttl StatusNone => Need Info
    2020-05-16 None Attached File- => Added 2020-05-17@01_23_37-Octave.png, #49095
        Attached File- => Added 2020-05-17@01_25_00-Octave.png, #49096

    Back to the top


    Powered by Savane 3.5