bugGNU Octave - Bugs: bug #57129, Add new stem plot properties such...

 
 

bug #57129: Add new stem plot properties such as ColorMode present in latest Matlab versions

Submitted by:  Alois Schlögl <schloegl>
Submitted on:  Mon 28 Oct 2019 08:14:00 AM UTC  
 
Category:  Plotting Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Matlab Compatibility
Status:  Confirmed Assigned to:  None
Originator Name:  Open/Closed:  Open
Release:  dev Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 29 Oct 2019 02:34:51 PM UTC, comment #4: 

That would be part of the same changeset.  Matlab has changed the implementation of various stem properties as well as adding new ones.  It all needs to be addressed at once.

Rik <rik5>
Project Administrator
Tue 29 Oct 2019 09:41:03 AM UTC, comment #3: 

But matlab doc for MarkerEdgeColor says:

Marker outline color, specified as 'auto', an RGB triplet, a hexadecimal color code, a color name, or a short name. The default value of 'auto' uses the same color as the Color property

A.R. Burgers <arb>
Tue 29 Oct 2019 12:40:01 AM UTC, comment #2: 

Properties that are missing in Octave:

ColorMode
LineStyleMode
MarkerMode
XDataMode
DataTipTemplate

Rik <rik5>
Project Administrator
Tue 29 Oct 2019 12:33:35 AM UTC, comment #1: 

Do you know when this changed in Matlab?  The documentation very clearly says that 'color' refers to the stem color, and not to the markercolor property.  See https://www.mathworks.com/help/matlab/ref/stem.html.

If you you look at the properties (https://www.mathworks.com/help/matlab/ref/matlab.graphics.chart.primitive.stem-properties.html) it appears that Matlab has added new properties recently that Octave does not yet implement.

Rik <rik5>
Project Administrator
Mon 28 Oct 2019 08:14:00 AM UTC, original submission:  

When using stem() with an 'color' argument, like this 

  stem([1:100],'color','k')

or

  stem([1:100],'color',[1,1,1]*2/3)

the color is applied only to the vertical lines and not to the marker symbols.

In Matlab, the color is applied to the lines and the marker symbols. I'd also prefer this behavior.

I've tested this on GNU/Linux with qt, fltk and gnuplot on octave 4.4.1, and octave-development (version 6.0.0) compiled from source on 2019-09-27

Alois Schlögl <schloegl>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #47757:  stem_marker_color.png added by schloegl (18KiB - image/png)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by arb (Posted a comment)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by schloegl (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-10-29 rik5 StatusNone => Confirmed
        Summarystem(...'color',..): color does not affect marker => Add new stem plot properties such as ColorMode present in latest Matlab versions
    2019-10-28 schloegl Attached File- => Added stem_marker_color.png, #47757

    Back to the top


    Powered by Savane 3.5