bugGNU Octave - Bugs: bug #56129, 5.1.0 build fails against Qt 5.11...

 
 

bug #56129: 5.1.0 build fails against Qt 5.11 in doc stage with qhelpgenerator error

Submitted by:  Andrew Janke <apjanke>
Submitted on:  Sun 14 Apr 2019 12:57:00 AM UTC  
 
Category:  Configuration and Build System Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Build Failure
Status:  Invalid Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  5.1.0 Operating System:  Mac OS

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 14 Apr 2019 02:03:51 AM UTC, comment #2:

You are correct: I had left the Qt 5.12 "export QCOLLECTIONGENERATOR=qhelpgenerator" hack in place after switching back to Qt 5.11. Removing it fixed the build. You can close this as a downstream error.

Thanks for the quick catch!

Andrew Janke <apjanke>
Sun 14 Apr 2019 01:45:55 AM UTC, comment #1:

I think you've confused your build configuration. If you're building with Qt 5.11, you need to not build with 'QCOLLECTIONGENERATOR=qhelpgenerator'. The build snippet shows that qhelpgenerator is being called, that's the wrong program.

I can't reproduce this with Qt 5.11.3, but I can reproduce if I build with 'QCOLLECTIONGENERATOR=qhelpgenerator'.

Please confirm you can build if you take that out so that QCOLLECTIONGENERATOR is set to qcollectiongenerator.

Mike Miller <mtmiller>
Project Administrator
Sun 14 Apr 2019 12:57:00 AM UTC, original submission:

I am unable to build Octave 5.1.0 against Qt 5.11.2 (instead of the current Qt 5.12.x). The build fails during the doc generation stage with the following error in the make log:

rm -f doc/interpreter/octave_interpreter.qhc doc/interpreter/octave_interpreter.qch && \
        perl ./doc/interpreter/mk-qthelp.pl octave.html doc/interpreter/octave_interpreter && \
        qhelpgenerator  doc/interpreter/octave_interpreter.qhcp -o doc/interpreter/octave_interpreter.qhc >/dev/null && \
        rm -f doc/interpreter/octave_interpreter.qhcp doc/interpreter/octave_interpreter.qhp
Error in line 3: Unknown token. Expected "QtHelpProject".
make[2]: *** [doc/interpreter/octave_interpreter.qhc] Error 255
make[1]: *** [install-recursive] Error 1
make: *** [install] Error 2

Full build logs: https://gist.github.com/8a0f554520d560ea3f537fb316f073ce
Octave.app bug report: https://github.com/octave-app/octave-app-bundler/issues/85

It's complaining about not finding the token "QtHelpProject". The contents of the doc/interpreter/octave_interpreter.qhcp it's looking at is this:

<?xml version="1.0" encoding="UTF-8"?>
<!--DO NOT EDIT! Generated automatically by ./doc/interpreter/mk-qthelp.pl-->
<QHelpCollectionProject version="1.0">
  <docFiles>
    <generate>
[...]
  </docFiles>
</QHelpCollectionProject>

And over in the doc/interpreter/octave_interpreter.qhp file next to it, there is a QtHelpProject element:

<?xml version="1.0" encoding="UTF-8"?>
<!--DO NOT EDIT!  Generated automatically by ./doc/interpreter/mk-qthelp.pl-->
<QtHelpProject version="1.0">
  <namespace>org.octave.interpreter-1.0</namespace>
[...]

Maybe this has to do with the Qt change where qhelpgenerator functionality was folded in to qcollectiongenerator? Maybe they don't take the same files as inputs, so you can't just use one as a drop-in for the other without also changing the file arguments passed to them?

Andrew Janke <apjanke>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by apjanke (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-04-15 mtmiller StatusWorks For Me => Invalid
        Open/ClosedOpen => Closed
    2019-04-14 mtmiller StatusNone => Works For Me

    Back to the top


    Powered by Savane 3.4