bugGNU Octave - Bugs: bug #56116, Native (KDE) file browser startup...

 
 

bug #56116: Native (KDE) file browser startup is slow

Submitted by:  Maxim Gawrilow <eldrad_ulthran>
Submitted on:  Thu 11 Apr 2019 12:01:03 PM UTC  
 
Category:  GUI Severity:  2 - Minor
Priority:  3 - Low Item Group:  Performance
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  5.1.0 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 17 Apr 2019 03:16:39 AM UTC, comment #5:

So far I only heard complains from openSUSE Leap 15.0 (latest stable release) users, like me.  Up to now I am convinced that openSUSE has a bad mixture of kde-plasma5 and qt5 library versions, that trigger this bug.

Again, I have no idea what is going wrong.  After tedious debugging last year, I did not get one step closer and created the workaround of bug #54607, and became tired of chasing after it.

When openSUSE Leap 15.1 is out (next month) then I'll investigate this problem again, and hopefully it is resolved.  I was also waiting for Kubuntu users, for example, to report similar issues, but nothing yet to my knowledge.

Kai Torben Ohlhus <siko1056>
Project Member
Tue 16 Apr 2019 06:59:39 PM UTC, comment #4:

@Kai Do you believe KDE is aware of or working on a solution to this problem? Or do you think this should already be fixed in a newer version of KDE that you don't have yet? Is there a minimal working example that demonstrates the cause of the problem of using KDE native file dialogs with Octave?

Mike Miller <mtmiller>
Project Administrator
Tue 16 Apr 2019 02:32:10 AM UTC, comment #3:

Thank you for checking.  Thus it is indeed a duplicate.  Don't worry about the details.  For openSUSE Leap 15.0 (that I use as well) we are at the moment not able to detect and solve this issue and hope for Leap 15.1 to show up with a different KDE version and a "magically solution" to this issue:

https://savannah.gnu.org/bugs/?54607#comment45

Please be patient and we hope you can cope with this workaround.

Kai Torben Ohlhus <siko1056>
Project Member
Mon 15 Apr 2019 03:32:41 PM UTC, comment #2:

It seems to be a related issue. If I uncheck "use native file dialogs", the problem is indeed resolved. The file browser becomes fast and usable again.

However, I am not sure whether it's a duplicate, because there is lots of dev talk I fail to follow.
The native file dialog is in principle usable, with the only drawback being its very slow first call. After initialization there is no difference between native and non-native file browser.

Maxim Gawrilow <eldrad_ulthran>
Thu 11 Apr 2019 01:26:46 PM UTC, comment #1:

Thank you for your bug report. Can you please check, if this is a duplicate of bug #54607? Try so uncheck in the Octave settings the option "Use native file dialogs" restart Octave and see if the problem is still present?

Kai Torben Ohlhus <siko1056>
Project Member
Thu 11 Apr 2019 12:01:03 PM UTC, original submission:

When the "open file" dialog of the GUI editor is opened for the first time in a session, it stays empty and unresponsive for some minutes. After that, normal browsing and opening of files is possible. Also, this only applies to the first time of calling the open dialog, any further call happens with normal speed.

I'm using Octave 5.1.0 on OpenSuse Leap 15.0 with Plasma. There is a samba network drive mounted.

This has been already reported as bug #54885 http://savannah.gnu.org/bugs/?54885, but because of the author not responding, it was closed. My recent comment there was overseen apparently.

Maxim Gawrilow <eldrad_ulthran>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by siko1056 (Posted a comment)
  • -email is unavailable- added by eldrad_ulthran (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-04-16 siko1056 Dependencies- => Depends on bugs #54607
    2019-04-16 siko1056 Severity3 - Normal => 2 - Minor
        Priority5 - Normal => 3 - Low
        StatusNeed Info => Duplicate
        Open/ClosedOpen => Closed
        SummarySlow startup of file browser => Native (KDE) file browser startup is slow
    2019-04-11 mtmiller StatusNone => Need Info

    Back to the top


    Powered by Savane 3.4