bugGNU Octave - Bugs: bug #55646, image package 2.10.0 install fails...

 
 

bug #55646: image package 2.10.0 install fails on Windows (octave v4.4.1 and later)

Submitted by:  Nicholas Jankowski <nrjank>
Submitted on:  Tue 05 Feb 2019 03:42:13 PM UTC  
 
Category:  Octave Forge Package Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Installation Failure
Status:  Invalid Assigned to:  None
Originator Name:  Nicholas Jankowski Open/Closed:  Closed
Release:  5.0.91 Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Fri 22 Feb 2019 07:29:26 PM UTC, comment #20: 

agreed.  wonder if there's a way to catch the error and provide better error response to the user.  maybe just add it to the pkg rework wishlist

Nicholas Jankowski <nrjank>
Fri 22 Feb 2019 05:47:45 PM UTC, comment #19: 

Thanks for following up with the results. So this is similar to a GNU/Linux system with /tmp mounted as a separate filesystem with the 'noexec' mount option. The package is successfully downloaded, unpacked, and can run configure, but it errors when attempting to run a test executable compiled in that temporary directory. This is good diagnostic information for helping users with similar installation problems.

Mike Miller <mtmiller>
Project Administrator
Fri 22 Feb 2019 04:43:52 PM UTC, comment #18: 

created a /Octave/temp/ directory and set tempdir to that. image pkg install went fine then. appears to be a managed security setting preventing execution from user profile temp folder.

can close report. thanks for the troubleshooting effort.

Nicholas Jankowski <nrjank>
Thu 07 Feb 2019 12:54:24 PM UTC, comment #17: 

You can set the TEMP env var in octave.

 setenv('TEMP', somewherelse)

John Donoghue <lostbard>
Project Member
Thu 07 Feb 2019 12:55:52 AM UTC, comment #16: 

Re: comment #14 - yes, used that bash to try. Tried calling octave from within rrhere, and a system command still executes using the windows cmd, so same error.

Re: comment #11 - I'm editing the pkgpribate configure_make, but its ignoring any changes I make to that file. (Ignoring keyboards no matter where I put them, and always stating error at line 82...  Is that the right file?

Wondering if the issue is the temp location in my user profile.  Can I try changing .bat startup or something to designate elsewhere as temp location or is user profile hardcoded into pkg?

Nicholas Jankowski <nrjank>
Wed 06 Feb 2019 02:26:45 PM UTC, comment #15: 

using ./configure ac_cv_path_OCTAVE=octave.bat

detects octave etc ok, but the compile fails after configure as the OCTAVE_HOME var isnt set correctly - I'm changing that  in mxe, but that wont be effect the install from within octave.

John Donoghue <lostbard>
Project Member
Wed 06 Feb 2019 12:59:17 AM UTC, comment #14: 

for comment #11, did you try from a bash shell using cmdshell.bat ?

John Donoghue <lostbard>
Project Member
Wed 06 Feb 2019 12:38:15 AM UTC, comment #13: 

zeromq has a lot of compiled files in it, if you wanted to try that one

John Donoghue <lostbard>
Project Member
Tue 05 Feb 2019 11:08:30 PM UTC, comment #12: 

You could try editing pkg/private/configure_make.m and insert 'keyboard' right before both calls to 'rmdir' so that it drops you to a debug shell when the configure and/or make commands fail, you can then look at the contents of the temporary build directory including config.log before they get cleaned up.

Mike Miller <mtmiller>
Project Administrator
Tue 05 Feb 2019 11:01:32 PM UTC, comment #11: 

windows command shell has no idea what to do with a ./configure command. outside octave I opened a bash shell to /src and .configure yelled at me for 'checking for octave... no'.  I think generally it was assumed that the windows install wouldn't look outside of the octave system for a compiler, because most users probably don't have one.  is there another way for me to call this within octave?

Nicholas Jankowski <nrjank>
Tue 05 Feb 2019 10:54:14 PM UTC, comment #10: 

The signal package installation error is just because I haven't made a 1.4.1 release yet, will be coming soon, have a few more small bugs to fix.

Mike Miller <mtmiller>
Project Administrator
Tue 05 Feb 2019 10:53:11 PM UTC, comment #9: 

Yes, image is very different from symbolic because symbolic has no compiled code. If you want to know what's failing in the image configure script, try unpacking the package, chdir to the src directory, run system("./configure"), and look at config.log for the real error message.

The error "configure: error: cannot run C++ compiled programs" is good, but really needs a more detailed error message from the compiler to see what it tried to do and what exactly failed. On Windows it could be anything from directory permissions, a space in a file name somewhere, to a conflicting library somewhere. If you can't decipher config.log you can post it somewhere or attach a compressed version of the log file here.

Mike Miller <mtmiller>
Project Administrator
Tue 05 Feb 2019 10:36:04 PM UTC, comment #8: 

ok, so something's just off. here's the output when I try to install signal:

>> pkg install -forge signal
cl2bp.cc: In function 'octave_value_list Fcl2bp(const octave_value_list&, int)':
cl2bp.cc:92:5: error: 'gripe_wrong_type_arg' was not declared in this scope
     gripe_wrong_type_arg ("cl2bp", args(0));
     ^~~~~~~~~~~~~~~~~~~~
cl2bp.cc:92:5: note: suggested alternative: 'err_wrong_type_arg'
     gripe_wrong_type_arg ("cl2bp", args(0));
     ^~~~~~~~~~~~~~~~~~~~
     err_wrong_type_arg
cl2bp.cc:97:5: error: 'gripe_wrong_type_arg' was not declared in this scope
     gripe_wrong_type_arg ("cl2bp", args(1));
     ^~~~~~~~~~~~~~~~~~~~
cl2bp.cc:97:5: note: suggested alternative: 'err_wrong_type_arg'
     gripe_wrong_type_arg ("cl2bp", args(1));
     ^~~~~~~~~~~~~~~~~~~~
     err_wrong_type_arg
cl2bp.cc:102:5: error: 'gripe_wrong_type_arg' was not declared in this scope
     gripe_wrong_type_arg ("cl2bp", args(2));
     ^~~~~~~~~~~~~~~~~~~~
cl2bp.cc:102:5: note: suggested alternative: 'err_wrong_type_arg'
     gripe_wrong_type_arg ("cl2bp", args(2));
     ^~~~~~~~~~~~~~~~~~~~
     err_wrong_type_arg
cl2bp.cc:107:5: error: 'gripe_wrong_type_arg' was not declared in this scope
     gripe_wrong_type_arg ("cl2bp", args(3));
     ^~~~~~~~~~~~~~~~~~~~
cl2bp.cc:107:5: note: suggested alternative: 'err_wrong_type_arg'
     gripe_wrong_type_arg ("cl2bp", args(3));
     ^~~~~~~~~~~~~~~~~~~~
     err_wrong_type_arg
cl2bp.cc:112:5: error: 'gripe_wrong_type_arg' was not declared in this scope
     gripe_wrong_type_arg ("cl2bp", args(4));
     ^~~~~~~~~~~~~~~~~~~~
cl2bp.cc:112:5: note: suggested alternative: 'err_wrong_type_arg'
     gripe_wrong_type_arg ("cl2bp", args(4));
     ^~~~~~~~~~~~~~~~~~~~
     err_wrong_type_arg
cl2bp.cc:129:5: error: 'gripe_wrong_type_arg' was not declared in this scope
     gripe_wrong_type_arg ("cl2bp", args(5));
     ^~~~~~~~~~~~~~~~~~~~
cl2bp.cc:129:5: note: suggested alternative: 'err_wrong_type_arg'
     gripe_wrong_type_arg ("cl2bp", args(5));
     ^~~~~~~~~~~~~~~~~~~~
     err_wrong_type_arg
make: *** [Makefile:40: cl2bp.o] Error 1
make: Entering directory '/c/Users/NICHOL~1.JAN/AppData/Local/Temp/oct-wLRxet/signal-1.4.0/src'
C:/Programs/Octave/OCTAVE~1.91-/mingw64/bin/mkoctfile-5.0.91.exe -Wall -Wno-deprecated-declaratio
ns  __fwht__.cc -o __fwht__.oct
C:/Programs/Octave/OCTAVE~1.91-/mingw64/bin/mkoctfile-5.0.91.exe -Wall -Wno-deprecated-declaratio
ns  __ultrwin__.cc -o __ultrwin__.oct
C:/Programs/Octave/OCTAVE~1.91-/mingw64/bin/mkoctfile-5.0.91.exe -Wall -Wno-deprecated-declaratio
ns  -c cl2bp.cc -o cl2bp.o
make: Leaving directory '/c/Users/NICHOL~1.JAN/AppData/Local/Temp/oct-wLRxet/signal-1.4.0/src'

pkg: error running `make' for the signal package.
error: called from
    configure_make at line 99 column 9
    install at line 184 column 7
    pkg at line 441 column 9

Nicholas Jankowski <nrjank>
Tue 05 Feb 2019 10:34:39 PM UTC, comment #7: 

nothing that's showing up in any logs.  and is symbolic different enough that it would work but image would not? is there another suggested package to try? I can uninstall reinstall each and see if others produce the same effect. There are some I think we expect to fail, but it's been a while since I reviewed what those were.

Nicholas Jankowski <nrjank>
Tue 05 Feb 2019 10:04:30 PM UTC, comment #6: 

You dont happen to have any virus check software thats messing with configure test?

Ive seen a few warning on mine for other packages tests, but so far hasnt been anything that has stopped it from installing.

John Donoghue <lostbard>
Project Member
Tue 05 Feb 2019 08:56:47 PM UTC, comment #5: 

sorry, cannot reinstall it with any version of image as far back as 2.6.1.  previously those had at least 2.8.0

Nicholas Jankowski <nrjank>
Tue 05 Feb 2019 08:55:52 PM UTC, comment #4: 

verified that in Octave 5.0.91 and 4.4.1 after uninstalling the image package I cannot reinstall it. on another pc with same OS and general permission set and 4.2.1, I get the same error. Not sure what's unique to my system causing a problem with this package but not others.

Nicholas Jankowski <nrjank>
Tue 05 Feb 2019 06:59:42 PM UTC, comment #3: 

permissions?

I just did a successful uninstall and reinstall of symbolic and had no issues, but I get  the error with image 2.10.0. so it's not a complete inability to install a package. I don't know what goes on under the hood with those packages, and if there's another better comparison.

I haven't stepped back through image packages yet. will try that shortly.

Nicholas Jankowski <nrjank>
Tue 05 Feb 2019 05:58:31 PM UTC, comment #2: 

pkg install -forge image works ok on my win10 machine using the 5.0.91 zip archive

John Donoghue <lostbard>
Project Member
Tue 05 Feb 2019 04:34:45 PM UTC, comment #1: 

Can you check that indeed that image 2.8.0 builds fine with your setup. I checked the compiler section for the configure script for both 2.8.0 and 2.10.0 and couldn't find any difference.

Carnë Draug <carandraug>
Project Member
Tue 05 Feb 2019 03:42:13 PM UTC, original submission:  

noticed on 4.4.1 and just verified it also occurs on the current 5.0.91 (RC2):  attempting to install or update the image package on windows results in an install/build failure. I know there are some packages that cannot be compiled/installed from the Windows build, but thought image was usually okay. (using the Windows zip archive binaries)

>> pkg install -forge image
configure: error: in `/c/Users/NICHOL~1.JAN/AppData/Local/Temp/oct-u9So6s/image-2.10.0/src':
configure: error: cannot run C++ compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details
configure: loading site script /usr/local/etc/config.site
checking for a sed that does not truncate output... /usr/bin/sed
checking for octave... C:/Programs/Octave/OCTAVE~1.91-/mingw64/bin/octave-5.0.91.bat
checking for mkoctfile... C:/Programs/Octave/OCTAVE~1.91-/mingw64/bin/mkoctfile-5.0.91.exe
checking whether the C++ compiler works... yes
checking for C++ compiler default output file name... a.exe
checking for suffix of executables... .exe
checking whether we are cross compiling...
pkg: error running the configure script for image.
error: called from
    configure_make at line 82 column 9
    install at line 184 column 7
    pkg at line 441 column 9

Nicholas Jankowski <nrjank>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by lostbard (Posted a comment)
  • -email is unavailable- added by nrjank (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-02-22 mtmiller StatusNone => Invalid
        Open/ClosedOpen => Closed
    2019-02-06 carandraug Carbon-CopyRemoved -email is unavailable- => -
    2019-02-05 nrjank Carbon-Copy- => Added carandraug@octave.org

    Back to the top


    Powered by Savane 3.5