bugGNU Octave - Bugs: bug #55126, Sparse Matrix and binary oparators

 
 

bug #55126: Sparse Matrix and binary oparators

Submitted by:  Nik Demus <sumocin>
Submitted on:  Wed 28 Nov 2018 03:54:09 PM UTC  
 
Category:  Interpreter Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Duplicate Assigned to:  None
Originator Name:  sumocin Open/Closed:  Closed
Release:  4.4.1 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 28 Nov 2018 06:32:47 PM UTC, comment #2: 

Unfortunately this is a known problem, see bug #41441.

Marking this report as a duplicate and closing.

Rik <rik5>
Project Administrator
Wed 28 Nov 2018 04:03:00 PM UTC, comment #1: 

Forgot to mention that the result in GNU Octave is

error: operator <op>: nonconformant arguments (op1 is 3x3, op2 is 3x1)

I think the problem is related to broadcasting the vector with sparse matrices.

Not sure though if this is a bug or a feature yet to implement.

Nik Demus <sumocin>
Wed 28 Nov 2018 03:54:09 PM UTC, original submission:  

Hi, the following code fails in GNU Octave

a = [1 2 0; 0 0 1; 1 0 0];
b = [1 2 3]';

% this works
a .* b

% this don't
sparse(a).*b

other commands which fail are

sparse(a).^ b
sparse(a)./ b
sparse(a) + b
sparse(a) - b

In matlab they all return a sparse matrix

Nik Demus <sumocin>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by sumocin (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-11-28 rik5 CategoryNone => Interpreter
        StatusNone => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #41441

    Back to the top


    Powered by Savane 3.7