bugGNU Octave - Bugs: bug #54680, imagesc incomplete when using...

 
 

bug #54680: imagesc incomplete when using software rendering

Submitted by:  Muhali <muhali>
Submitted on:  Tue 18 Sep 2018 02:50:15 PM UTC  
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Open
Release:  4.4.1 Operating System:  GNU/Linux

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 22 Oct 2018 07:06:37 PM UTC, comment #4:

Oh, this is really disappointing.

While debugging I found out that this is a duplicate of a bug I've filed 4 years ago:

https://savannah.gnu.org/bugs/?43873

Andreas Weber <andy1978>
Project Member
Fri 05 Oct 2018 02:43:51 PM UTC, comment #3:

I see the same but cropped around 16380 (I guess 2^14) but with hardware rendering (free radeon driver)

Andreas Weber <andy1978>
Project Member
Tue 18 Sep 2018 06:22:34 PM UTC, comment #2:

Also confirmed here with LIBGL_ALWAYS_SOFTWARE=1. It looks like it stops drawing about 8200, maybe 8192? When the zoom is changed to focus on the area around x=9000, the area that was white now appears shaded.

Mike Miller <mtmiller>
Project Administrator
Tue 18 Sep 2018 05:42:09 PM UTC, comment #1:

Confirm.
It appears the issue is due to software GL vs hardware GL.
I can trigger the same behavior by doing

LIBGL_ALWAYS_SOFTWARE=1 octave

on local machine.

I wonder if this is bug in Mesa llvmpipe driver.

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Tue 18 Sep 2018 02:50:15 PM UTC, original submission:

When I issue

imagesc(ones(10000, 1)')

directly on my local machine I get a normal full rectangle (local.png attached), but when done remotely via ssh my rectangle is cropped (remote.png).

Muhali <muhali>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #45035:  local.png added by muhali (11KiB - image/png)
file #45036:  remote.png added by muhali (12KiB - image/png)

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by andy1978 (Posted a comment)
  • -email is unavailable- added by dasergatskov (Posted a comment)
  • -email is unavailable- added by muhali (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 8 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-10-22 andy1978 Dependencies- => Depends on bugs #43873
    2018-10-22 andy1978 StatusConfirmed => Duplicate
    2018-09-19 mtmiller Carbon-CopyRemoved 80942 => -
    2018-09-18 mtmiller CategoryNone => Plotting with OpenGL
        StatusNone => Confirmed
        Summaryimagesc incomplete => imagesc incomplete when using software rendering
    2018-09-18 muhali Attached File- => Added local.png, #45035
        Attached File- => Added remote.png, #45036

    Back to the top


    Powered by Savane 3.3