bugGNU Octave - Bugs: bug #54662, Document that 4.4.1 will not...

 
 

bug #54662: Document that 4.4.1 will not install without error on Windows XP SP3

Submitted by:  None
Submitted on:  Fri 14 Sep 2018 01:06:13 PM UTC  
 
Category:  Octave website Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  Wont Fix Assigned to:  None
Originator Name:  John Stensby Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  4.4.1
Operating System:  Microsoft Windows

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Tue 26 Mar 2019 05:27:36 PM UTC, comment #23:

added a note to the Octave wiki regarding winxp for versions post 4.4.1

https://wiki.octave.org/Octave_for_Microsoft_Windows

Nicholas Jankowski <nrjank>
Sun 10 Mar 2019 02:53:18 PM UTC, comment #22:

Also if you are interested in speeding up Octave's performance, you might want to have a look at the (as of now rudimentary) JIT compiler. AFAIK it isn't part of the Windows version of Octave (yet). Just search the bug tracker for "JIT" and you should be able to find some interesting projects to work on.
Although it also depends on LLVM...

Markus Mützel <mmuetzel>
Project Member
Sun 10 Mar 2019 02:45:42 PM UTC, comment #21:

The difference in size is probably due to the fact that we switched to llvmpipe which performs orders of magnitudes faster than softpipe on some scenes (see bug #54396).
That switch is probably also the reason why the newer dll no longer works on Windows XP:
https://www.phoronix.com/scan.php?page=news_item&px=LLVM-Drops-Windows-XP

So if you are interested in creating a Windows XP compatible Octave, the way forward is probably to try and get a working (albeit veeeery slow) softpipe OpenGL renderer.

Markus Mützel <mmuetzel>
Project Member
Sun 10 Mar 2019 02:14:47 PM UTC, comment #20:

The opengl32.dll that shipped with octave has functions that aren't included in the original XP dll. One other thing is that opengl32 that shipped with Octave 5 has a size of 37 MB while in 4.4 it is 8.8 MB.

The compiler shortly converts a m file to a cpp file and then it compiles the cpp to a dll or an oct file. In some primary tests it shows 3X speed up related to the interpreter. It is based on Octave 4.4. Fortunately octave-5-cli can be run in Windows XP. I probably switch to octave 5 after completing the basic working version in octave 4.4.

Anonymous
Sun 10 Mar 2019 01:36:15 PM UTC, comment #19:

I was thinking that Windows shipped a (slow) built-in OpenGL software renderer (that is its own "opengl32.dll"). But it looks like Windows XP would need a graphics card driver with OpenGL support(?).

We aren't a big group of developers. Especially not for the Windows target. So it often is the fastest/easiest fix to update dependencies to a newer version instead of trying to code around issues that have already been fixed upstream.

If you want to, you could set up a dual boot system and cross build your version of Octave with the dependencies you prefer. Instructions are available on the Wiki:
https://wiki.octave.org/Windows_Installer

Also if you want to provide patches that fix compatibility issues, I am sure they will be considered if they aren't introducing incompatibilities with newer versions.
Any patches that improve performance are also welcome, too.

I am not sure what you mean by an "Octave native compiler". But looking forward to hearing about it (maybe better on the maintainers mailing list).

Markus Mützel <mmuetzel>
Project Member
Sun 10 Mar 2019 01:03:30 PM UTC, comment #18:

Octave-cli won't work without "opengl32.dll". I used dependency walker and it shows that "LIBOCTINTERP-7.DLL" has been built against "opengl32.dll" and some other possibly unrelated graphics libraries like "LIBGRAPHICSMAGICK++-12.DLL" "LIBGRAPHICSMAGICK-3.DLL" "LIBFONTCONFIG-1.DLL" "LIBFREETYPE-6.DLL" "GDI32.DLL" "LIBGL2PS.DLL" and "GLU32.DLL".

@Markus I'm sorry, as I did not judge you correctly. At least you are responsive. I believe that here the speed and importance of upgrading the third party libraries to their latest versions is more than the speed of improving the core Octave functionalities.
While, in spite of the recent improvements by jwe, the interpreter doesn't have a reasonable speed there is a tendency towards upgrading to the latest llvm version.
The same trend can be viewed in upgrading to the latest Qt version and those upgrades sometimes aren't without memory overhead.
I think I and others like me should switch to GNU R as it seems that it can be run in Windows XP.
PS: Beginning in Octave 4.4 I have been working on an Octave native compiler. Its runtime is almost complete. Its code generator is 80% complete and its build system is 70% complete. Without any shame all of its developments are done in a Windows XP system. I hope that it will be released and will be dedicated to all of users and developers.

Anonymous
Sun 10 Mar 2019 11:07:36 AM UTC, comment #17:

Does deleting (or renaming) opengl32.dll from the "bin" directory also allow running Octave CLI? Does plotting still work?

I hope you understand that we are not "trying hard" to drop support for Windows XP. It just seemed reasonable to do so now because I thought we already "accidentally" did so in the past.
I personally won't put days into debugging problems with old OS versions. But if the solution is as simple as "delete that file and it'll work again", I definitely won't oppose.
With your new information here, the potential change in bug #36477 is to be viewed under a different light.

Please, also see my recent message on the mailing list:
http://octave.1599824.n4.nabble.com/Minimum-version-of-Windows-for-default-branch-td4691942.html

Markus Mützel <mmuetzel>
Project Member
Sun 10 Mar 2019 10:12:11 AM UTC, comment #16:

In bug #36477 Mike and Markus are trying hard to change compiler options for dropping completely support for Windows XP. So it will be more difficult for you to provide even paid support.

Anonymous
Sun 10 Mar 2019 09:55:23 AM UTC, comment #15:

Thankfully core Octave engine libraries "liboctave-7.dll" and "liboctinterp-7.dll" of octave-5.1.0-w32 are currently working in Windows XP.
As a good news I also can execute octave-cli in Windows XP replacing opengl32.dll with the same file from Octave 4.4.

Anonymous
Sat 02 Mar 2019 09:26:03 PM UTC, comment #14:

Octave 4.4.1 is deprecated and no longer supported. I (Rik), personally, have given up compiling for Windows XP because it has grown too difficult. If the original reporter must run on Windows XP then I think paid support is the best option.

Rik <rik5>
Project Administrator
Wed 30 Jan 2019 06:26:10 PM UTC, comment #13:

@John: Please respond on the bug tracker so that others can follow as well.

"octave.bat" should be starting octave-cli.exe after setting up the necessary paths. octave-cli.exe is not linked to qt.
So if this fails as well that probably means that other dependencies also dropped support for Windows XP.

Since I don't have any means to test if it works, I don't see how I could offer an unofficial version for Windows XP (let alone hosting it).

If jwe is willing to look into it, please contact him to make the necessary arrangements.

Markus Mützel <mmuetzel>
Project Member
Wed 30 Jan 2019 06:16:32 PM UTC, comment #12:

John Stensby sent by email:
On a XP machine with 4.4.1 installed, I tried running

c:\octave\octave-4.4.1\bin\octave.bat

As expected, I got an error message stating "RegGetValueW could not be found in ADVAPI33.dll"

Thanks
John Stensby

Markus Mützel <mmuetzel>
Project Member
Wed 30 Jan 2019 04:40:22 PM UTC, comment #11:

Hello all!

I have seen many projects that dropped support for Windows XP because they exclusively need features that are contained in recent versions of libraries that don't work in XP.

Is there any feature in the recent version of Qt that Octave exclusively needs it? Octave 4.4 is based on Qt 5.7.1.0 that works in Windows XP. As I know Octave currently even can be built based on Qt 4.

I know Qt is great but many of users accustomed to Octave and they want to promote it and want to see its day to day improvements.

I hope that any of maintainers like John, Rik, Mike (maybe Markus) or other ones can compile at least an unofficial Windows version compatible with Windows XP.

Many thanks.

Anonymous
Wed 30 Jan 2019 03:53:27 PM UTC, comment #10:

People interested in Octave on Windows XP are always free to build it for themselves and others.

I would be willing to put some effort in, but probably only if it is paid work.

John W. Eaton <jwe>
Project Administrator
Wed 30 Jan 2019 02:41:36 PM UTC, comment #9:

I didn't expect this. But according to [1], the market share of Windows XP still is comparable to that of Mac OS X 10.13 (which seems to be the most common OS on the Mac platform currently).

Since Qt5 dropped support for Windows XP, one way of supporting the GUI might be to provide builds with Qt4 (which we decided to discontinue gradually and which is unsupported since 2015).

However, I am uncertain of whether we really should put too much effort in supporting an OS which dropped out of official support by its producer almost 5 years ago.
Maybe it would be better to just document that we require a minimum Windows version. Maybe that could be Windows 7 which still has one year to live.

@John: Could you try running "octave.bat" in "C:\Octave\Octave-4.4.1\bin"? If that doesn't open the CLI, that means that other dependencies than Qt also no longer support Windows XP.

[1]: https://netmarketshare.com/operating-system-market-share.aspx?options=%7B%22filter%22%3A%7B%22%24and%22%3A%5B%7B%22deviceType%22%3A%7B%22%24in%22%3A%5B%22Desktop%2Flaptop%22%5D%7D%7D%5D%7D%2C%22dateLabel%22%3A%22Trend%22%2C%22attributes%22%3A%22share%22%2C%22group%22%3A%22platformVersion%22%2C%22sort%22%3A%7B%22share%22%3A-1%7D%2C%22id%22%3A%22platformsDesktopVersions%22%2C%22dateInterval%22%3A%22Monthly%22%2C%22dateStart%22%3A%222018-01%22%2C%22dateEnd%22%3A%222018-12%22%2C%22segments%22%3A%22-1000%22%7D

Markus Mützel <mmuetzel>
Project Member
Wed 30 Jan 2019 01:41:03 PM UTC, comment #8:

Depending on what the trade offs are, including XP compatibility in Octave 5 could be worth the effort.

From a global perspective, there are still a significant number of machines running XP.

John <stensby>
Wed 30 Jan 2019 12:36:28 PM UTC, comment #7:

Should we act on this bug before the release of Octave 5?

Markus Mützel <mmuetzel>
Project Member
Wed 19 Sep 2018 04:22:00 PM UTC, comment #6:

Oh, I remember now that we don't provide octave.exe, but octave-gui.exe could execute in command-line mode as well.

John W. Eaton <jwe>
Project Administrator
Wed 19 Sep 2018 04:20:36 PM UTC, comment #5:

Did you try running octave-cli.exe or octave.exe?

The octave-cli.exe program is not supposed to be linked with Qt, so I think it could still work if it is the Qt5 libraries that don't work with Windows XP.

John W. Eaton <jwe>
Project Administrator
Wed 19 Sep 2018 03:59:39 PM UTC, comment #4:

Both the command line and GUI versions of 4.4.1 will not work on 32 bit XP SP#

John <stensby>
Sun 16 Sep 2018 01:11:58 PM UTC, comment #3:

@John: Please use savannah to respond to this bug so that others can follow the conversation.

Octave no longer supports Windows XP since we updated to a newer version of Qt that dropped its support. The error that you are seeing could be due to that change. Please see bug #54199.

We should probably document that on the download page as well.

@John: The CLI version could still be working. But I don't have a Windows XP to test with. Could you please try?

Markus Mützel <mmuetzel>
Project Member
Sun 16 Sep 2018 01:05:25 PM UTC, comment #2:

John Stensby sent via emails:

On 32 bit XP SP3, version 4.4.1 starts to install. However, the installation process will not complete before the error is displayed. A user form command button must be pressed to get back to the desk top. Then, the same error is displayed each time you try to run Octave.

On the web, I've read posts (which may be incorrect) from people that state RegGetValueW is not a procedure in the XP version of ADVAPI32.dll. But, this is outside of my knowledge base.

I use the installer version of Octave since I do not want to try and build the program from its source.

John

--------------------------------------------

Apparently, RegGetValueW is not available in the 32 bit version of Windows XP. See the link given below (scroll down to the bottom where "Requirements" are listed.)

https://docs.microsoft.com/en-us/windows/desktop/api/winreg/nf-winreg-reggetvaluew

John

--------------------------------------------

I downloaded the .zip file for 32 bit 4.4.0. After a long unzip process, I ran the .vbs file. At the very beginning, the same error

"RegGetValueW could not be located in the dynamic link library ADVAPI32.dll"

occurred.

John

Markus Mützel <mmuetzel>
Project Member
Fri 14 Sep 2018 02:56:15 PM UTC, comment #1:

Octave itself doesn't call RegGetValue. That error is probably caused by the NSIS installer or another tool we call during installation.

Does the installer start at all? Or do you see this error immediately when starting the installer?

As a workaround, you might try and use the 7z or zip version.

Markus Mützel <mmuetzel>
Project Member
Fri 14 Sep 2018 01:06:13 PM UTC, original submission:

Installation of version 4.4.1 on 32 bit Windows XP SP3 produces the error message:

"The procedure entry point RegGetValueW could not be located in the dynamic link library ADVAPI32.dll"

Note that version 4.4.0 installs correctly and operates OK.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by nrjank (Posted a comment)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by stensby (Posted a comment)
  • -email is unavailable- added by mmuetzel (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-03-02 rik5 StatusNeed Info => Wont Fix
        Open/ClosedOpen => Closed
    2018-09-16 mmuetzel CategoryConfiguration and Build System => Octave website
        Summary4.4.1 will not install without error on Windows XP SP3 => Document that 4.4.1 will not install without error on Windows XP SP3
    2018-09-14 mmuetzel StatusNone => Need Info

    Back to the top


    Powered by Savane 3.4