bugGNU Octave - Bugs: bug #54316, [octave forge] (ga) Unit test in...

 
 

bug #54316: [octave forge] (ga) Unit test in ga.m fails randomly

Submitted by:  Rafael Laboissiere <rlaboiss>
Submitted on:  Mon 16 Jul 2018 12:13:46 PM UTC  
 
Category:  Octave Forge Package Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  other Operating System:  Any

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 03 Jan 2019 09:50:25 PM UTC, comment #2:

Duplicate of #55348, which contains patch

Thanks for the bug report. This particular bug has already been
reported into our bug tracking system, but please feel free to
report any further bugs you find.

John Donoghue <lostbard>
Project Member
Wed 25 Jul 2018 12:08:44 PM UTC, comment #1:

Looks like it occurs when the input nParents in the _ga_selectionfcn_ function call is 0.

Ay that point

fails

John Donoghue <lostbard>
Project Member
Mon 16 Jul 2018 12:13:46 PM UTC, original submission:

One of the unit tests in file ga.m fails randomly. This is a way of triggering the bug:

There are other unit tests that also use the randi() function. they may be affected, but I did not do extensive investigation on the issue.

Rafael Laboissiere <rlaboiss>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by lostbard (Posted a comment)
  • -email is unavailable- added by rlaboiss (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-01-03 lostbard StatusNone => Duplicate
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.4