bugGNU Octave - Bugs: bug #53728, test failure in ov-java.cc

 
 

bug #53728: test failure in ov-java.cc

Submitted by:  A.R. Burgers <arb>
Submitted on:  Mon 23 Apr 2018 07:42:35 PM UTC  
 
Category:  Interpreter Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Regression
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  4.3.91 Operating System:  GNU/Linux

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 24 Apr 2018 05:33:43 PM UTC, comment #3:

This basically looks the same as bug #51804, but in your case Oracle Java 7 is exposing this problem. I've already done some research into this and posted comments on that bug report about the problem, so feel free to discuss there if this is important to you.

I will add a bug number tag to this test so if it fails it will point to the same report.

Mike Miller <mtmiller>
Project Administrator
Tue 24 Apr 2018 07:24:04 AM UTC, comment #2:

Indeed the last line was missing:

***** testif HAVE_JAVA; usejava ("jvm")
n = javaObject ("java.lang.Short", 1.35);
assert (n.compareTo (0), 1);
assert (n.compareTo (1), 0);
assert (n.compareTo (2), -1);
!!!!! test failed
[java] java.lang.ClassCastException: java.lang.Double cannot be cast to java.lang.Short

A.R. Burgers <arb>
Mon 23 Apr 2018 09:08:27 PM UTC, comment #1:

It looks like you trimmed off the error message. Which of the commands in the second test fails and what is the error message?

Mike Miller <mtmiller>
Project Administrator
Mon 23 Apr 2018 07:42:35 PM UTC, original submission:

I get this failure:

libinterp/octave-value/ov-java.cc-tst ....................... PASS 14/16
FAIL 1
(reported bug) XFAIL 1

in test/fntests.log

***** testif HAVE_JAVA; usejava ("jvm") <51804>
n = javaObject ("java.lang.Integer", 1.35);
assert (n.compareTo (0), 1);
assert (n.compareTo (1), 0);
assert (n.compareTo (2), -1);
!!!!! known bug: https://octave.org/testfailure/?51804
[java] java.lang.ClassCastException: java.lang.Double cannot be cast to java.lang.Integer
***** testif HAVE_JAVA; usejava ("jvm")
n = javaObject ("java.lang.Short", 1.35);
assert (n.compareTo (0), 1);
assert (n.compareTo (1), 0);
assert (n.compareTo (2), -1);
!!!!! test failed

from the configure output:

Java home: /usr/lib/jvm/java-1.7.0-oracle-1.7.0.161.x86_64
Java JVM path: /usr/lib/jvm/java-1.7.0-oracle-1.7.0.161.x86_64/jre/lib/amd64/server
Java CPPFLAGS: -I/usr/lib/jvm/java-1.7.0-oracle-1.7.0.161.x86_64/include -I/usr/lib/jvm/java-1.7.0-oracle-1.7.0.161.x86_64/include/linux
Java libraries:

A.R. Burgers <arb>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by arb (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-04-24 mtmiller Dependencies- => Depends on bugs #51804
    2018-04-24 mtmiller StatusNeed Info => Duplicate
        Open/ClosedOpen => Closed
    2018-04-23 mtmiller StatusNone => Need Info

    Back to the top


    Powered by Savane 3.4