bugGNU Octave - Bugs: bug #53645, mxe-octave: make hg-octave-dist...

 
 

bug #53645: mxe-octave: make hg-octave-dist confuses octave-5.0.0 and 4.3.90

Submitted by:  Marshall <marsian>
Submitted on:  Fri 13 Apr 2018 08:16:16 PM UTC  
 
Category:  Configuration and Build System Severity:  1 - Wish
Priority:  5 - Normal Item Group:  Feature Request
Status:  Invalid Assigned to:  None
Originator Name:  Marsian Open/Closed:  Closed
Release:  4.3.90 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 14 Apr 2018 11:01:33 AM UTC, comment #5: 

In mxe-octave, the first time you tun make- hg-octave-dist and it creates the octave hg repo, it uses the environment var 'hg-octave-branch' to checkout the correct branch, so that can be used initially to set the correct repo branch.

It only works when it initialy pulls to repo.

Other than that, you can also go into the octave-hg-repo directory and checkout the branch you want.

However as mentioned, t was intended for use with default so doesnt check you have the correct branch vs what you are trying to build

John Donoghue <lostbard>
Project Member
Fri 13 Apr 2018 11:06:17 PM UTC, comment #4: 

Yes, there are usually only a handful of release candidates made when the Octave maintainers feel that a release will be made soon. It's a subjective and manual process to create a new release candidate. Yes, there are already commits on the stable branch since the 4.3.90 release candidate was made. There may be a 4.3.91 release candidate, or we may go straight to a 4.4.0 release, depending on the number of bugs found and fixed and our confidence in the stability of the last one.

Closing this as invalid, unless you see a need for 'hg-octave-dist' to support both the default and stable branch.

I think most of the developers who are building and testing mxe-octave regularly with Octave's stable branch already know how to build the tarball and manually copy it into the mxe-octave/src directory.

Mike Miller <mtmiller>
Project Administrator
Fri 13 Apr 2018 10:47:07 PM UTC, comment #3: 

Thanks, I wasn't aware that's how it is. I didn't know about the alpha.gnu.org site, which looks like an appropriate installer is already there so there is even less reason to build. How often is that updated? Just the once when first creating the alpha release? Aren't there other commits on the stable branch that might not be in the snapshot?

Marshall <marsian>
Fri 13 Apr 2018 09:04:03 PM UTC, comment #2: 

Apologies if my response was a little confusing.

If this is the first time you are build with '--enable-octave=stable', then you might not have realized, but you don't need to run 'make hg-octave-dist'. Just './configure --enable-octave=stable' and 'make', or 'make zip-dist' or 'make nsis-installer', whichever you need.

The 'hg-octave-dist' target is only for building the development version of Octave and isn't needed at all to build the stable release.

I hope that was clearer.

Mike Miller <mtmiller>
Project Administrator
Fri 13 Apr 2018 08:36:08 PM UTC, comment #1: 

The hg-octave-dist target is only supposed to be used with '--enable-octave=default'. So consequently the 'hg-octave-dist' target only builds the default branch from the hg repo.

If you build with '--enable-octave=stable', it will build the 4.3.90 tarball downloaded from alpha.gnu.org.

If you think it should be able to also build a snapshot of the stable branch, that is a new feature request, not a bug.

Mike Miller <mtmiller>
Project Administrator
Fri 13 Apr 2018 08:16:16 PM UTC, original submission:  

I am running "make hg-octave-dist" in a mxe-octave configuration with "enable-octave=stable" (among other config options). It fails at the very end with the build error

make[3]: Entering directory '/home/marshall/mxe-octave/octave-hg-repo/.build'
chmod -R go-w "octave-5.0.0"
find "octave-5.0.0" -type f -perm -100 -exec chmod a+rx {} \;
make[3]: Leaving directory '/home/marshall/mxe-octave/octave-hg-repo/.build'
test -n "" \
|| find "octave-5.0.0" -type d ! -perm -755 \
        -exec chmod u+rwx,go+rx {} \; -o \
  ! -type d ! -perm -444 -links 1 -exec chmod a+r {} \; -o \
  ! -type d ! -perm -400 -exec chmod a+r {} \; -o \
  ! -type d ! -perm -444 -exec /bin/bash /home/marshall/mxe-octave/octave-hg-repo/build-aux/install-sh -c -m a+r {} {} \; \
|| chmod -R a+r "octave-5.0.0"
tardir=octave-5.0.0 && tar --format=ustar -chf - "$tardir" | lzip -c ${LZIP_OPT--9} >octave-5.0.0.tar.lz
tardir=octave-5.0.0 && tar --format=ustar -chf - "$tardir" | XZ_OPT=${XZ_OPT--e} xz -c >octave-5.0.0.tar.xz
tardir=octave-5.0.0 && tar --format=ustar -chf - "$tardir" | GZIP='--best --no-name' gzip -c >octave-5.0.0.tar.gz
make[2]: Leaving directory '/home/marshall/mxe-octave/octave-hg-repo/.build'
if test -d "octave-5.0.0"; then find "octave-5.0.0" -type d ! -perm -200 -exec chmod u+w {} ';' && rm -rf "octave-5.0.0" || { sleep 5 && rm -rf "octave-5.0.0"; }; else :; fi
make[1]: Leaving directory '/home/marshall/mxe-octave/octave-hg-repo/.build'
mv: cannot stat 'octave-4.3.90.tar.lz': No such file or directory
/home/marshall/mxe-octave/hg-octave-dist.mk:34: recipe for target 'hg-octave-dist' failed

I do find octave-5.0.0.tar.* files in "octave-hg-repo/.build", and not the expected 4.3.90 version that I expect to be built. I re-ran from a new clone of mxe-octave and got the same result.

Marshall <marsian>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by lostbard (Posted a comment)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by marsian (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-04-13 mtmiller StatusNeed Info => Invalid
        Open/ClosedOpen => Closed
    2018-04-13 mtmiller Severity3 - Normal => 1 - Wish
        Item GroupBuild Failure => Feature Request
        StatusNone => Need Info
        Summarymake hg-octave-dist confuses octave-5.0.0 and 4.3.90 => mxe-octave: make hg-octave-dist confuses octave-5.0.0 and 4.3.90

    Back to the top


    Powered by Savane 3.5