bugGNU Octave - Bugs: bug #53630, Lines in "Command...

 
 

bug #53630: Lines in "Command Window" and "Editor" Overlapping

Submitted by:  None
Submitted on:  Fri 13 Apr 2018 12:52:28 AM UTC  
 
Category: GUISeverity: 3 - Normal
Priority: 5 - NormalItem Group: Other
Status: InvalidAssigned to: None
Originator Name: Todor Originator Email: -unavailable-
Open/Closed: ClosedRelease: 4.2.2
Operating System: GNU/Linux

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Tue 17 Apr 2018 03:50:59 PM UTC, comment #11:

This seems to be all upstream bugs, or badly designed font selectors that can't find a fallback to "Courier New" if it is not installed.

I'm going to close this report as an upstream issue.

Rik <rik5>
Project Administrator
Tue 17 Apr 2018 12:58:02 AM UTC, comment #10:

So does this problem only affect users with Nvidia graphics? Has anyone confirmed whether removing the 'appmenu-qt5' package fixes the problem with the menu bar?

Mike Miller <mtmiller>
Project Administrator
Sat 14 Apr 2018 03:33:31 PM UTC, comment #9:

There is no problem with the display in the Command Window or the Editor with the following video display hardware. Same version of Ubuntu on both systems (as in comment #1) with Qt 5 installed. Octave 4.2.2 was upgraded from 4.2.1 from the ppa on both systems. The only difference appears to be the graphics hardware.
peregrine: sudo lshw -c video
*-display
description: VGA compatible controller
product: RS880 [Radeon HD 4250]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 5
bus info: pci@0000:01:05.0
version: 00
width: 32 bits
clock: 33MHz
capabilities: pm msi vga_controller bus_master cap_list rom
configuration: driver=radeon latency=0
resources: irq:18 memory:d0000000-dfffffff ioport:d000(size=256) memory:feaf0000-feafffff memory:fe900000-fe9fffff memory:c0000-dffff

Carl Greco <cgreco>
Sat 14 Apr 2018 12:15:09 AM UTC, comment #8:

Ok, if this is about the ppa update from 4.2.1 to 4.2.2, then the bigger and more relevant change is probably that Octave is now built against Qt 5 instead of Qt 4.

I think the reason for your missing menu bar is https://bugs.launchpad.net/bugs/1307619, not an Octave bug. Does uninstalling the 'appmenu-qt5' package fix the problem for you?

If changing the font works for everyone concerned with this bug, and uninstalling 'appmenu-qt5' fixes the missing menu problem, can we call this resolved?

Mike Miller <mtmiller>
Project Administrator
Fri 13 Apr 2018 11:24:07 PM UTC, comment #7:

Had exactly this issue on two machines both updated from ppa:octave/stable.

One box is running Lubuntu 14.04 LTS 32 bit, second box running Lubuntu 16.04 LTS 64 bit.

I could see the menu bar on the 64 bit box and was able to get to the preferences where changing the default font to something other than Courier New did the trick.

Anonymous
Fri 13 Apr 2018 06:24:16 PM UTC, comment #6:

It would be helpful to know if either or both of you (anonymous OP and Carl Greco) are building Octave 4.2.2 yourself or installing it from packages in the ppa:octave/stable that I just updated to 4.2.2 less than 24 hours ago.

Mike Miller <mtmiller>
Project Administrator
Fri 13 Apr 2018 06:18:21 PM UTC, comment #5:

Oh, I see what was meant now. The phenomenon is happening in both the Command Window and the Editor. Well, in the Mageia case I've shown, the font in the Command Window is shrunk and oddly distorted, so this could be the some root cause with different manifestation on different systems. For example, the leading (i.e., line-spacing) could be the same but in Mageia/nuveau some kind of crude resampling is done on the font while in Ubuntu no resampling is done, just print the font which results in overlap.

Dan Sebald <sebald>
Fri 13 Apr 2018 06:10:07 PM UTC, comment #4:

The screenshot link I posted for Mageia 6 came from the stable branch head, I think (or default). That was KDE, I have an Nvidia card, but the driver I believe in action was Nuveau.

I'm not understanding a portion of the original post. Is the expectation that Editor is not supposed to be in the same tab stack as Command Window? By default? Octave settings are supposed to remember what the most recent configuration was at exit.

Dan Sebald <sebald>
Fri 13 Apr 2018 06:01:50 PM UTC, comment #3:

4.2.2 is about to be deprecated. You might want to try the 4.4.0 release candidate which will become the new stable release within the next week or so. The release candidate is available as source code at ftp://alpha.gnu.org/gnu/octave/octave-4.3.90.tar.lz

Rik <rik5>
Project Administrator
Fri 13 Apr 2018 05:59:56 PM UTC, comment #2:

Oh, other's are seeing this too. I thought this was something to do with Mageia when I was looking at another bug. Here's a screen shot from Bug #53276:

https://savannah.gnu.org/bugs/download.php?file_id=43844

Note where I annotated "tiny wrong font". The peculiar font is in the Command Window and in the Variable Editor as well, if one looks closely.

Dan Sebald <sebald>
Fri 13 Apr 2018 01:48:34 PM UTC, comment #1:

Same issue. See attached file.
System info.

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.4 LTS
Release: 16.04
Codename: xenial

NVIDIA binary driver version 390.48
sudo lshw -c video
*-display
description: VGA compatible controller
product: GF108 [GeForce GT 620]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:49 memory:fd000000-fdffffff memory:f0000000-f7ffffff memory:f8000000-f9ffffff ioport:e000(size=128) memory:c0000-dffff

(file #43913)

Carl Greco <cgreco>
Fri 13 Apr 2018 12:52:28 AM UTC, original submission:

After update from 4.2.1, lines in the "Command Window" and "Editor" are overlapping. Check attached images.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #43913:  Selection_142.png added by cgreco (135KiB - image/png)
file #43907:  octave422_gui_problem_editor.png added by None (174KiB - image/png)
file #43908:  octave422_gui_problem.png added by None (166KiB - image/png)

 

Depends on the following items: None found

Digest:
   bug dependencies.

 

Carbon-Copy List
  • -unavailable- added by mtmiller (Posted a comment)
  • -unavailable- added by rik5 (Posted a comment)
  • -unavailable- added by sebald (Posted a comment)
  • -unavailable- added by cgreco (Updated the item)
  • -unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 7 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue 17 Apr 2018 03:50:59 PM UTCrik5StatusNeed Info=>Invalid
      Open/ClosedOpen=>Closed
    Sat 14 Apr 2018 12:16:21 AM UTCmtmillerDependencies-=>bugs #53633 is dependent
    Sat 14 Apr 2018 12:15:09 AM UTCmtmillerStatusNone=>Need Info
    Fri 13 Apr 2018 01:48:34 PM UTCcgrecoAttached File-=>Added Selection_142.png, #43913
    Fri 13 Apr 2018 12:52:28 AM UTCNoneAttached File-=>Added octave422_gui_problem_editor.png, #43907
      Attached File-=>Added octave422_gui_problem.png, #43908

    Back to the top


    Powered by Savane 3.1-cleanup1