bugGNU Octave - Bugs: bug #53389, Allow environment variable...

 
 

bug #53389: Allow environment variable JAVA_HOME to override registry location of JRE on Windows

Submitted by:  None
Submitted on:  Tue 20 Mar 2018 11:50:56 AM UTC  
 
Category:  Configuration and Build System Severity:  2 - Minor
Priority:  5 - Normal Item Group:  Feature Request
Status:  Duplicate Assigned to:  None
Originator Name:  Friedrich Melchert Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  dev
Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 05 Aug 2018 10:41:05 PM UTC, comment #4: 

This should be fixed with the patch for bug #40111.

Closing as a duplicate.

Markus M├╝tzel <mmuetzel>
Project Member
Tue 20 Mar 2018 10:42:51 PM UTC, comment #3: 

JAVA_HOME is a good idea insofar as on Windows this setting is ignored AFAIK and in any case not present on Windows PCs at my home and at work.

However maybe we should care for possible other SW out there that might use JAVA_HOME for similar or different purposes, like expecting it to point to the "standard" Java (e.g., SW that cannot read the registry).
Having this setting in Octave's underlying cmd shell invocation rather than as a global setting might be polite.

Philip Nienhuis <philipnienhuis>
Project Member
Tue 20 Mar 2018 06:21:13 PM UTC, comment #2: 

I agree that this would be a very useful feature. Let's constrain this bug report to being about the Windows implementation, since it is very separate from the GNU/Linux implementation. See bug #40111 for the equivalent task for GNU/Linux systems.

This is a good idea, but I would prefer that we not invent a new environment variable for the purpose. It would be extremely helpful if this patch could be rewritten to use the standard JAVA_HOME environment variable, which is expected to point to the root directory of the Java installation.

Mike Miller <mtmiller>
Project Administrator
Tue 20 Mar 2018 06:14:53 PM UTC, comment #1: 

AFAIK Octave has no provisions yet for specifying a specific JVM on any operating system; that bites esp. on Linux where the path to the libjvm.so gets hard-coded in Octave, so any Java upgrade by  e.g. a distro package manager means upgrading or rebuilding Octave.

Just meaning that you're not alone.

Philip Nienhuis <philipnienhuis>
Project Member
Tue 20 Mar 2018 11:50:56 AM UTC, original submission:  

The original scenario is a portable installation of Octave on Windows.
Unlike other software (i.e. Eclipse Portable) Octave does not provide any way to specify an alternative JVM as the one specified in the WINDOWS Registry key
HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment

An option to use an Environment variable specifying the path to a certain jvm.dll, that is queried before the registry key, would solve the issue.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #43601:  ov-java.cc.diff added by None (1023B - application/octet-stream - Possible implementation)

 

Carbon-Copy List
  • -email is unavailable- added by mmuetzel (Posted a comment)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 9 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-08-05 mmuetzel StatusConfirmed => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #40111
    2018-04-04 rik5 Dependencies- => bugs #53520 is dependent
    2018-03-22 mtmiller Severity3 - Normal => 2 - Minor
        Release4.2.2 => dev
        SummaryUse of JVM other than specified in Windows Registry => Allow environment variable JAVA_HOME to override registry location of JRE on Windows
    2018-03-20 philipnienhuis StatusNone => Confirmed
    2018-03-20 None Attached File- => Added ov-java.cc.diff, #43601

    Back to the top


    Powered by Savane 3.5