bugGNU Octave - Bugs: bug #52069, delete (<filename>) or...

 
 

bug #52069: delete (<filename>) or unlink (<filename>) crashes GUI on Windows

Submitted by:  Philip Nienhuis <philipnienhuis>
Submitted on:  Wed 20 Sep 2017 09:29:54 AM UTC  
 
Category:  Octave Function Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Duplicate Assigned to:  None
Originator Name:  philipnienhuis Open/Closed:  Closed
Release:  dev Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Fri 22 Sep 2017 03:08:03 PM UTC, comment #13: 

Yes, this bug report can be closed now as duplicate of bug #43922.

Torsten Lilge <ttl>
Project Member
Fri 22 Sep 2017 11:24:51 AM UTC, comment #12: 

@Torsten

Thank you.

Shall we continue the discussion in bug #43922 ? As that is where the cset was meant for.

If you agree I'll set this bug's status to "duplicate", add a dependency on bug 43922 and close this report.

Philip Nienhuis <philipnienhuis>
Project Member
Fri 22 Sep 2017 08:02:41 AM UTC, comment #11: 

Still existing.

It feels like Qt doesn't release a handle to the file so that (some other thread in) Octave cannot move/delete it.

Philip Nienhuis <philipnienhuis>
Project Member
Fri 22 Sep 2017 03:27:26 AM UTC, comment #10: 

Backed out with cset
http://hg.savannah.gnu.org/hgweb/octave/rev/0052d47ddc3e

When octave crashes, was the file already removed or still existing?

Torsten Lilge <ttl>
Project Member
Thu 21 Sep 2017 04:06:28 PM UTC, comment #9: 

Torsten, will you backout the cset?

In the mean time, if you can come up with alternative csets for bug #43922 I can easily test then.

I've optimized my cross-build setup; I only cross-build Octave itself, occasionally also the OF packages when I need an installer on other systems.

I have a multiboot system where I cross-build on Linux and interrupt that just before it generates the installer (zip or dist).
At that time a complete Octave installation is present in .../mxe-octave/dist/octave-<date> that I can easily access from Windows (after rebooting) by executing octave.vbs in that subdir (I use ext2fsd for mounting linux partitions in Windows).
That saves me about 15-20 mins for (1) generating the installer and (2) wiping and re-installing on Windows.

Philip Nienhuis <philipnienhuis>
Project Member
Thu 21 Sep 2017 05:05:29 AM UTC, comment #8: 

Confirmed.  I don't have a problem if I use the CLI version on Wndosws, only the GUI.

Rik <rik5>
Project Administrator
Thu 21 Sep 2017 04:01:21 AM UTC, comment #7: 

What is the best way to proceed here? Due to the long turn around cycles for testing mxe builds it will take me some time to fix this. I therefore suggest to backout the related changeset.

Torsten Lilge <ttl>
Project Member
Wed 20 Sep 2017 07:28:59 PM UTC, comment #6: 

Indeed, backing out
http://hg.savannah.gnu.org/hgweb/octave/rev/ba164db1c4a4
fixes this issue.

cc'ing Torsten.

Philip Nienhuis <philipnienhuis>
Project Member
Wed 20 Sep 2017 03:58:14 PM UTC, comment #5: 

Hartmut,

In the CLI it all works fine.
The GUI crashes.

I'll add a comment in bug #43922

Philip Nienhuis <philipnienhuis>
Project Member
Wed 20 Sep 2017 03:52:57 PM UTC, comment #4: 

? Could be. Good hint

I'll try with backing out that fix & rebuilding. Hopefully I'll manage to do that tonight.

Philip Nienhuis <philipnienhuis>
Project Member
Wed 20 Sep 2017 02:58:54 PM UTC, comment #3: 

Is this a side effect of the recent changes for bug #43922 ?

Hartmut <hardy>
Wed 20 Sep 2017 09:45:04 AM UTC, comment #2: 

Crash also happens with the function rmdir

Philip Nienhuis <philipnienhuis>
Project Member
Wed 20 Sep 2017 09:34:16 AM UTC, comment #1: 

system ("del <filename>)

works fine, and next calling delete on the file gives the proper error message:

debug>
warning: delete: no such file: io-test.xls

Philip Nienhuis <philipnienhuis>
Project Member
Wed 20 Sep 2017 09:29:54 AM UTC, original submission:  

Calling delete or unlink to wipe a file from disk leads to a hard crash.

hg id 8a6747c6db1a, built for Windows 64b

Philip Nienhuis <philipnienhuis>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by philipnienhuis
  • -email is unavailable- added by mtmiller (Updated the item)
  • -email is unavailable- added by hardy (Posted a comment)
  • -email is unavailable- added by philipnienhuis (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 8 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2017-09-22 ttl StatusConfirmed => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #43922
    2017-09-21 mtmiller Summary[MXE] delete (<filename>) or unlink (<filename>) leads to crash => delete (<filename>) or unlink (<filename>) crashes GUI on Windows
    2017-09-21 rik5 StatusNone => Confirmed
        Summarydelete (<filename>) or unlink (<filename>) crashes GUI on Windows => [MXE] delete (<filename>) or unlink (<filename>) leads to crash
    2017-09-20 philipnienhuis Carbon-Copy- => Added ttl
    2017-09-20 mtmiller Summary[MXE] delete (<filename>) or unlink (<filename>) leads to crash => delete (<filename>) or unlink (<filename>) crashes GUI on Windows

    Back to the top


    Powered by Savane 3.5