bugGNU Octave - Bugs: bug #51398, 'pkg update' fails as first...

 
 

bug #51398: 'pkg update' fails as first instruction in a fresh instalation

Submitted by:  Denis J Navas <djnavas>
Submitted on:  Thu 06 Jul 2017 03:30:30 AM UTC  
 
Category: Configuration and Build SystemSeverity: 3 - Normal
Priority: 5 - NormalItem Group: Installation Failure
Status: Works For MeAssigned to: None
Originator Name: Denis J NavasOpen/Closed: Closed
Release: 4.2.1Operating System: Microsoft Windows

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Tue 10 Oct 2017 01:40:25 AM UTC, comment #8:

Ok

Denis J Navas <djnavas>
Sun 08 Oct 2017 08:12:40 PM UTC, comment #7:

I've closed this because no one else has been able to reproduce this and there has been no progress in identifying if it can be reproduced on another system or if it's unique to something about your system. I don't have access to any Windows system to test or else I would try this myself.

Quite a few people have jumped on this bug report to say that they cannot reproduce it, and no one else has confirmed this behavior yet. I'm sorry to say, but it's up to you to either find the reason for this bug on your system or find another system or another developer that can help you find the cause and fix it.

As it is, there is nothing in this bug report that any Octave developers can act on without more information. So if this is important to you, please keep investigating, or consider asking for help or hiring someone to help you.

Mike Miller <mtmiller>
Project Administrator
Sun 08 Oct 2017 07:37:49 PM UTC, comment #6:

Until now have an announcement.

Octave 4.2.1 never listed or updated the pkg list, and I have not a clue of what's going on. Maxima can't run too, which make me think that Microsoft has changed something to forbid the execution of something, that I suposose are the bat and cmd files.

You don't need to change the status, because as you say, "It works for me", that I supose it means you, but not me.

Denis J Navas <djnavas>
Sun 08 Oct 2017 04:13:29 PM UTC, comment #5:

No response or further information in several months, assuming this can be closed with status "works for me".

Mike Miller <mtmiller>
Project Administrator
Fri 07 Jul 2017 11:59:38 AM UTC, comment #4:

The 1.1 is the DOS 8.3 short version of the path name so is correct.

If you rerun pkg update does it work?

For pkg list, try running "pkg rebuild" first and see if that populates the list.

John Donoghue <lostbard>
Project Member
Fri 07 Jul 2017 03:13:27 AM UTC, comment #3:

Found a probable source of the problem with the path variable.
Octave version is not 1.1 but 4.2.1!

>> getenv ("PATH")

ans = C:\FOSS\OCTAVE~1.1\bin;C:\Program Files\ATI Technologies\ATI.ACE\Core-Static;
.
.
.
C:\FOSS\OCTAVE~1.1\bin;C:\FOSS\OCTAVE~1.1\notepad++;C:\FOSS\OCTAVE~1.1\libexec\octav
e\4.2.1\site\exec\i686-w64-mingw32;C:\FOSS\OCTAVE~1.1\libexec\octave\api-v51\site\exec
\i686-w64-mingw32;C:\FOSS\OCTAVE~1.1\libexec\octave\site\exec\i686-w64-mingw32;C:\FOSS
\OCTAVE~1.1\libexec\octave\4.2.1\exec\i686-w64-mingw32;C:\FOSS\OCTAVE~1.1\bin

Denis J Navas <djnavas>
Fri 07 Jul 2017 12:34:46 AM UTC, comment #2:

The installer is "octave-4.2.1-w32-installer.exe"
My machine is 32 bits, use Windows 7 starter, Service Pack 1.
Octave is installed in "C:\FOSS\Octave-4.2.1"
All the windows updates are applied.
Was installed as an aplication for multiple users.
I am the only user registered as administrator in this machine.

The update process asked for "dicom-0.2.0" but the software only has "C:\FOSS\Octave-4.2.1\share\octave\packages\dicom-0.1.1", therefore I downloade it and placed in my working directory, in "C:\Users\Denis\Documents\Octave".

The user path variable has been set to "C:\FOSS\Octave-4.2.1".
The installer does not set any path, system or user variable.

Also, "pkg list" reports nothing.

When I wrote, "fails as first instruction" I mean that the first run after installation, I inmediatly ran pkg update without any prior command before.

Denis J Navas <djnavas>
Thu 06 Jul 2017 03:04:15 PM UTC, comment #1:

Hi,

I tried a fresh install and do not see the issue occuring.

Was octave installed via the installer, or zip file, and 32 or 64 bit version?

The title says 'fails as first instruction', deoes that mean when you reran the command it worked?

John Donoghue <lostbard>
Project Member
Thu 06 Jul 2017 03:30:30 AM UTC, original submission:

Here is the error message:

>> pkg update

system: unable to start subprocess for '"gzip -d -c "C:\Users\Denis\Documents\Octave\dicom-0.2.0.tar.gz" | tar xf - 2>&1"'
error: called from
unpack at line 245 column 20
untar at line 47 column 5
install at line 81 column 9
pkg at line 394 column 9
pkg at line 552 column 11

GNU Octave, version 4.2.1
Windows 7 SP 1, starter edition.
Installed for all users.

Denis J Navas <djnavas>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by mtmiller (Posted a comment)
  • -unavailable- added by lostbard (Posted a comment)
  • -unavailable- added by djnavas (Submitted the item)
  • -unavailable- added by djnavas (I checked and did not see it reported.)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 08 Oct 2017 04:13:29 PM UTCmtmillerStatusNeed Info=>Works For Me
      Open/ClosedOpen=>Closed
    Thu 06 Jul 2017 03:04:15 PM UTClostbardStatusNone=>Need Info
    Thu 06 Jul 2017 03:30:30 AM UTCdjnavasCarbon-Copy-=>Added djnavas

    Back to the top


    Powered by Savane 3.1-cleanup1