bugGNU Octave - Bugs: bug #50284, Unable to type or paste non-ASCII...

 
 

bug #50284: Unable to type or paste non-ASCII characters into the terminal window

Submitted by:  Mingye Wang <arthur2e5>
Submitted on:  Sun 12 Feb 2017 03:40:53 AM UTC  
 
Category: GUISeverity: 3 - Normal
Priority: 5 - NormalItem Group: Feature Request
Status: DuplicateAssigned to: None
Originator Name: Open/Closed: Closed
Release: 4.2.0Operating System: Microsoft Windows

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Wed 05 Apr 2017 08:33:50 AM UTC, comment #8:

Adding bug #50404 as a dependency and closing as duplicate of bug #47571.

Markus Mützel <mmuetzel>
Project Member
Tue 04 Apr 2017 09:27:08 PM UTC, comment #7:

I agree that it is a duplicate of #47571. The wrapping problem should be dealt with in #50404, I guess.

Mingye Wang <arthur2e5>
Tue 04 Apr 2017 08:10:34 PM UTC, comment #6:

I think this is now a duplicate of bug #47571. Adding a dependency to that report.

We also could re-purpose this bug report for the issue you mentioned in comment #2: "writing and running a function that returns a UTF-8 string with multicolumn (East Asian Width, etc.) characters would ruin the terminal window's alignment".

However, I cannot re-produce that. Could you please attach a screenshot? (Or point to the bug report in case you already opened one dedicated to that issue.)

Markus Mützel <mmuetzel>
Project Member
Sun 26 Feb 2017 03:40:27 PM UTC, comment #5:

I changed the title according to your suggestion.

I can confirm that behaviour. The same happens when trying to enter an umlaut (e.g. ä) which has a dedicated key or a composed character (e.g. é) which is entered by the accent key followed by the base key on a German keyboard layout.
Copy-pasting also doesn't work. I tried pasting the following to the CLI or GUI:

Only the following is actually pasted:

Markus Mützel <mmuetzel>
Project Member
Sun 26 Feb 2017 02:35:10 PM UTC, comment #4:

I am running it on Windows 10, hence the ability to see the "in addition to that" problem.

The mojibake in my old report happens in 4.0.0, so I guess it is really no longer the case. In the last comment I (sort of) shifted the complaint to copy/paste filtering. Is "Unable to type or paste non-ASCII characters into the terminal window" a good title?

Mingye Wang <arthur2e5>
Sun 26 Feb 2017 10:05:31 AM UTC, comment #3:

What version of Windows do you use? If I remember correctly, UTF-8 support was non-existant in Windows XP, incomplete in Windows 7 (and maybe also in Windows 8) and did not work correctly before Windows 10.
The command window in Octave is basicly the Windows command prompt and (at least for the time being) we have to live with its limitations.

What do you want the title changed to?

Markus Mützel <mmuetzel>
Project Member
Sat 25 Feb 2017 11:40:59 PM UTC, comment #2:

With system('chcp') I verified that Octave is indeed running under 65001.

Still, something in the terminal emulator is filtering out non-ASCII characters even on copy-paste. (Test input is "Déjà vu") Is there any way to retitle an issue?

In addition to that, writing and running a function that returns a UTF-8 string with multicolumn (East Asian Width, etc.) characters would ruin the terminal window's alignment. (Test input is something that returns "世界".) This one should be reported as a separate

Mingye Wang <arthur2e5>
Sat 25 Feb 2017 08:49:36 PM UTC, comment #1:

How do you execute Octave? GUI or CLI?
The GUI should be using cp65001 by default.

I can confirm that the CLI uses the system code page.
You can change that manually by executing the following line at the Octave command line:

Does that work around your problem? If yes, you might consider adding that line to your ".octaverc" file until this is properly fixed in Octave.

Markus Mützel <mmuetzel>
Project Member
Sun 12 Feb 2017 03:40:53 AM UTC, original submission:

Unicode support is becoming increasing useful as writers of certain Octave packages (like, well, "symbolic") start to use Unicode mathematical symbols in its help text as well as for output. However, since Octave currently seems to use the current system code page as opposed to cp65001 (Windows UTF-8) for output, it may display unreadable mojibake (bug #50283, pre-regression) for such characters.

(No luck with SetLocale in the launcher VBS. Running chcp 65001 before spawning the VBS does not work either.)

See also bug #49685.

Mingye Wang <arthur2e5>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by mmuetzel (Posted a comment)
  • -unavailable- added by arthur2e5 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 7 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 05 Apr 2017 08:33:50 AM UTCmmuetzelStatusNeed Info=>Duplicate
      Open/ClosedOpen=>Closed
      Dependencies-=>Depends on bugs #50404
    Tue 04 Apr 2017 08:10:34 PM UTCmmuetzelStatusConfirmed=>Need Info
      Dependencies-=>Depends on bugs #47571
    Sun 26 Feb 2017 03:40:27 PM UTCmmuetzelStatusNone=>Confirmed
      SummaryAllow using UTF-8 for Command Window on Windows=>Unable to type or paste non-ASCII characters into the terminal window

    Back to the top


    Powered by Savane 3.1-cleanup1