bugGNU Octave - Bugs: bug #49464, support for audio playback and...

 
 

bug #49464: support for audio playback and recording through PortAudio was unavailable or disabled when Octave was built

Submitted by:  zhangmuzhi <chard>
Submitted on:  Fri 28 Oct 2016 03:50:08 AM UTC  
 
Category:  Libraries Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  Invalid Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  4.2.0-rc2 Operating System:  Mac OS

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri 28 Oct 2016 12:52:32 PM UTC, comment #5: 

Thank you very much for your recommendation.And I have solved this problem.For octave I'm a new hand,I wonder that if octave support video just like matlab ?Can you give me some advice or reference?

zhangmuzhi <chard>
Fri 28 Oct 2016 06:32:55 AM UTC, comment #4: 

You can check the install options with "brew info octave" and you will find (among other options):

--with-portaudio
Use portaudio for audio playback and recording

so

"brew install octave --with-portaudio"

should give you portaudio support. You may also want to use " --with-sndfile". However, both options are not extremely well tested on macOS (at least not by me).

Seb.

Sebastian <sschoeps>
Fri 28 Oct 2016 06:22:17 AM UTC, comment #3: 

That's a question for the homebrew maintainers, cc sschoeps, see https://github.com/Homebrew/homebrew-science/.

Mike Miller <mtmiller>
Project Administrator
Fri 28 Oct 2016 06:08:59 AM UTC, comment #2: 

I installed octave from homebrew and I don't know how to enable it

zhangmuzhi <chard>
Fri 28 Oct 2016 05:20:47 AM UTC, comment #1: 

This is not a bug, this is a message telling you how Octave was configured. If you built Octave yourself from source, then you should make sure that the PortAudio library is installed on your system before running configure. If you installed octave from a packaging system (e.g. homebrew or macports), then you should check with the packaging team to see if there is an option to enable PortAudio or ask them to add it as a dependency.

Mike Miller <mtmiller>
Project Administrator
Fri 28 Oct 2016 03:50:08 AM UTC, original submission:  

octave:3> soundsc(a)
error: _player_audioplayer_: support for audio playback and recording through PortAudio was unavailable or disabled when Octave was built
error: called from
    audioplayer at line 105 column 19
    soundsc at line 90 column 8

zhangmuzhi <chard>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by sschoeps (Posted a comment)
  • -email is unavailable- added by mtmiller
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by chard (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-10-28 mtmiller Carbon-Copy- => Added sschoeps
    2016-10-28 mtmiller StatusNone => Invalid
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.5