bugGNU Octave - Bugs: bug #49265, octave-gui freezes when displaying...

 
 

bug #49265: octave-gui freezes when displaying large outputs

Submitted by:  None
Submitted on:  Tue 04 Oct 2016 10:28:45 AM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Duplicate Assigned to:  None
Originator Name:  TB@DH Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  4.0.3
Operating System:  Mac OS

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 05 Oct 2016 01:51:38 PM UTC, comment #4: 

I'll close this report as a duplicate of bug #49051. Tullio can you post any further comment there.

The OP there also says "Pretty sure that this was working a few days back out-of-the-box". So investigating what triggers the appearance of this bug after installation my give us a clue.

Pantxo Diribarne <pantxo>
Project Member
Wed 05 Oct 2016 01:43:27 PM UTC, comment #3: 

@Tullio:
You must send your answer directly from the bug tracker interface or it won't appear in the list of comments.

>> Thanks guys,
>>I've seen the same solution pointed out in the thread Dan pointed to. I see however no .octaverc file in my home (or elsewhere). Should I just create one?
>>Cheers


Yes, see https://www.gnu.org/software/octave/doc/interpreter/Startup-Files.html#Startup-Files for further details on startup scripts.

Pantxo Diribarne <pantxo>
Project Member
Tue 04 Oct 2016 06:48:53 PM UTC, comment #2: 

Turning off the pager avoids the problem, but not using the pager isn't so good for very large outputs.  Displaying all that data takes quite a while, whereas pager is immediately available and searchable.

Version 4.0.3 and Mac OS is going to be hard to investigate.  I'd say the first thing would be to get the most up-to-date software and do a build.  But I know this isn't the easiest thing to do:

https://savannah.gnu.org/bugs/?49051
http://wiki.octave.org/Octave_for_MacOS_X

Dan Sebald <sebald>
Tue 04 Oct 2016 11:08:42 AM UTC, comment #1: 

I have no idea what may be going wrong. There is a simple workaround though, you just need to disable the pager. Add the following to your startup script (e.g. "~/.octaverc"):

more off

Pantxo Diribarne <pantxo>
Project Member
Tue 04 Oct 2016 10:28:45 AM UTC, original submission:  

I installed octave-gui yesterday, and I'm getting this quite often: when printing large outputs to the command window, the line

-- less -- (f)orward, (b)ack, (q)uit

doesn't respond interactively to the input: hitting any of the keys just prints the corresponding letter on the command window, rather than e.g. quitting displaying and continuing with the rest of the script. Force quitting octave seems to be the only way to get out of this.

Oddly enough, the problem disappears for a while if I delete and reinstall the application, to pop up again shortly afterwards. And when it's working "properly", a

warning: broken pipe

message appears after hitting q to interrupt the output.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by sebald (Posted a comment)
  • -email is unavailable- added by pantxo (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-10-05 pantxo StatusNone => Duplicate
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.5