bugGNU Octave - Bugs: bug #49191, working directory spoiled after...

 
 

bug #49191: working directory spoiled after run of mkoctfile

Submitted by:  Georg Michel <georgmichel>
Submitted on:  Mon 26 Sep 2016 02:35:28 PM UTC  
 
Category:  Interpreter Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Duplicate Assigned to:  None
Originator Name:  Georg Michel Open/Closed:  Closed
Release:  4.2.0-rc2 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 27 Sep 2016 05:45:01 PM UTC, comment #4: 

Thanks, this looks the same as bug #49184 that I pointed you to. The current directory is removed from the load path after changing to a directory that has been added to the path. Closing as a duplicate.

Mike Miller <mtmiller>
Project Administrator
Tue 27 Sep 2016 08:14:20 AM UTC, comment #3: 

Hi,

I have narrowed down the problem. It is not related to mkoctfile. The attached files hello1.m hello2.m and hello3.m demonstrate the bug. Put hello1.m and hello3.m in some directory and hello2.m in the directory ../test2

Then call hello1.m. On OpenSUSE 42.1 I see the following output:

octave:1> hello1
This is hello1 in /home/georg/test1
1st call to hello3 in /home/georg/test1
This is hello3 in /home/georg/test1
This is hello2 in /home/georg/test2
2nd call to hello3 in /home/georg/test1
error: 'hello3' undefined near line 7 column 1
error: called from
    hello1 at line 7 column 1
octave:1>

(file #38604, file #38605, file #38606)

Georg Michel <georgmichel>
Mon 26 Sep 2016 06:41:14 PM UTC, comment #2: 

Can you take a look at bug #49184 and see if it fully describes the same situation you are seeing?

Mike Miller <mtmiller>
Project Administrator
Mon 26 Sep 2016 06:23:44 PM UTC, comment #1: 

Thanks for your bug report. Can you show a complete example demonstrating this effect? I am unable to reproduce it. I have tried compiling an oct file in the current directory as well as a different directory, either in or out of the load path, and scripts in the current directory continue to work.

In addition to a complete session example, it would be helpful to show what pwd and path show before and after this happens.

Mike Miller <mtmiller>
Project Administrator
Mon 26 Sep 2016 02:35:28 PM UTC, original submission:  

When Octave is pointed to a working directory, it finds the scripts in this directory as expected. However, after an (error free) run of mkoctfile and a call to the just compiled function (in another but known directory), Octave does not find the scripts in the working directory anymore. Even with cd and pwd showing the correct working directory, the scripts there are not found. The only solution that works for me is a restart after the compilation. Then no new compilation is necessary and everything works as expected.

The whole thing appears under OpenSUSE Leap 42.1 with 4.2.0-rc2. With 4.0.0 it is OK.

Georg Michel <georgmichel>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #38604:  hello1.m added by georgmichel (173B - application/octet-stream)
file #38605:  hello3.m added by georgmichel (38B - application/octet-stream)
file #38606:  hello2.m added by georgmichel (344B - application/octet-stream)

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by georgmichel (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-09-27 mtmiller StatusWorks For Me => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #49184
    2016-09-27 georgmichel Attached File- => Added hello1.m, #38604
        Attached File- => Added hello3.m, #38605
        Attached File- => Added hello2.m, #38606
    2016-09-26 mtmiller StatusNone => Works For Me

    Back to the top


    Powered by Savane 3.5