bugGNU Octave - Bugs: bug #47555, Segmentation violation after...

 
 

bug #47555: Segmentation violation after "runtests" mxe-octave 64bit

Submitted by:  Tatsuro MATSUOKA <tmacchant>
Submitted on:  Mon 28 Mar 2016 05:33:33 AM UTC  
 
Category:  Interpreter Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Duplicate Assigned to:  None
Originator Name:  Tatsuro MATUOKA Open/Closed:  Closed
Release:  4.0.1 Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 28 Mar 2016 10:37:57 AM UTC, comment #3: 

OK. I understand the situation. Please mark this report as duplicated.

Tatsuro MATSUOKA <tmacchant>
Mon 28 Mar 2016 10:35:42 AM UTC, comment #2: 

Isn't this just the "normal" segmentation fault

  • running under Windows
  • after using any image related command (e.g. imread, as the test suite does)
  • that happens when shutting Octave down ?

I see this happen under Windows 7 with the official (32bit) 4.0.1 release as well.

I think is is discussed in bug #41699 and lately also in bug #47372. (In comment #12 of bug #47372 is a small patch from Rik that solves this issue for me.)

Hartmut <hardy>
Mon 28 Mar 2016 10:34:04 AM UTC, comment #1: 

This is probally the a duplicate of #41699 and effects win32 and win64

John Donoghue <lostbard>
Project Member
Mon 28 Mar 2016 05:33:33 AM UTC, original submission:  

After runtest and exit octave causes Segmentation violation.

>> runtests
(rutests results)

>> exit

panic: Segmentation violation -- stopping myself...
attempting to save variables to 'octave-workspace'...
save to 'octave-workspace' complete

gdb backtrace and octave-workspace does not give useful information.

I cannot narrow down the issue so that what is a trigger.

Tatsuro MATSUOKA <tmacchant>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Updated the item)
  • -email is unavailable- added by hardy (Posted a comment)
  • -email is unavailable- added by lostbard (Posted a comment)
  • -email is unavailable- added by tmacchant (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-03-28 mtmiller Dependencies- => Depends on bugs #41699
    2016-03-28 mtmiller StatusNone => Duplicate
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.5