bugGNU Octave - Bugs: bug #44874, QT5 and QT4 build collision

 
 

bug #44874: QT5 and QT4 build collision

Submitted by:  marco atzeri <matzeri>
Submitted on:  Sat 18 Apr 2015 07:12:25 PM UTC  
 
Category:  Configuration and Build System Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Build Failure
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  4.0.0 Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 02 Jun 2015 04:46:25 PM UTC, comment #4: 

Retagging release from 4.0.0-rc3 to 4.0.0.

John W. Eaton <jwe>
Project Administrator
Sat 18 Apr 2015 08:22:53 PM UTC, comment #3: 

Yes, both the configure script and code, and possibly the makefiles, will need to be updated to work with Qt5. See bug #40252 about porting Octave to Qt5 and allowing it to build with either. I made a first attempt to update the libgui directory to build against both Qt4 and Qt5, but haven't tackled the configure script yet.

I don't think there's anything different about this bug report, closing as a duplicate, but please correct me if I'm wrong and there is a reason to keep this open as a separate report.

Mike Miller <mtmiller>
Project Administrator
Sat 18 Apr 2015 08:08:42 PM UTC, comment #2: 

This point of configure.ac

  ## Check for Qt libraries
  QT_MODULES="QtCore QtGui QtNetwork QtOpenGL"
  PKG_CHECK_MODULES(QT, [$QT_MODULES],

will only detect the QT4 modules.
The equivalent ones on QT5 (at least on cygwin) are

  QT_MODULES="Qt5Core Qt5Gui Qt5Network Qt5OpenGL"

marco atzeri <matzeri>
Sat 18 Apr 2015 07:19:25 PM UTC, comment #1: 

This fails on Fedora 21 also. Not in quite the same
way. The problem is if qt5 include files are present
the build crashes since it does not find the expected
header files.

Michael Godfrey <godfrey>
Project Member
Sat 18 Apr 2015 07:12:25 PM UTC, original submission:  

On cygwin 64 bit.
Both QT5 and QT4 devel headers are available:

make[2]: Entering directory '/cygdrive/e/cyg_pub/devel/octave/octave-4.0.0rc3-1.x86_64/build/libgui'
make  all-am
make[3]: Entering directory '/cygdrive/e/cyg_pub/devel/octave/octave-4.0.0rc3-1.x86_64/build/libgui'
  CXX      src/src_libgui_src_la-settings-dialog.lo
In file included from /pub/devel/octave/octave-4.0.0rc3-1.x86_64/src/octave-4.0.0-rc3/libgui/src/settings-dialog.cc:31:0:
src/ui-settings-dialog.h:13:29: fatal error: QtWidgets/QAction: No such file or directory
 #include <QtWidgets/QAction>
                             ^
compilation terminated.

QtWidgets/QAction exists for QT5
but is different for QT4
QtGui/QAction

from configs.log

  Qt CPPFLAGS:                 -I/usr/include/qt4 -I/usr/include/qt4/QtNetwork -I/usr/include/qt4 -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/qt4 -I/usr/include/qt4/QtCore

[cut]

ac_cv_prog_ac_ct_LRELEASE=lrelease-qt5
ac_cv_prog_ac_ct_MOC=moc-qt5
ac_cv_prog_ac_ct_OBJDUMP=objdump
ac_cv_prog_ac_ct_RANLIB=ranlib
ac_cv_prog_ac_ct_RCC=rcc-qt5
ac_cv_prog_ac_ct_STRIP=strip
ac_cv_prog_ac_ct_UIC=uic-qt5

marco atzeri <matzeri>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by godfrey (Posted a comment)
  • -email is unavailable- added by matzeri (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-06-02 jwe Release4.0.0-rc3 => 4.0.0
    2015-04-18 mtmiller StatusNone => Duplicate
        Open/ClosedOpen => Closed
        Operating SystemMicrosoft Windows => Any
        Dependencies- => Depends on bugs #40252

    Back to the top


    Powered by Savane 3.5