bugGNU Octave - Bugs: bug #44260, Images appear clipped in NSIS...

 
 

bug #44260: Images appear clipped in NSIS installer splash screen

Submitted by:  Rik <rik5>
Submitted on:  Sun 15 Feb 2015 05:48:17 PM UTC  
 
Category:  Configuration and Build System Severity:  2 - Minor
Priority:  5 - Normal Item Group:  Other
Status:  Fixed Assigned to:  John Donoghue <lostbard>
Originator Name:  Open/Closed:  Closed
Release:  dev Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Fri 20 Feb 2015 01:11:13 AM UTC, comment #13: 

Closing report as fixed

John Donoghue <lostbard>
Project MemberIn charge of this item.
Wed 18 Feb 2015 11:34:24 PM UTC, comment #12: 
John Donoghue <lostbard>
Project MemberIn charge of this item.
Wed 18 Feb 2015 06:49:24 PM UTC, comment #11: 

Looks better to my eye!

Rik <rik5>
Project Administrator
Wed 18 Feb 2015 06:41:55 PM UTC, comment #10: 

How about this?


John Donoghue <lostbard>
Project MemberIn charge of this item.
Wed 18 Feb 2015 06:14:49 PM UTC, comment #9: 

I found out when using the nsis installer - nsis doesn't complain, just doesn't show anything.

I should have tried using gimp or whatever, and then resaving in paint afterward and seeing if that works or not.

John Donoghue <lostbard>
Project MemberIn charge of this item.
Wed 18 Feb 2015 05:51:40 PM UTC, comment #8: 

I don't want to make a lot of work for you.  I could do some cleanup in GIMP, but is there a way to test whether my image will read-in properly?  I suppose I could transfer it to the Windows VM and see if the Image Viewer program there reads it.

Rik <rik5>
Project Administrator
Wed 18 Feb 2015 05:49:33 PM UTC, comment #7: 

I am ashamed to say ... paint.

I didn't change the logo, but did center it so maybe messed it up at that point.

The sombrero probally is issues with anti aliasing.

I initially attempted to use gimp, however nsis didn't like the bmap images created for some reason.

John Donoghue <lostbard>
Project MemberIn charge of this item.
Wed 18 Feb 2015 05:43:33 PM UTC, comment #6: 

@John: Can you take a look at the attached snapshot of the installer screen?  I notice that there is a black line in the lower left-corner of the Octave logo.  I also notice fuzz on the right-hand side of the sombrero plot.  I opened the bmp file with Gimp and it looks like anti-aliasing during screen capture led to some pixels being set (See the other two attached files).

In the Octave logo, what program did you use to render the svg of the Octave logo?  It looks like the right-hand side was truncated.  I've used Inkscape in the past and that seems to work better than most other programs.


Rik <rik5>
Project Administrator
Tue 17 Feb 2015 06:59:40 PM UTC, comment #5: 
John Donoghue <lostbard>
Project MemberIn charge of this item.
Mon 16 Feb 2015 06:40:09 PM UTC, comment #4: 

If we make a new screenshot I think it should show the Qt figure since it is The default when using the GUI. ( not FLTK AS now)

Anonymous
Mon 16 Feb 2015 03:26:51 PM UTC, comment #3: 

Yes should be easy - I post something up later today.

John Donoghue <lostbard>
Project MemberIn charge of this item.
Mon 16 Feb 2015 03:17:58 PM UTC, comment #2: 

Oh, this seems easier than I thought.  I think jwe probably made the image just by displaying the logo and a sombrero plot and then taking a screenshot.  Could you re-generate the plot?

Rik <rik5>
Project Administrator
Sun 15 Feb 2015 06:22:03 PM UTC, comment #1: 

Whoever ever made the image (int installer-files) cut it off.

Is there any other images we can/should be using, or just regenerate and center the plot?

John Donoghue <lostbard>
Project MemberIn charge of this item.
Sun 15 Feb 2015 05:48:17 PM UTC, original submission:  

A very minor issue, but it appears that the sombrero plot in the NSIS installer splash screen is clipped on the right-hand side.  See the attached screenshot.

Rik <rik5>
Project Administrator

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #33119:  octave2.png added by lostbard (24KiB - image/png)
file #33116:  Win_Installer_BMP.png added by rik5 (45KiB - image/png)
file #33117:  sombrero_fuzz_bmp.png added by rik5 (11KiB - image/png)
file #33118:  octave_logo_bmp.png added by rik5 (12KiB - image/png)
file #33083:  Install_screen.png added by rik5 (52KiB - image/png)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by lostbard (Posted a comment)
  • -email is unavailable- added by rik5 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 10 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-02-20 lostbard StatusReady For Test => Fixed
        Open/ClosedOpen => Closed
    2015-02-18 lostbard Attached File- => Added octave2.png, #33119
    2015-02-18 rik5 Attached File- => Added Win_Installer_BMP.png, #33116
        Attached File- => Added sombrero_fuzz_bmp.png, #33117
        Attached File- => Added octave_logo_bmp.png, #33118
    2015-02-17 lostbard StatusIn Progress => Ready For Test
    2015-02-16 lostbard StatusNone => In Progress
        Assigned toNone => lostbard
    2015-02-15 rik5 Attached File- => Added Install_screen.png, #33083

    Back to the top


    Powered by Savane 3.5