bugGNU Octave - Bugs: bug #44161, imread ('file.jpg') & clear...

 
 

bug #44161: imread ('file.jpg') & clear all cause crash

Submitted by:  Avinoam Kalma <avinoam>
Submitted on:  Mon 02 Feb 2015 07:08:15 PM UTC  
 
Category:  Octave Function Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Duplicate Assigned to:  None
Originator Name:  Avinoam Open/Closed:  Closed
Release:  dev Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 02 Feb 2015 08:14:41 PM UTC, comment #3: 

I understand, closing this bug report as a duplicate. The bug fix list you point to is a wiki, you are as free to make changes to it as anyone :)

Also be aware that Octave has crashed on Windows with the "clear all" command for many, many releases now as I understand it, this is definitely not a new problem with 4.0.

Mike Miller <mtmiller>
Project Administrator
Mon 02 Feb 2015 08:00:16 PM UTC, comment #2: 

Hi,

the title of bug 41699 is
"imread causes a segmentation fault when exiting Octave", well,
it does not look so severe, so in http://wiki.octave.org/Bug_Fix_List_-_4.0_Release it is marked as:
"It would be nice to fix these, but they don't require resolution before the release.", but if it crashes every "clear all" after "imread", then this is really a show stopper for version 4.0.

Thanks

Avinoam Kalma <avinoam>
Project Member
Mon 02 Feb 2015 07:21:35 PM UTC, comment #1: 

Thanks for your bug report and for trying to help make the 4.0 release better.

Can you explain why you think this is not a duplicate of bug #41699? That bug report says "imread followed by clear all causes a segmentation fault". That is what you are reporting here also. What is not duplicated?

I agree about raising the severity of the original bug, but it can only be fixed for 4.0 if we have motivated people who can help find the cause in Windows and come up with a suitable fix.

Mike Miller <mtmiller>
Project Administrator
Mon 02 Feb 2015 07:08:15 PM UTC, original submission:  

imread ('file.jpg')
clear all

cause Octave to crash under windows.
This is a severe variant (but not duplicant) of bug 416699.

I have opened a new bug for two reasons:

1. This bug should have severity of 4 (and not 3).
2. It should be fixed in version 4.0.

Thanks!

Avinoam

Avinoam Kalma <avinoam>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by avinoam (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-02-02 mtmiller Dependencies- => Depends on bugs #41699
    2015-02-02 mtmiller Open/ClosedOpen => Closed
    2015-02-02 mtmiller StatusNone => Duplicate

    Back to the top


    Powered by Savane 3.5