bugGNU Octave - Bugs: bug #44114, image: plotting a 1D image fails...

 
 

bug #44114: image: plotting a 1D image fails with gnuplot

Submitted by:  Mike Miller <mtmiller>
Submitted on:  Thu 29 Jan 2015 03:46:54 AM UTC  
 
Category:  Plotting with gnuplot Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  3.8.2 Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 29 Jan 2015 03:07:43 PM UTC, comment #5: 

Thanks for catching this Avinoam! I was only testing with stable and gui-release, neglected to try in the default branch. Closing as a duplicate of bug #43836. The fix for this bug will be released with Octave 4.2.

Mike Miller <mtmiller>
Project Administrator
Thu 29 Jan 2015 02:21:15 PM UTC, comment #4: 

Hi,

I think that this bug has already been fixed.
Please see bug 43836

Avinoam Kalma <avinoam>
Project Member
Thu 29 Jan 2015 06:26:51 AM UTC, comment #3: 

Much nicer...

Lachlan Andrew <lachlan>
Thu 29 Jan 2015 06:02:10 AM UTC, comment #2: 

I think since this works already when plotting with OpenGL, the appropriate place to fix it is in the Gnuplot plotting routines.

How about the attached patch instead, which works for me and produces the same axis that I get with FLTK.

(file #32933)

Mike Miller <mtmiller>
Project Administrator
Thu 29 Jan 2015 04:41:06 AM UTC, comment #1: 

Good timing!  I was just about to report that error.

Try the attached patch.

(file #32932)

Lachlan Andrew <lachlan>
Thu 29 Jan 2015 03:46:54 AM UTC, original submission:  

The following two examples work with FLTK:

image (0:1, 1, randi (255, 1, 2))
image (1, 0:1, randi (255, 2, 1))

but not with Gnuplot. The error prints something like this from Gnuplot to the console:

multiplot> plot "-" binary array=2x2 scan=yx origin=(1,0) dx=0 dy=1 using 1 title "" with image; ;

Mike Miller <mtmiller>
Project Administrator

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #32933:  gnuplot-1d-image.diff added by mtmiller (949B - text/x-patch)
file #32932:  image.patch added by lachlan (752B - text/x-patch)

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by avinoam (Posted a comment)
  • -email is unavailable- added by lachlan (Updated the item)
  • -email is unavailable- added by mtmiller (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-01-29 mtmiller StatusPatch Submitted => Duplicate
    2015-01-29 mtmiller Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #43836
    2015-01-29 mtmiller Attached File- => Added gnuplot-1d-image.diff, #32933
        StatusNone => Patch Submitted
        Operating SystemGNU/Linux => Any
    2015-01-29 lachlan Attached File- => Added image.patch, #32932

    Back to the top


    Powered by Savane 3.5