bugGNU Octave - Bugs: bug #43159, The Signal package (1.3.0)...

 
 

bug #43159: The Signal package (1.3.0) specgram() function is broken in ML when installed from MacPorts or Brew 0.9.5

Submitted by:  None
Submitted on:  Sat 06 Sep 2014 03:50:07 AM UTC  
 
Category:  Plotting Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Regression
Status:  Duplicate Assigned to:  None
Originator Name:  Joe Burnett Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  3.8.1
Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 06 Sep 2014 07:18:33 PM UTC, comment #3: 

Thanks for your bug report. This is a known regression in Octave 3.8.1 and has been fixed in version 3.8.2. Please update your version of Octave (I have no idea if this is available yet in homebrew) to fix this problem. This was reported earlier as bug #42043.

Mike Miller <mtmiller>
Project Administrator
Sat 06 Sep 2014 05:06:54 AM UTC, comment #2: 

Josephs-Mac-Pro:~ jburnett$ brew info homebrew/science/octave
octave: stable 3.8.1, HEAD
http://www.gnu.org/software/octave/index.html
/usr/local/Cellar/octave/3.8.1 (2109 files, 56M) *
  Built from source
From: https://github.com/homebrew/homebrew-science/blob/master/octave.rb
==> Dependencies
Build: pkg-config ✔, gnu-sed ✔, texinfo ✔
Required: pcre ✔, qscintilla2 ✔, qt ✔
Recommended: gnuplot ✔, suite-sparse ✔, readline ✔, arpack ✔, fftw ✔, glpk ✔, gl2ps ✔, graphicsmagick ✔, ghostscript ✔, hdf5 ✔, qhull ✔, qrupdate ✔, pstoedit ✔, epstool ✔
Optional: openblas ✘
==> Options
--with-native-graphics
Use native OpenGL/FLTKgraphics (does not work with the GUI)
--with-openblas
Use OpenBLAS instead of native LAPACK/BLAS
--without-arpack
Build without arpack support
--without-check
Skip build-time tests (not recommended)
--without-curl
Do not use cURL (urlread/urlwrite/@ftp)
--without-docs
Do not build documentation
--without-epstool
Build without epstool support
--without-fftw
Do not use FFTW (fft,ifft,fft2,etc.)
--without-ghostscript
Do not use Ghostscript (PS/PDF image output)
--without-gl2ps
Build without gl2ps support
--without-glpk
Do not use GLPK
--without-gnuplot
Do not use gnuplot graphics
--without-graphicsmagick
Do not use GraphicsMagick++ (imread,imwrite)
--without-gui
Do not build the experimental GUI
--without-hdf5
Do not use HDF5 (hdf5 data file support)
--without-pstoedit
Build without pstoedit support
--without-qhull
Do not use the Qhull library (delaunay,voronoi,etc.)
--without-qrupdate
Do not use the QRupdate package (qrdelete,qrinsert,qrshift,qrupdate)
--without-readline
Build without readline support
--without-suite-sparse
Do not use SuiteSparse (sparse matrix operations)
--without-zlib
Do not use zlib (compressed MATLAB file formats)
--HEAD
install HEAD version
==> Caveats

To use the gnuplot plotting engine, you must set the environment
variable GNUTERM. Valid choices include:
    GNUTERM=x11   # X windows must be installed
    GNUTERM=qt    # gnuplot must have been compiled with Qt support
    GNUTERM=aqua  # if you are using Aquaterm
You may also set this variable from within Octave with the command
    setenv('GNUTERM','qt') % or 'x11', or 'aqua'

The Octave GUI is experimental and not enabled by default. To use it,
use the command-line argument "--force-gui"; e.g.,
    octave --force-gui

Anonymous
Sat 06 Sep 2014 04:02:41 AM UTC, comment #1: 

One thing I noticed that is kind of weird, is that I had been using Octave all year up until last month. Only since August, have I ever seen this happen. According to the package description, this was released back in January???

Name: Signal
Version: 1.3.0
Date: 2014-01-26
Author: various authors
Maintainer: Mike Miller <mtmiller@ieee.org>
Title: Signal Processing.
Description: Signal processing tools, including filtering, windowing and display functions.
Depends: octave (>= 3.8.0), control (>= 2.4.5), general (>= 1.3.2)
Autoload: no
License: GPLv3+, public domain
Url: http://octave.sf.net

It could be something relating to the brew Repository, which installs Octave 3.8.1. However, if it is a recent repository related problem for a Mac OSX packaging tool, how come MacPorts is also having the exact same issue?

I can't think of a logical reason both of these package managers install the problematic Signal package.

Further more, I have tried pulling the Signal package directly from the Octave package repository from inside of Octave by installing each package using the pkg command directly like "pkg install <package> -forge". I tried this after having the packages fail when installed from the MacPorts repository, as well as after downloading the packages directly (last month).

Did the January release not get pushed when committed or something? I am really confused here.

Anonymous
Sat 06 Sep 2014 03:50:07 AM UTC, original submission:  

octave:8> pkg list
Package Name  | Version | Installation directory
--------------+---------+-----------------------
       audio *|   1.1.4 | /Users/jburnett/octave/audio-1.1.4
     control *|   2.6.5 | /Users/jburnett/octave/control-2.6.5
     general *|   1.3.4 | /Users/jburnett/octave/general-1.3.4
          io *|   2.2.3 | /Users/jburnett/octave/io-2.2.3
      signal *|   1.3.0 | /Users/jburnett/octave/signal-1.3.0
octave:9> Josephs-Mac-Pro:~ jburnett$ brew --version
0.9.5

octave:1> pkg load all
octave:2> setenv("GNUTERM","x11")
octave:3> x = sin(2*pi.*1234.*[1:20000]./44100) + (rand(1,20000).*2 - 1).*power(10, -24/20);
octave:4> specgram(x)

I have attached the version installed by the latest version of brew from Mountain Lion 12F45...

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #32038:  Screen Shot 2014-09-06 at 3.25.27 AM.png added by None (763KiB - image/png - Problem persists despite supplying window size and sample rate inside function arguments....)
file #32037:  Screen Shot 2014-09-05 at 10.02.11 PM.png added by None (1MiB - image/png - After removing, and re-installing without JIT, I am still experiencing the issue….)
file #32036:  user_octave_signal-1.3.0.tar added by None (1MiB - application/x-tar - * Here is the signal package as located in my user's home folder….)
file #32035:  signal.tar added by None (117KiB - application/x-tar)

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 11 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-09-06 mtmiller CategoryPlotting with gnuplot => Plotting
        Item GroupIncorrect Result => Regression
        StatusNone => Duplicate
        Open/ClosedOpen => Closed
        Operating SystemMac OS => Any
        Dependencies- => Depends on bugs #42043
    2014-09-06 None Attached File- => Added Screen Shot 2014-09-06 at 3.25.27 AM.png, #32038
    2014-09-06 None Attached File- => Added Screen Shot 2014-09-05 at 10.02.11 PM.png, #32037
    2014-09-06 None Attached File- => Added user_octave_signal-1.3.0.tar, #32036
    2014-09-06 None Attached File- => Added Screen Shot 2014-09-05 at 8.44.45 PM.png, #32034
        Attached File- => Added signal.tar, #32035

    Back to the top


    Powered by Savane 3.5