bugGNU Octave - Bugs: bug #42988, print() breaks LaTeX labels with...

 
 

bug #42988: print() breaks LaTeX labels with FLTK

Submitter:  None
Submitted:  Thu 14 Aug 2014 04:37:22 PM UTC
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Duplicate Assigned to:  None
Originator Name:  Joe BH Originator Email:  -email is unavailable-
Open/Closed:  * Closed Release:  * 3.8.1
Operating System:  * GNU/Linux
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Mon 18 Aug 2014 04:41:18 PM UTC, comment #5: 

I backported the documentation patch about 'pdflatexstandalone' to the stable branch here (http://hg.savannah.gnu.org/hgweb/octave/rev/d6f1f46e5b8f).  It will be in the next bug fix release of Octave.

For the original reporter, when switching over to gnuplot you may also need to set the environment variable GNUTERM in the shell to something reasonable.  On my Linux platform the default is 'x11' which produces ugly plots but 'wxt' or 'qt' produce nice plots.

Rik <rik5>
Project Administrator
Mon 18 Aug 2014 12:36:56 PM UTC, comment #4: 

Sorry, the new documentation only made it into
the devel branch. You could download that or wait
for the next release.

Michael

Michael Godfrey <godfrey>
Project Member
Mon 18 Aug 2014 11:12:43 AM UTC, comment #3: 

Thanks for the quick response.

Using `doc print` in Octave 3.8.1 and 3.6.4 and the online help for 3.8.0 I can't find any reference to 'pdflatexstandalone' though there are a few equivalent options that I have used before.

I will use Rik's solution as I need to print to .png. Once again, thanks for the help.

Anonymous
Fri 15 Aug 2014 05:44:06 PM UTC, comment #2: 

Or, you could read the help print or relevant
section of the Manual about print options. A
useful snippet is:

          'pdflatexstandalone'
               Generate a LaTeX file 'FILENAME.tex' for the text
               portions of a plot and a file 'FILENAME.(ps|eps|pdf)' for
               the remaining graphics.  The graphics file suffix
               .ps|eps|pdf is determined by the specified device type.
               The LaTeX file produced by the 'standalone' option can be
               processed directly by LaTeX.  The file generated without
               the 'standalone' option is intended to be included from
               another LaTeX document.  In either case, the LaTeX file
               contains an '\includegraphics' command so that the
               generated graphics file is automatically included when
               the LaTeX file is processed.  The text that is written to
               the LaTeX file contains the strings exactly as they
               were specified in the plot.  If any special characters of
               the TeX mode interpreter were used, the file must be
               edited before LaTeX processing.  Specifically, the
               special characters must be enclosed with dollar signs ('$
               ... $'), and other characters that are recognized by
               LaTeX may also need editing (.e.g., braces).  The
               'pdflatex' device, and any of the 'standalone' formats,
               are not available with the Gnuplot toolkit.

Michael Godfrey <godfrey>
Project Member
Fri 15 Aug 2014 04:06:52 PM UTC, comment #1: 

This is a known issue.  Tex labels are rendered on-screen only with the FLTK toolkit.  For the time being if you need to print you should switch over to the gnuplot toolkit with

graphics_toolkit gnuplot

Marking this as a duplicate of bug #42320 and closing.

Rik <rik5>
Project Administrator
Thu 14 Aug 2014 04:37:22 PM UTC, original submission:  

Using the default build of Octave 3.8.1 latex labels for plots render correctly. However, if when they are exported using `print` the labels appear as a raw text string.

See the example in the attached files.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #31900:  Screenshot from 2014-08-14 16:20:17.png added by None (16KiB - image/png - screen shots and out put related to the bug)
file #31901:  test1.png added by None (34KiB - image/png - screen shots and out put related to the bug)

 

Carbon-Copy List
  • -email is unavailable- added by godfrey (Posted a comment)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 8 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-08-15 rik5 Dependencies- Depends on bugs #42340
    2014-08-15 rik5 Dependencies- Depends on bugs #42320
    2014-08-15 rik5 StatusNone Duplicate
        Open/ClosedOpen Closed
    2014-08-15 rik5 CategoryPlotting Plotting with OpenGL
        Summaryprint() breaks LaTeX labels print() breaks LaTeX labels with FLTK
    2014-08-14 None Attached File- Added Screenshot from 2014-08-14 16:20:17.png, #31900
        Attached File- Added test1.png, #31901

    Back to the top


    Powered by Savane 3.9