bugGNU Octave - Bugs: bug #42488, "imread" usage causes...

 
 

bug #42488: "imread" usage causes crash under Windows

Submitted by:  Hartmut <hardy>
Submitted on:  Mon 02 Jun 2014 01:16:15 PM UTC  
 
Category:  Octave Function Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  3.8.1 Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 02 Jun 2014 06:38:38 PM UTC, comment #5: 

Ok, that sounds like enough to declare this as the same underlying bug. Closing as duplicate of bug #41699, please continue with any comments on that bug report.

Mike Miller <mtmiller>
Project Administrator
Mon 02 Jun 2014 06:09:37 PM UTC, comment #4: 

Yes, probably all my "run twice to crash" skripts have a "clear all" statement somewhere at the beginning, and the "imread" statement lateron.

Hartmut <hardy>
Mon 02 Jun 2014 05:36:36 PM UTC, comment #3: 

This could be the same bug

test imread;
clear all;

results in the same crash information I got with

myimg = imread('dummy.jpg');
clear all;

In both cases:

panic: Segmentation violation -- stopping myself...
0x68A807C0 (0x0022F560 0x055D1ED0 0x0022FFC4 0x76A08CD5), _ZN5ArrayIdED2Ev() + 0x10 bytes(s)
attempting to save variables to 'octave-workspace'...
save to 'octave-workspace' complete

I was unable to replicate H.G.Hardy observation that just running a script twice causes the crash. Perhaps the script involved has a clear all statement?

Ian Journeaux <ijourneaux>
Mon 02 Jun 2014 01:30:03 PM UTC, comment #2: 

Yes, this might well be a duplicate of your mentioned bug. But I cannot judge this fully.

"My" crash does NOT happen when you exit Octave (by "exit" I mean to close the Octave program itself). In contrary: you can "reset" Octave by closing it and restarting it again, after this restart the freshly started Octave instance will be fine. But maybe you have a different understanding of "exit"?

As I said in my last lines: You CAN also provoke the crash by just calling a script (with an imread command inside). And then just call the same script again. The crash will (mostly) only happen on the second run! If you restart Octave again, then you get one more run without a crash, and a crash on the second run again. I hope this is understandable.

Hartmut <hardy>
Mon 02 Jun 2014 01:21:51 PM UTC, comment #1: 

Thanks for your bug report. Is this the same as bug #41699? Does the segmentation fault happen either when you exit Octave or when you "clear all" or both?

Mike Miller <mtmiller>
Project Administrator
Mon 02 Jun 2014 01:16:15 PM UTC, original submission:  

This crash behavior only happens on Windows. I used the mxe version 3.8.1-1.

Here is one way to reproduce the crash. Just run the following script under Windows:

clear all;
myimg = imread('dummy.jpg');
clear all;

The content of "dummy.jpg" is not relevant, but I'll attach my sample image anyways.

This crash happens only under Windows, not under Linux.

This crash happens in the GUI version as well as in the terminal version of Octave.

I very commen variant to provoke this bug is:

  • run any script that contains a imread command
  • run it a second time
  • crash!

(It happend under an up to date Windows 7 for me.)

Hartmut <hardy>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #31486:  dummy.jpg added by hardy (1KiB - image/jpeg)

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by ijourneaux (Posted a comment)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by hardy (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-06-02 mtmiller StatusNeed Info => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #41699
    2014-06-02 mtmiller CategoryNone => Octave Function
        StatusNone => Need Info
    2014-06-02 hardy Attached File- => Added dummy.jpg, #31486

    Back to the top


    Powered by Savane 3.5