bugGNU Octave - Bugs: bug #41994, pcolor does plotting, but the...

 
 

bug #41994: pcolor does plotting, but the window does not react at all

Submitted by:  Benja Krieg <zhop>
Submitted on:  Fri 28 Mar 2014 11:59:38 PM UTC  
 
Category:  Plotting Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Invalid Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  3.8.0 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Sat 29 Mar 2014 07:25:53 PM UTC, comment #8: 

Just one more followup. I think the reason that fltk plots are unresponsive is because QtOctave runs octave with readline disabled. So does GNU Emacs. Disabling readline means fltk plots do not respond and operate correctly. See bug #37795.

Mike Miller <mtmiller>
Project Administrator
Sat 29 Mar 2014 06:45:51 PM UTC, comment #7: 

The new GUI is really nice. thnx!

Benja Krieg <zhop>
Sat 29 Mar 2014 06:36:02 PM UTC, comment #6: 

Okay, that's good to know.  QtOctave, despite having Octave in the name, is not associated with this project at all.  We don't know anything about their code base and can't fix this problem.  I'm going to close this bug report as it belongs to the QtOctave project.

In the meantime, if you want to try the experimental GUI that the Octave project has made you could try running

octave --force-gui

from a shell.  The GUI will become the default for this project with release 4.0.

Rik <rik5>
Project Administrator
Sat 29 Mar 2014 06:13:44 PM UTC, comment #5: 

Ok. now have found something. The bug does not affect the "pure octave".

It is triggered with QtOctave.

the bug affects demo("pcolor",1) and demo("plot",1) too. It seems also, that it affects the whole FLTK backend within QtOctave.

Benja Krieg <zhop>
Sat 29 Mar 2014 05:19:50 PM UTC, comment #4: 

To be concrete about things, does this example fail?

demo ("pcolor", 1);
## Close window using mouse and clicking on "Close Window" button in window menubar.

It works for me with 3.8.0 and FLTK.

Rik <rik5>
Project Administrator
Sat 29 Mar 2014 02:12:08 PM UTC, comment #3: 

The problem is triggered with the FLTK. With the gnuplot all works fine.

And yes, it is specific to pcolor. FTLK with regular plotting (something like plot(x,sin(x)) works fine.

Benja Krieg <zhop>
Sat 29 Mar 2014 02:42:45 AM UTC, comment #2: 

Also works for me in the development version.

Is this specific to pcolor or does it affect all plotting for you?

Mike Miller <mtmiller>
Project Administrator
Sat 29 Mar 2014 12:18:31 AM UTC, comment #1: 

demo pcolor works for me in 3.9.1+
What graphics_toolkit are you using?

Doug Stewart <dastew>
Fri 28 Mar 2014 11:59:38 PM UTC, original submission:  

do any plotting with pcolor and then try to interact with the plotting-window. It's not possible to close etc.

Benja Krieg <zhop>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by dastew (Posted a comment)
  • -email is unavailable- added by zhop (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-03-29 rik5 StatusNeed Info => Invalid
        Open/ClosedOpen => Closed
    2014-03-29 mtmiller Item GroupNone => Incorrect Result
        StatusNone => Need Info

    Back to the top


    Powered by Savane 3.5