bugGNU Octave - Bugs: bug #41893, Display issues with the command...

 
 

bug #41893: Display issues with the command window after resizing the Editor window

Submitted by:  None
Submitted on:  Tue 18 Mar 2014 09:36:43 AM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  Wont Fix Assigned to:  None
Originator Name:  Max R Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  3.8.1
Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Thu 20 Mar 2014 10:07:41 PM UTC, comment #7: 

Aren't we caching what has already been displayed?

Is there some reason that our cache of the text that has already been displayed can't be kept and used when the terminal size is reduced?  That way we could preserve what was there previously while still allowing wrapping to occur.  And then if the terminal width is later enlarged, we would still have all the characters that were previously displayed, not the truncated version that the terminal buffer contains.

I guess this would require maintaining a list of buffers of possibly different sizes along with some extra complexity in the code that displays the buffers.

Or maybe it's not possible to know when to use our cache vs. using the info from the terminal?

John W. Eaton <jwe>
Project Administrator
Thu 20 Mar 2014 02:49:39 PM UTC, comment #6: 

Ok, Michael, I see the point.

Thank you for explaining me that. I see the point now.

From the former GUI of QtOctave (0.10), I was indeed used to a horizontal scroll bar and - indeed - it can be kind of annoying.

The issue also explains another effect I thought might be a bug:
When typing something like:
"aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa"
in the command prompt and resizing the command window back and forth, you are able to produce quite an ammount of a's (without using the keyboard).

Nevermind, know that I am aware of that, I should be able to deal with it.

There are some other displays issues I will open another ticket, though.

Anonymous
Thu 20 Mar 2014 01:04:45 PM UTC, comment #5: 

Keeping the buffer width in sync with the window width is more a trade-off than anything else, because that's the most likely expected behavior (like resizing a terminal in Linux).

It doesn't play well if you only want to shrink the command window temporarily. But if your intention was to reduce the command window width permanently, then you'd be annoyed to have a horizontal scrollbar and be forced to always scroll to see the window content.

Michael Goffioul <goffioul>
Thu 20 Mar 2014 11:55:40 AM UTC, comment #4: 

Thanks again, Michael.

I get that issue now with cmd as well, however, as you mentioned, you have to edit the properties (buffer) of the terminal.
In the GUI, you just have to drag the Editor-Window by using the mouse. Apparently, the buffer-value in Octave is set to the window width upon a resizing process? Could it be an option to leave the buffer-size unaffected by the window-size?

Sorry, these might be stupid questions, but I am absolutely not into programming of such stuff.

Anonymous
Thu 20 Mar 2014 11:37:40 AM UTC, comment #3: 

Right-click on the titlebar icon, select Properties, change the window size and the buffer size so that their width match; reduce it, then bring it back to its original size.

Michael Goffioul <goffioul>
Thu 20 Mar 2014 08:21:45 AM UTC, comment #2: 

Thanks for the answer.

With cmd.exe starting Octave I do not get any behaviour like in the GUI, but I am not sure how to exacly duplicate that issue with cmd.exe.

However, it is interesting to know, that this is a Windows issue. That is, it does not occur on Linux systems? Might be worth to think about a switch?

Anonymous
Wed 19 Mar 2014 10:53:05 PM UTC, comment #1: 

This is a known limitation of the Win32 terminal emulation. The behavior would be exactly the same when running octave in the regular command prompt window (cmd.exe).

Michael Goffioul <goffioul>
Tue 18 Mar 2014 09:36:43 AM UTC, original submission:  

I am using the new 3.8.1 release for Windows on a Windows 7 PC.

Right after starting the new GUI:
-Dragging (resizing) the Editor Window (positioned on the right hand side of the main window) towards the left, overlapping the command window and
- Resizing it back to its original size,
leaves the command window with a "cut" display of the Octave startup-message.

This effect also occurs after working with the command line, displaying some text and then resizing the editor window (back and forth), etc.

A screenshot is attached.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Updated the item)
  • -email is unavailable- added by jwe (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-02-08 rik5 Open/ClosedOpen => Closed
    2014-03-19 goffioul StatusNone => Wont Fix
    2014-03-18 None Attached File- => Added Octave_3_8_1_bug_command_window_does_not_refresh.png, #30936

    Back to the top


    Powered by Savane 3.5