bugGNU Octave - Bugs: bug #41821, gui-release: octave-cli selects...

 
 

bug #41821: gui-release: octave-cli selects 'qt' graphics_toolkit by default, but it is not available

Submitted by:  Michael C. Grant <mcgrant>
Submitted on:  Mon 10 Mar 2014 06:35:03 AM UTC  
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Regression
Status:  Duplicate Assigned to:  None
Originator Name:  Michael C. Grant Open/Closed:  Closed
Release:  dev Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 10 Mar 2014 12:55:26 PM UTC, comment #1: 

Thanks for your bug report. This problem has already been reported and discussed as bug #41665. Closing as duplicate, please follow up with comments on that bug.

Mike Miller <mtmiller>
Project Administrator
Mon 10 Mar 2014 06:35:03 AM UTC, original submission:  

Consider the constructor for gtk_manager (libinterp/corefcn/graphics.cc):

gtk_manager::gtk_manager (void)
  : dtk (), available_toolkits (), loaded_toolkits ()
{
#if defined (HAVE_QT)
  dtk = display_info::display_available () ? "qt" : "gnuplot";
#elif defined (HAVE_FLTK)
  dtk = display_info::display_available () ? "fltk" : "gnuplot";
#else
  dtk = "gnuplot";
#endif
}

Notice that if HAVE_QT=1, then "qt" is entered as the default toolkit. However, *this assumes that "qt" will eventually be added to the list of available toolkits. This is not the case with octave-cli. It has "fltk" (if HAVE_FLTK=1 as well), but not "qt". At least, not yet.

It looks like this function is implemented incorrectly, then. In the HAVE_QT branch, it somehow needs to determine if the GUI is present, and if not, select "fltk" instead of "qt". Right? If I knew how to do that I'd offer a patch.

Michael C. Grant <mcgrant>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by mcgrant (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-03-10 mtmiller StatusNone => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #41665

    Back to the top


    Powered by Savane 3.5