bugGNU Octave - Bugs: bug #41552, GUI crashes with...

 
 

bug #41552: GUI crashes with ""QSpiAccessible::accessibleEvent not handled"

Submitted by:  Manfred Grauvogl <mgrauvogl>
Submitted on:  Tue 11 Feb 2014 03:28:36 PM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Wont Fix Assigned to:  None
Originator Name:  Manfred Grauvogl Open/Closed:  Closed
Release:  3.8.0 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Fri 21 Feb 2014 10:47:33 PM UTC, comment #13: 

Closing as won't fix. Doug's comment confirming the simple patch fixes it for him means that simply unsetting the variable does work. And the proper way to do that is in the user's desktop settings.

Mike Miller <mtmiller>
Project Administrator
Thu 20 Feb 2014 01:02:10 AM UTC, comment #12: 

Applying the patch works for me. Now 3.8.1 rc3 works correctly.

Doug Stewart <dastew>
Wed 19 Feb 2014 11:39:15 PM UTC, comment #11: 

Right, I don't think we want to be doing this, always be wary when considering overwriting user environment variables.

If Octave is a victim of problems with Qt's accessibility plugin, then so be it, users should be advised how to turn that setting off until Ubuntu or Qt get the problem fixed. The appropriate command to disable Qt a11y on modern Debian and Ubuntu systems seems to be:

gsettings set org.gnome.desktop.interface toolkit-accessibility false

After setting that and logging out and back in (I'm not sure how or why it gets set to true in the first place), the user's X session should no longer have the QT_ACCESSIBILITY environment variable set.

If there is a reproducible crash in Octave that we can determine is due to something that Octave is doing wrong, then that's worth fixing, but otherwise I'd leave this as a won't fix. I haven't seen a crash yet, just lots of debug/warning messages.

Mike Miller <mtmiller>
Project Administrator
Wed 19 Feb 2014 09:26:06 PM UTC, comment #10: 

Is this the right fix? Presumably we don't want to cripple future accessibility features in the GUI just because of a packaging bug in Ubuntu, if that's what the problem is.

Jordi GutiƩrrez Hermoso <jordigh>
Project Administrator
Wed 19 Feb 2014 09:13:57 PM UTC, comment #9: 

I have attached a patch set disables QT_ACCESIBILITY for the gui process. This fixes the issue on my system.

(file #30609)

Torsten Lilge <ttl>
Project Member
Wed 19 Feb 2014 11:17:24 AM UTC, comment #8: 

 I see this also, and one way to eliminate these messages is to run as supper user.
 I don't know why this works.
 I have 2 computers both running ubuntu 12.04, one has this problem and the other does not!!!???
Doug

Doug Stewart <dastew>
Wed 19 Feb 2014 06:01:29 AM UTC, comment #7: 

Setting QT_ACCESSIBILITY=1 I can reproduce this, too (Ubuntu 12.04). The message only appear when hovering over the menu of the dock widgets, not when hovering over the main menu.

Other Qt-applications like Texstudio and even Qt4-Designer or Qt4-assistant are showing the messages on my system, too ("Got bus address: ..." at program start and "FIXME: ..." or "QSpiAccessible::accessibleEvent ..." for some dialog or menu actions).

What can we do then? Setting QT_ACCESSIBILITY=0 for octave?

Torsten Lilge <ttl>
Project Member
Wed 19 Feb 2014 05:31:02 AM UTC, comment #6: 

I can reproduce these Qt accessibility error messages in Debian testing and Ubuntu 13.10 by doing all of the following:

$ sudo apt-get install qt-at-spi
$ export QT_ACCESSIBILITY=1
$ octave --force-gui

The error messages correspond to showing and mousing over menubar menus and popup menus. I haven't seen a crash occur yet, though. Any particular sequence of interactions in the GUI that causes a crash predictably?

Unless we can identify a specific interaction in the GUI that causes a crash, it seems like it's a problem internal to Qt or the qt-at-spi plugin and not something that Octave is doing.

Aside from the crash, there are already some bug reports about Qt error messages being shown in the Octave command window, see bug #41179 and bug #41304.

Mike Miller <mtmiller>
Project Administrator
Tue 18 Feb 2014 05:24:52 PM UTC, comment #5: 

It looks like this is a known bug in ubuntu's qt-at-spi package:
<https://bugs.launchpad.net/ubuntu/+source/qt-at-spi/+bug/857790>

Felipe G. Nievinski <fgnievinski>
Tue 18 Feb 2014 04:58:56 PM UTC, comment #4: 

So is there a bug here or not? Is the bug in Octave or in Qt? Are we doing something wrong that conflicts with the accessibility component in Qt?

Jordi GutiƩrrez Hermoso <jordigh>
Project Administrator
Mon 17 Feb 2014 07:48:48 PM UTC, comment #3: 

Hello Felipe, hello Torsten,

the advice of Felipe work quite well.

Thank's a lot

Manfred

Manfred Grauvogl <mgrauvogl>
Sun 16 Feb 2014 05:58:36 PM UTC, comment #2: 

Manfred, did Felipe's tipps help you to avoid the problems?

Torsten Lilge <ttl>
Project Member
Tue 11 Feb 2014 06:40:58 PM UTC, comment #1: 

Dear Manfred,

there seems to be three separate problems.

1) load Diffgl, where ls indicated a file Diffgl.m exists; if this is a data file, please include the file extension: load Diffgl.m; if this is an m-code script or function, please use the edit or run commands instead -- the extension then becomes optional: edit Diffgl

2) "it was not possible to change the folder" doesn't seem to be true, as you succeed doing:

>> cd MachineLearning
>> pwd

ans = /home/manfred/MachineLearning

3) the crash (octave exited with signal 6) was preempted by warning messages such as "QSpiAccessible::accessibleEvent not handled"; a google search indicates that removing the QT accessibility package (qt-at-spi) helps:
    sudo apt-get remove --purge qt-at-spi

In the future, please report problems as specifically as possible.  The crash should indeed be reported as a bug here; in contrast, for the usage issues, you'd obtain more helpful and timely feedback at the Octave general forum instead: <http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html>

Felipe G. Nievinski <fgnievinski>
Tue 11 Feb 2014 03:28:36 PM UTC, original submission:  

In the editor when trying to load or save a file, it was not possible to change the folder. Octave was closed with a message in the teminal where I startet octave. The message was:
octave excited with signal 6.

I started octave in the terminal with:
octave3.8 --force-gui

It was also not possibel to load a script file. The error was:
error: load: unable to find file Diffgl

It can be seen in more detail in the file I append.

Manfred Grauvogl <mgrauvogl>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #30609:  41552_v01.patch added by ttl (685B - text/x-diff)
file #30514:  Fehler octave added by mgrauvogl (3KiB - application/octet-stream)
file #30515:  Fehler octave02 added by mgrauvogl (16KiB - application/octet-stream)

 

Depends on the following items: None found

Digest:
   bug dependencies.

 

Carbon-Copy List
  • -email is unavailable- added by dastew (Posted a comment)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by jordigh (Posted a comment)
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by fgnievinski (Posted a comment)
  • -email is unavailable- added by mgrauvogl (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 9 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-02-27 rik5 Dependencies- => bugs #41714 is dependent
    2014-02-21 mtmiller Open/ClosedOpen => Closed
    2014-02-19 mtmiller StatusNeed Info => Wont Fix
    2014-02-19 ttl Attached File- => Added 41552_v01.patch, #30609
    2014-02-18 jordigh Item GroupOther => Segfault, Bus Error, etc.
        StatusNone => Need Info
        SummaryScript files not found. No folder change possible in the editor. => GUI crashes with ""QSpiAccessible::accessibleEvent not handled"
    2014-02-11 mgrauvogl Attached File- => Added Fehler octave, #30514
        Attached File- => Added Fehler octave02, #30515

    Back to the top


    Powered by Savane 3.5