bugGNU Octave - Bugs: bug #41423, Unable to type text into Command...

 
 

bug #41423: Unable to type text into Command window after swapping to another window

Submitted by:  None
Submitted on:  Sat 01 Feb 2014 11:56:19 PM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Performance
Status:  Duplicate Assigned to:  None
Originator Name:  Jamdaman5000 Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  3.8.0
Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Sun 02 Feb 2014 03:53:51 PM UTC, comment #12: 

Marked as duolicate of bug #40823

Torsten Lilge <ttl>
Project Member
Sun 02 Feb 2014 03:12:59 PM UTC, comment #11: 

Carlo, Thanks for the help with the patch.

Torsten, the patch didn't work for me either. I am experiencing the same results as Carlo. If I focus to the terminal, then back to the command window in octave, everything I type goes to the terminal (or whatever other program I was using before returning to Octave). I still have to mess around with the tabs or other options in Octave GUI to enable text entry in the command window.

I will also add that when I do a "make check" I get the following results:

PASS: 11465
FAIL: 2
XFAIL: 7
SKIPPED: 36

Jameson <jamdaman5000>
Sun 02 Feb 2014 02:49:39 PM UTC, comment #10: 

Jameson,

To apply the patch go to your Octave source directory,
which in my case is "~/octave-3.8.0", then use the command
"patch -p1" to apply the patch:

cd ~/octave-3.8.0
patch -p1 < patch_30435
./configure
make -j4
./run-octave --force-gui

c.

Carlo de Falco <cdf>
Project Member
Sun 02 Feb 2014 02:45:57 PM UTC, comment #9: 

Torsten,

BTW, I also tried your patch but it doesn't fix the problem.

If I

1) open octave with --force-gui
2) click on the terminal window
3) click back on the Octave window
4) type some characters

the characters appear in the terminal and not in Octave.

c.

Carlo de Falco <cdf>
Project Member
Sun 02 Feb 2014 02:34:17 PM UTC, comment #8: 

Hi,

I see the same in Octave 3.8.0 in Ubuntu 13.10, i.e. if I move the focus from a different application I cannot type in the
Octave command prompt window anymore.

In addition, the focus is lost also if I click on a figure
plotted with FLTK.

I can get back the focus to the Octave command prompt in the gui
if I either:

- Click on the editor or documentation tab and then on the command prompt

- Click on the Octave icon in the launcher

c.

Carlo de Falco <cdf>
Project Member
Sun 02 Feb 2014 02:30:18 PM UTC, comment #7: 

Yes, I built octave myself using the source files provided through ftp://ftp.gnu.org/gnu/octave

This is my first time patching a file, so I could use a little help with how to do it.

I did a little browsing and here are the steps I have taken so far:

1) I downloaded the patch to my Downloads folder.

2) In the terminal I navigated to that folder, and typed 'patch < focus_v01.patch'

3) Now the terminal is displaying a prompt "File to patch: "

Which file exactly do I need to patch?

Jameson <jamdaman5000>
Sun 02 Feb 2014 02:18:50 PM UTC, comment #6: 

Are you building octave youself? If yes, could you please test the attached patch?

(file #30435)

Torsten Lilge <ttl>
Project Member
Sun 02 Feb 2014 01:23:33 PM UTC, comment #5: 

Torsten, The same does not happen when I Alt-Tab. This only happens when I focus to another window outside the Octave GUI.

If I click into another widget, like the editor, it works properly and gets the focus, and conversly, when I click back into the Command Window, it gets the proper focus as well.

The problem seems to be when I focus on another program outside Octave, then focus back into Octave using the mouse.

Jameson <jamdaman5000>
Sun 02 Feb 2014 11:21:04 AM UTC, comment #4: 

Does the same happen

  • when you switch back to octave by Alt-Tab?
  • when you click into another widget (e.g. the editor, does this widget get the focus)?
Torsten Lilge <ttl>
Project Member
Sun 02 Feb 2014 11:12:55 AM UTC, comment #3: 

Unity alone can not be the problem. I am running unity on ubuntu 12.04 (amd64) and can not reproduce the issue.

Torsten Lilge <ttl>
Project Member
Sun 02 Feb 2014 01:04:57 AM UTC, comment #2: 

Yes, I run Unity. I also have an Intel i7 Processor

Jameson <jamdaman5000>
Sun 02 Feb 2014 12:15:52 AM UTC, comment #1: 

Do you run Unity? I have the same behaviour with Unity (on amd64). With LXDE (on i386), octave works fine. Both machines running Ubuntu 13.10.

Anonymous
Sat 01 Feb 2014 11:56:19 PM UTC, original submission:  

After opening Octave 3.8.0 GUI with the command "octave3.8 --force-gui",
cursor blinks in the command window and I am able to type text, commands, etc.

If I focus to a different program (e.g. Chromium) while octave is still running, upon returning to Octave, I can not immediately type text into the command line (even after clicking inside the Command Window multiple times and trying to type text and hit Enter. To get around this bug, I need to switch tabs within Octave GUI (e.g. Editor), then switch back to Command Window tab to re-initiate text entry.

I am running Ubuntu 12.04.

I also have Chromium and Skype open. Closing these programs does not correct the issue.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #30435:  focus_v01.patch added by ttl (722B - text/x-diff)

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by cdf (Posted a comment)
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by jamdaman5000 (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-02-02 ttl StatusNone => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #40823
    2014-02-02 ttl Attached File- => Added focus_v01.patch, #30435

    Back to the top


    Powered by Savane 3.5