bugGNU Octave - Bugs: bug #41099, octave-mode in emacs doesn't ...

 
 

bug #41099: octave-mode in emacs doesn't launch inferior mode

Submitted by:  None
Submitted on:  Sat 04 Jan 2014 04:11:14 PM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Other
Status:  Invalid Assigned to:  None
Originator Name:  Pablo Ordonez Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  other
Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 29 May 2014 02:12:15 AM UTC, comment #5: 

Closing this bug as invalid since there is nothing for Octave to fix. According to comment #2, Emacs 24.4 will be compatible with Octave 3.8. If there are any problems with Emacs Octave mode, they should be reported to the Emacs maintainers.

Mike Miller <mtmiller>
Project Administrator
Tue 04 Mar 2014 08:27:52 PM UTC, comment #4: 

I had a similar problem with Octave 3.8.0 and Emacs 24.3.1 in Ubuntu 13.10 (64bit). I could run Octave in shell mode but every time I tried to start an inferior octave process (either by submittinf part of a .m file or by M x run-octave) Emacs froze The emacs process had to be ended using System Monitor. The "--no-gui" solution had no effect (as expected in 3.8 where the GUI is not the default).

I had  the same problem with the MXE build of octave in Windows 7 with emacs 24.3.1 and octave 3.8.0.

As System Monitor showed that Octave had started but appeared to lose contact with Emacs I decided to experiment with the Octave font. I added

PS1(">> ")

to my .octaverc file in my home directory and 

(setq inferior-octave-prompt ">> ")

to my .emacs file.

This solved the problem in both Ubuntu and Windows. It would appear to me that the installation of version 3.8 changed the prompt causing Emacs to lose contact with Octave in both Windows and Ubuntu.

Earlier I had tried to revert to 3.6.4 in Windows (simple change of path in Windows). Earlier I think (but I am not absolutely sure) that I was able to start an inferior Octave process. After changing the path so that emacs would load 3.6.4 Emacs again froze. Has the installation of 3.8 change some of the prompt defaults? Perhaps someone with a better knowledge of Octave Emacs  Octave mode has an answer.

John C Frain <frainj>
Mon 24 Feb 2014 10:58:05 PM UTC, comment #3: 

So it sounds like we can close this bug since there's really nothing Octave can do. But before we do, is there an Emacs bug report or a commit diff we can link to for future reference in case people ask the Octave developers about this issue again in the future?

Also if you mean Emacs will add "--no-gui" to the command line by default, doesn't that make it incompatible with Octave 3.6.4? Or does Emacs query the Octave version and dynamically decide which options to pass?

Mike Miller <mtmiller>
Project Administrator
Mon 24 Feb 2014 10:17:10 PM UTC, comment #2: 

Add "--no-gui" to the `inferior-octave-startup-args' flags.  This will be done automatically in the new version of octave-mode in Emacs 24.4  I'd generally recommend to use the new version of the octave mode, which has seen a lot of changes.  It should be backwards compatible with Emacs 24.3.  So you should be able to simply grab it from the current trunk and use it.

I'd also recommend to report issues with the Emacs mode to the Emacs bugtracker.

RĂ¼diger Sonderfeld <ruediger>
Sat 04 Jan 2014 05:20:06 PM UTC, comment #1: 

It would be better if you could try this with the official 3.8.0 release to see if the problem still occurs. In particular, the 3.7 development series launched the GUI by default but 3.8.0 does not.

Or if you can tell me how to send a line to octave, I can try to reproduce. I got as far as M-x octave-mode in a scratch buffer, non-emacs user here.

Mike Miller <mtmiller>
Project Administrator
Sat 04 Jan 2014 04:11:14 PM UTC, original submission:  

My system
uname -a : 3.8.0-35
lsb_release: Ubuntu 13.04
Octave:  3.7.7 from ppa:octave/unstable
Emacs: 24.3.1
Starting octave from CLI with or without GUI works. But if I open an octave file from Emacs and I "send" a line or a region, the inferior octave mode doesn't open. Instead, the GUI from the new version pops up.
Any other information please contact me.

Thanks

Pablo

PS: I don't include any customization for octave mode.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by frainj (Posted a comment)
  • -email is unavailable- added by ruediger (Posted a comment)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-05-29 mtmiller StatusNeed Info => Invalid
        Open/ClosedOpen => Closed
    2014-01-07 rik5 Carbon-CopyRemoved 72865 => -
    2014-01-07 rik5 Summaryoctave-mode in emacs doesn\'t launch iferior mode => octave-mode in emacs doesn't launch inferior mode
    2014-01-04 mtmiller StatusNone => Need Info

    Back to the top


    Powered by Savane 3.5