bugGNU Octave - Bugs: bug #41092, GUI Editor does not open

 
 

bug #41092: GUI Editor does not open

Submitted by:  None
Submitted on:  Fri 03 Jan 2014 08:54:09 PM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Other
Status:  Invalid Assigned to:  None
Originator Name:  Bryan Poling Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  3.8.0
Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 04 Jan 2014 12:12:20 AM UTC, comment #5: 

I do agree - this was not a bug.

I am afraid I am not really able to contribute in this way. I do not know Qt and only some C++. I think the best I can do here is testing and reporting issues (hopefully no more issues due to me building improperly). Thanks for the help.

Bryan Poling <poli0048>
Sat 04 Jan 2014 12:07:56 AM UTC, comment #4: 

The editor works now. I am really impressed so far by the quality of the GUI :-)

Bryan Poling <poli0048>
Fri 03 Jan 2014 11:36:06 PM UTC, comment #3: 

I'm tentatively closing this report as invalid. I hope you agree.

Perhaps the GUI should open a dialog window saying that Octave was compiled without editor support. Are you able to provide such a patch yourself? Do you know C++ and/or Qt programming?

If so, please follow up on the development mailing list: -email is unavailable-

Jordi GutiƩrrez Hermoso <jordigh>
Project Administrator
Fri 03 Jan 2014 11:29:16 PM UTC, comment #2: 

This is indeed the case. I feel a little silly actually - I mis-interpreted the warning during the configure process. When it said "GUI editor will be disabled", I thought it meant a dev tool for editing the GUI... not the Editor component of the GUI itself (I thought "No problem - I don't need that"). I am re-building now.

What would you ask of me for help with the GUI?

Bryan Poling <poli0048>
Fri 03 Jan 2014 09:06:44 PM UTC, comment #1: 

Did you compile Octave yourself? It looks like it, since you say "GNU/Linux", but I don't believe anyone has packaged 3.8 yet.

My guess is that you compiled Octave without QScintilla support. Can you verify that this is the case?

Also, since you're almost certainly compiling, are you willing to help us with the GUI? It's currently experimental, and as you can see, we need lots of help.

Jordi GutiƩrrez Hermoso <jordigh>
Project Administrator
Fri 03 Jan 2014 08:54:09 PM UTC, original submission:  

The editor component of the GUI does not seem to work. Double clicking on a file in the file browser does nothing. Typing edit foo.m, for instance, in the command window will create the file, but nothing opens to edit the file. In the Window menu, I can check and uncheck "Show Editor" to no effect.

In preferences, I do see many options for the editor. I just cannot run the editor.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by poli0048 (Posted a comment)
  • -email is unavailable- added by jordigh (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-01-03 jordigh StatusNeed Info => Invalid
        Open/ClosedOpen => Closed
    2014-01-03 jordigh StatusNone => Need Info

    Back to the top


    Powered by Savane 3.5