bugGNU Octave - Bugs: bug #40215, no plots generated with fltk on...

 
 

bug #40215: no plots generated with fltk on different virtual desktop

Submitted by:  Andreas Stahel <sha1>
Submitted on:  Wed 09 Oct 2013 11:18:25 AM UTC  
 
Category: Plotting with OpenGLSeverity: 3 - Normal
Priority: 5 - NormalItem Group: None
Status: DuplicateAssigned to: None
Originator Name: Andreas StahelOpen/Closed: Closed
Release: devOperating System: GNU/Linux

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 29 May 2014 03:52:40 PM UTC, comment #5:

Thanks for the confirmation for both LXDE and XFCE. I can also reproduce with an older GNOME 2 but not with GNOME 3.

The failure to print occurs if a window manager puts a window in the unmapped state when it is minimized or moved to a different virtual desktop. Some window managers/desktop environments do and some do not.

Marking as a duplicate of bug #33180 because it is the same basic problem, unable to print a figure that is not rendered when using FLTK.

Mike Miller <mtmiller>
Project Member
Thu 29 May 2014 03:25:59 PM UTC, comment #4:

I can confirm too (with Lubuntu 14.04 / LXDE).

Stefan Mahr <dac922>
Thu 29 May 2014 02:22:33 PM UTC, comment #3:

I can confirm this with Octave 3.8.1 and default 79f69742971a under XFCE 4.8.0.3, debian wheezy amd64.

Andreas Weber <andy1978>
Project Member
Thu 29 May 2014 01:55:34 AM UTC, comment #2:

No followup comments from OP in about 8 months. Closing as works for me. If this problem persists or returns, feel free to reopen this bug or report a new bug describing the problem in more detail.

Mike Miller <mtmiller>
Project Member
Wed 09 Oct 2013 06:12:08 PM UTC, comment #1:

This works for me on the development branch (17616:8cc19352fd74). This may have more to do with windowing systems (I use KDE) than with Octave. Test system was Mint, based on ubuntu 12.04, with 64-bit kernel. The critical OpenGL2ps library was libgl2ps0 1.3.6-1.

Rik <rik5>
Project Administrator
Wed 09 Oct 2013 11:18:25 AM UTC, original submission:

Generate a plot on screen, then switch to a different virtual desktop, launch print('test.png') command. No PNG graphics is generated

This I tested with the dev version and 3.6.4 on an Xubuntu 12.04
platform (XFCE) on different computers.
The Gnuplot backend does not show this problem.
The attached code TestPrint.m should help to repeat the problem.

Andreas Stahel <sha1>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #29333:  TestPrint.m added by sha1 (352B - text/x-objcsrc)

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by dac922 (Posted a comment)
  • -unavailable- added by andy1978 (Posted a comment)
  • -unavailable- added by mtmiller (Posted a comment)
  • -unavailable- added by rik5 (Posted a comment)
  • -unavailable- added by sha1 (Submitted the item)
  • -unavailable- added by sha1
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 6 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu 29 May 2014 03:50:17 PM UTCmtmillerStatusWorks For Me=>Duplicate
      Dependencies-=>Depends on bugs #33180
    Thu 29 May 2014 01:55:34 AM UTCmtmillerOpen/ClosedOpen=>Closed
    Wed 09 Oct 2013 06:12:08 PM UTCrik5StatusNone=>Works For Me
    Wed 09 Oct 2013 11:18:25 AM UTCsha1Attached File-=>Added TestPrint.m, #29333
      Carbon-Copy-=>Added -unavailable-

    Back to the top


    Powered by Savane 3.1-cleanup