bugGNU Octave - Bugs: bug #39307, make html in doc/interpreter fails...

 
 

bug #39307: make html in doc/interpreter fails with texinfo 5.1

Submitted by:  Mike Miller <mtmiller>
Submitted on:  Fri 21 Jun 2013 02:04:03 AM UTC  
 
Category: Configuration and Build SystemSeverity: 3 - Normal
Priority: 5 - NormalItem Group: Build Failure
Status: FixedAssigned to: None
Originator Name: Open/Closed: Closed
Release: devOperating System: GNU/Linux

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 23 Jun 2013 04:29:06 AM UTC, comment #5:

Yes, that fixes it, thanks for looking into it.

I see you already pushed this as

http://hg.savannah.gnu.org/hgweb/octave/rev/ab0454713ded

Marking as fixed.

Mike Miller <mtmiller>
Project Member
Sat 22 Jun 2013 03:21:39 PM UTC, comment #4:

I think it may be the case that Texinfo 5.1 is much more picky about how macros, like @seealso, are used.

I'm attaching a changeset which I believe will fix the error reported at system.texi:2890. Could you try it out and report back?

(file #28388)

Rik <rik5>
Project Administrator
Sat 22 Jun 2013 05:39:59 AM UTC, comment #3:

I've bisected the error to this changeset:

http://hg.savannah.gnu.org/hgweb/octave/rev/bf1de4943a5d

I'm not sure what about that change is causing the error I see, but there it is.

Mike Miller <mtmiller>
Project Member
Sat 22 Jun 2013 04:14:22 AM UTC, comment #2:

I was on cc1657be1ee7. I've now updated to 286904321282 and built from scratch and I get the same error again. I've been seeing this error for a couple of weeks, but I can't say whether it's due to a change in Octave or the recent change in Debian from texinfo 4.13 to 5.1.

Mike Miller <mtmiller>
Project Member
Fri 21 Jun 2013 11:53:41 PM UTC, comment #1:

What changeset are you at in Mercurial?

Is it before or after 16772:7eff3032d144 where I made the HTML documentation buildable under Texinfo 4.X?

Rik <rik5>
Project Administrator
Fri 21 Jun 2013 02:04:03 AM UTC, original submission:

I am sure I had been able to build doc/interpreter with texinfo 5 at one point, but it no longer works for me. The command that fails and the error message produced are:

where srcdir=../../../default/doc/interpreter for my setup.

Mike Miller <mtmiller>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #28388:  bug_39307.cset added by rik5 (833B - application/octet-stream)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by rik5 (Posted a comment)
  • -unavailable- added by mtmiller (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 23 Jun 2013 04:29:06 AM UTCmtmillerStatusNeed Info=>Fixed
      Open/ClosedOpen=>Closed
    Sat 22 Jun 2013 03:21:39 PM UTCrik5Attached File-=>Added bug_39307.cset, #28388
    Fri 21 Jun 2013 11:53:41 PM UTCrik5StatusNone=>Need Info

    Back to the top


    Powered by Savane 3.1-cleanup