bugGNU Octave - Bugs: bug #38575, crash on lapack error if libraries...

 
 

bug #38575: crash on lapack error if libraries built with -Bsymbolic

Submitted by:  Mike Miller <mtmiller>
Submitted on:  Fri 22 Mar 2013 11:56:24 PM UTC  
 
Category: Configuration and Build SystemSeverity: 3 - Normal
Priority: 5 - NormalItem Group: Crash
Status: Wont FixAssigned to: None
Originator Name: Open/Closed: Closed
Release: devOperating System: GNU/Linux

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri 27 Sep 2013 02:15:51 AM UTC, comment #2:

Closing my own bug as wont-fix, this is something that should probably be addressed in the way the numerical libraries are compiled and I don't think there is much Octave could do about it, other than detecting and printing a warning in the configure script.

Now that the lapack library in Ubuntu has been fixed to build without the -Bsymbolic-functions option, the only case of this I cared about has vanished, so closing.

Mike Miller <mtmiller>
Project Member
Fri 22 Mar 2013 11:57:58 PM UTC, comment #1:

I forgot to conclude:

It should be easy to detect this in configure, but what to do when this is the case? Fail to compile? Is there any other way we could work around this problem?

Mike Miller <mtmiller>
Project Member
Fri 22 Mar 2013 11:56:24 PM UTC, original submission:

Octave crashes, or rather exits from within the BLAS or LAPACK libraries, when those libraries are linked with the -Bsymbolic or -Bsymbolic-functions linker options. The entire Ubuntu distribution is built by default with -Bsymbolic-functions, for example.

The problem is that Octave expects to be able to override the XERBLA error handler function by defining its own copy and linking it first so it takes precedence over BLAS and LAPACK's own copies. This has no effect when the LAPACK shared library is linked using -Bsymbolic-functions.

The attached program (modified from a snippet posted by jwe in a different bug report) shows the difference between Debian and Ubuntu, both with LAPACK version 3.4.2:

Mike Miller <mtmiller>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #27663:  xerbla-test.f added by mtmiller (789B - text/x-fortran)

 

Depends on the following items: None found

Digest:
   bug dependencies.

 

Carbon-Copy List
  • -unavailable- added by mtmiller (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 27 Sep 2013 02:15:51 AM UTCmtmillerStatusNone=>Wont Fix
      Open/ClosedOpen=>Closed
    Thu 15 Aug 2013 11:59:00 AM UTCmtmillerDependencies-=>bugs #39788 is dependent
    Fri 22 Mar 2013 11:56:24 PM UTCmtmillerAttached File-=>Added xerbla-test.f, #27663

    Back to the top


    Powered by Savane 3.1-cleanup