bugGNU Octave - Bugs: bug #38498, Octave package image-2.0.0 install...

 
 

bug #38498: Octave package image-2.0.0 install failure on Windows

Submitted by:  Juhani Heiskanen <juheni>
Submitted on:  Sun 10 Mar 2013 11:43:03 PM UTC  
 
Category: Octave Forge PackageSeverity: 3 - Normal
Priority: 5 - NormalItem Group: Installation Failure
Status: InvalidAssigned to: None
Originator Name: Open/Closed: Closed
Release: 3.6.2Operating System: Microsoft Windows

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 23 Apr 2013 08:44:06 AM UTC, comment #1:

Octave-3.6.4 MinGW version now ships image-2.0.0 package.

http://sourceforge.net/projects/octave/files/Octave%20Windows%20binaries/Octave%203.6.4%20for%20Windows%20MinGW%20installer/

Octave 3.6.2 VS2010 version has image-2.0.0 package in Forge Packages Upgrades.

http://sourceforge.net/projects/octave/files/Octave%20Windows%20binaries/Octave%203.6.2%20for%20Windows%20Microsoft%20Visual%20Studio/

Tatsuro MATSUOKA <tmacchant>
Sun 10 Mar 2013 11:43:03 PM UTC, original submission:

Hi,

Can't install image-2.0.0 Octave package.
First I installed general-1.3.2 package, then I installed signal-1.2.0 package. After that I try to install image-2.0.0 package, but it stop everytime an error as follow:

In file included from c:\Octave\Octave3.6.2_gcc4.6.2\include\octave-3.6.2\octave/lo-utils.h:31:0,
from c:\Octave\Octave3.6.2_gcc4.6.2\include\octave-3.6.2\octave/Array.h:38,
from c:\Octave\Octave3.6.2_gcc4.6.2\include\octave-3.6.2\octave/boolMatrix.h:27,
from c:\Octave\Octave3.6.2_gcc4.6.2\include\octave-3.6.2\octave/mx-base.h:32,
from c:\Octave\Octave3.6.2_gcc4.6.2\include\octave-3.6.2\octave/Matrix.h:30,
from bwlabeln.cc:20:
c:\Octave\Octave3.6.2_gcc4.6.2\include\octave-3.6.2\octave/lo-cutils.h:50:12: error: 'pid_t' does not name a type g++: error: bwlabeln.o: No such file or directory
make: *** [bwlabeln.oct] Error 1
'make' returned the following error: make: Entering directory `/tmp/oct-5/image/src'
C:/Octave/Octave3.6.2_gcc4.6.2/bin/mkoctfile-3.6.2 _spatial_filtering_.cc
C:/Octave/Octave3.6.2_gcc4.6.2/bin/mkoctfile-3.6.2 _bilateral_.cc
C:/Octave/Octave3.6.2_gcc4.6.2/bin/mkoctfile-3.6.2 _custom_gaussian_smoothing_.cc
C:/Octave/Octave3.6.2_gcc4.6.2/bin/mkoctfile-3.6.2 _boundary_.cc
C:/Octave/Octave3.6.2_gcc4.6.2/bin/mkoctfile-3.6.2 bwlabel.cc
C:/Octave/Octave3.6.2_gcc4.6.2/bin/mkoctfile-3.6.2 bwfill.cc
C:/Octave/Octave3.6.2_gcc4.6.2/bin/mkoctfile-3.6.2 rotate_scale.cc
C:/Octave/Octave3.6.2_gcc4.6.2/bin/mkoctfile-3.6.2 hough_line.cc
C:/Octave/Octave3.6.2_gcc4.6.2/bin/mkoctfile-3.6.2 graycomatrix.cc
C:/Octave/Octave3.6.2_gcc4.6.2/bin/mkoctfile-3.6.2 _bwdist_.cc
C:/Octave/Octave3.6.2_gcc4.6.2/bin/mkoctfile-3.6.2 nonmax_supress.cc
CXXFLAGS='-g -02 -std=c++0x -Wall' C:/Octave/Octave3.6.2_gcc4.6.2/bin/mkoctfile-3.6.2 bwlabeln.cc
make: Leaving directory `/tmp/oct-5/image/src'
error: called from ┬┤pkg>configure_make' in file C:\Octave\Octave3.6.2_gcc4.6.2\share\octave\3.6.2\m\pkg\pkg.m near line 1385, column 9
error: called from:
error: C:\Octave\Octave3.6.2_gcc4.6.2\share\octave\3.6.2\m\pkg\pkg.m at line 827, column 5
error: C:\Octave\Octave3.6.2_gcc4.6.2\share\octave\3.6.2\m\pkg\pkg.m at line 383, column 9

I have tried installation on Windows XP 32-bit. and Windows 7 64-bit.
Octave version is: Octave-3.6.2-mingw + octaveforge pkgs (Octave3.6.2_gcc4.6.2_20120609.7z and Octave3.6.2_gcc4.6.2_pkgs_20120613.7z)

What I can do to install new image package?

Thanks

Juhani Heiskanen <juheni>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by tmacchant (Posted a comment)
  • -unavailable- added by juheni (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sat 26 Oct 2013 09:16:24 AM UTCcarandraugStatusNone=>Invalid
      Open/ClosedOpen=>Closed

    Back to the top


    Powered by Savane 3.1-cleanup