bugGNU Octave - Bugs: bug #37468, Octave hangs when using F instead...

 
 

bug #37468: Octave hangs when using F instead of f for More or Less

Submitted by:  Doug Stewart <dastew>
Submitted on:  Sun 30 Sep 2012 01:43:50 AM UTC  
 
Category: GUISeverity: 3 - Normal
Priority: 5 - NormalItem Group: Crash
Status: DuplicateAssigned to: None
Originator Name: Doug StewartOpen/Closed: Closed
Release: devOperating System: GNU/Linux

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Sun 28 Jul 2013 07:42:16 PM UTC, comment #6:

Update: duplicate of bug #37672. Closing this bug as I've now copied the information about less not receiving a SIGINT to that bug report.

Mike Miller <mtmiller>
Project Member
Sun 30 Sep 2012 12:36:17 PM UTC, comment #5:

I think this is really a duplicate of #36986. Less is behaving correctly but you need Ctrl-C to work to exit out of "tail" mode, otherwise it will intentionally block forever.

Mike Miller <mtmiller>
Project Member
Sun 30 Sep 2012 04:25:15 AM UTC, comment #4:

I am using "less"

Doug Stewart <dastew>
Sun 30 Sep 2012 04:17:56 AM UTC, comment #3:

Confirmed on development build 2fa06d83263a.

Which pager are you using? Try typing PAGER at the Octave prompt to find out. When I use 'less' I see the problem that you do. According to the man page for 'less', the key 'F' is a command.

My guess is that less tries to do a read and there is no more data and so the process blocks.

I have no problems if I use 'more'.

A good test case is 'help eigs' because this has a long docstring which invokes the pager.

Rik <rik5>
Project Administrator
Sun 30 Sep 2012 02:07:49 AM UTC, comment #2:

OK just GUI

Doug Stewart <dastew>
Sun 30 Sep 2012 01:56:17 AM UTC, comment #1:

Please avoid using the term "GUIDE" to refer to Octave's graphical interface. Using that term just invites confusion among our users because Matlab has something called "GUIDE" that is used for building programs that have graphical interfaces.

John W. Eaton <jwe>
Project Administrator
Sun 30 Sep 2012 01:43:50 AM UTC, original submission:

When trying hg id
219479b461b8 tip

I accidently typed in F instead of f in the pager. and the GUIDE system froze and would not even close with the X or the close command. I had to use Ubuntu Kill command to get rid of it.

Doug Stewart <dastew>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by mtmiller (Posted a comment)
  • -unavailable- added by rik5 (Posted a comment)
  • -unavailable- added by jwe (Posted a comment)
  • -unavailable- added by dastew (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 5 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 28 Jul 2013 07:42:16 PM UTCmtmillerStatusConfirmed=>Duplicate
      Open/ClosedOpen=>Closed
    Sun 28 Jul 2013 07:39:23 PM UTCmtmillerDependencies-=>Depends on bugs #37672
    Sun 30 Sep 2012 04:18:27 AM UTCrik5StatusNone=>Confirmed
    Sun 30 Sep 2012 01:56:17 AM UTCjweSummaryGUIDE system hangs when using F instead of f for More or Less=>Octave hangs when using F instead of f for More or Less

    Back to the top


    Powered by Savane 3.1-cleanup