bugGNU Octave - Bugs: bug #37354, Add support for multiple octave...

 
 

bug #37354: Add support for multiple octave interpreters in one gui window

Submitted by:  Gryllida <gryllida>
Submitted on:  Sat 15 Sep 2012 09:50:01 AM UTC  
 
Category:  GUI Severity:  1 - Wish
Priority:  1 - Later Item Group:  Feature Request
Status:  Wont Fix Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  dev Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Sun 07 Oct 2012 04:28:27 PM UTC, comment #10: 

This is good to know.  And, it would be good to
make this clear to users.

If a user has more than one "project" it would
seem reasonable to provide a means of creating
"project-based" settings.

Michael Godfrey <godfrey>
Project Member
Sun 07 Oct 2012 01:10:02 PM UTC, comment #9: 

Indeed, multiple instances of the GUI are working on the same settings file. From the Qt-Documentation at http://harmattan-dev.nokia.com/docs/library/html/qt4/qsettings.html#details this should be no problem:

"QSettings can safely be used from different processes (which can be different instances of your application running at the same time or different applications altogether) to read and write to the same system locations. It uses advisory file locking and a smart merging algorithm to ensure data integrity. Note that sync() imports changes made by other processes (in addition to writing the changes from this QSettings)."

Torsten Lilge <ttl>
Project Member
Thu 04 Oct 2012 04:21:17 PM UTC, comment #8: 

Jordi,

You are right, of course.  Even if it could be done
it is unlikely that running muliple Ocataves in the GUI is
a good idea.  (Sure wish there were a spec of the GUI that
addressed this and other issues.)

This does bring up the question of what happens if a user
starts more than one instance of the GUI?  At present it
appears that all the instances will reference the same config
files. Are these locked or otherwise protected against
corruption?

Michael Godfrey <godfrey>
Project Member
Thu 04 Oct 2012 01:07:59 PM UTC, comment #7: 

Debating the merits of having multiple interpreter instances will not affect the fact that it's a metric buttload of work required to get this done, not to mention the other fact that the last time this was partially attempted, it resulted in a huge slowdown as reference counting was converted into atomic operations.

Jordi GutiƩrrez Hermoso <jordigh>
Project Administrator
Thu 04 Oct 2012 04:29:43 AM UTC, comment #6: 

The control-c bug is known, but fixing it
will not provide multiple windows running
Octave.

You can have several editing windows open,
but only one instance of Octave within the
GUI.

Michael Godfrey <godfrey>
Project Member
Thu 04 Oct 2012 03:53:55 AM UTC, comment #5: 

godfrey, I had the Command Window go in a loop and there is no button to stop it. Probably implementing such button could remedy the lack of ability to open multiple command windows.

Generally such impression is caused by me working with multiple files often and having a separate command window for each could be more comfortable as the Editor supports multiple tabs. If that's difficult to implement, I could open a new GUI instance as mentioned earlier.

Thanks for your replies.

Gryllida <gryllida>
Thu 04 Oct 2012 03:41:50 AM UTC, comment #4: 

You said:
A user may edit a .m file, start it, see that it may be too slow and edit file, start a new command window with the new version (in parallel). Having multiple instances of the GUI could be less convenient.

It does not appear that this is or will be possible.  What
gave you the impression that a new command window could be opened?

Michael Godfrey <godfrey>
Project Member
Thu 04 Oct 2012 01:29:44 AM UTC, comment #3: 

I understand that currently 'octave' process includes GUI, but my original understanding of the structure was that octave-gui is a parent process, and octave-cli are its child processes, that may be terminated or added.

A user may edit a .m file, start it, see that it may be too slow and edit file, start a new command window with the new version (in parallel). Having multiple instances of the GUI could be less convenient.

Gryllida <gryllida>
Wed 03 Oct 2012 03:22:39 PM UTC, comment #2: 

Even if you could open a command window, I do not see
how this would work.  All of the panels which display
context of the current Octave session would have to be
duplicated.

On the other hand, have multiple instances of the GUI
been considered in the design?  What happens to the
configuration files if multiple instances of the GUI
are started?

Michael Godfrey <godfrey>
Project Member
Wed 03 Oct 2012 03:14:33 PM UTC, comment #1: 

Octave is not multithreaded and creating multiple interpreters in the same process is not currently possible.  Although it would be nice to be able to do what you suggest, it would require a lot of work to make it possible.

John W. Eaton <jwe>
Project Administrator
Sat 15 Sep 2012 09:50:01 AM UTC, original submission:  

In the GUI, we should make it possible to open multiple command windows.

This may be useful if one file is taking longer to be processed than another one, and a user wants to keep using Octave while the larger file is running.

Gryllida <gryllida>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Updated the item)
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by jordigh (Posted a comment)
  • -email is unavailable- added by godfrey (Posted a comment)
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by gryllida (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-02-04 rik5 StatusNone => Wont Fix
        Open/ClosedOpen => Closed
    2012-10-03 jwe Severity3 - Normal => 1 - Wish
        Priority5 - Normal => 1 - Later

    Back to the top


    Powered by Savane 3.5