bugGNU Octave - Bugs: bug #37231, MinGW: Both plot and hist are...

 
 

bug #37231: MinGW: Both plot and hist are crashing

Submitted by:  None
Submitted on:  Thu 30 Aug 2012 11:31:28 PM UTC  
 
Category:  Plotting Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Duplicate Assigned to:  None
Originator Name:  Manish Dharwadker Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  3.6.2
Operating System:  Microsoft Windows

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 03 Sep 2012 05:33:59 PM UTC, comment #5:

Duplicate of bug #35769.

Philip Nienhuis <philipnienhuis>
Project Member
Sat 01 Sep 2012 07:51:26 AM UTC, comment #4:

(Added "MinGW" to title)
As to status there aren't that much fine-grained options.

Good that it works for you. Reference BLAS isn't so very slow BTW, just not as optimized as the other versions.

AFAIU the issue has to do with (perhaps too aggressive?) internal optimization (by the compiler) when the libblas libs are built. Newer compilers versions seem to behave better, though.
This type of problems is very hard to debug, as in debug builds the errors seemingly randomly pop up in other places and debug build usually have no optimization anyway.

The MSVC-versions of Octave for Windows have better stability in this respect; maybe you could try those.

Philip Nienhuis <philipnienhuis>
Project Member
Fri 31 Aug 2012 10:49:43 PM UTC, comment #3:

Thanks .. I posted the MinGW and Java versions so the developers have an idea about my environment ...

I got it to work last night with libblas.dll.ref, it crashes with the other ones, I tried the dynamicarch libraries as well as the core2 ones (since my AMD E300 is dual-core).

Guess we can change status to "works with libblas.dll.ref but not with others" ? I cant debug this on Windows, if it was linux I could provide a core dump and a backtrace on gdb ...

Appreciate your help.

Manish

Anonymous
Fri 31 Aug 2012 10:16:19 PM UTC, comment #2:

(Sorry my memory was a bit hazy)
ARM CPU you wrote? It occurred to me that your problem probably refers to an issue related to libblas.dll that hasn't popped up for quite a while. See e.g., bug #35769.
The symptoms are on the one hand unpredictable (i.e., where and when), OTOH usually lead to a segfault.

In short, you'll have to experiment with the various libblas.dll versions in your <OCTAVE_INSTALL_DIR>/bin subdir (see below), copying and then renaming them one by one to libblas.dll until you find one which is stable.
This is outlined in the README with the Octave-3.6.2_gcc4.6.2 binary. Did you care to read that?

I used "demo plotyy" for a fairly reliable crash test; Tatsuro advised something like (IIRC):
a = randn (30, 100) + randn (30, 100) * i;
b = a * a;

FYI, in my <Octave-3.6.2_gcc4.6.2>/bin subdir I have:

libblas.dll.ref is the reference BLAS which /should/ work on most, if not all, architectures - but it is also the slowest.

Philip Nienhuis <philipnienhuis>
Project Member
Fri 31 Aug 2012 03:44:54 PM UTC, comment #1:

Sorry I do not fully understand: what do "MinGW version: 0.5-beta" and "Java: JRE 7" have to do with it? I suppose you simply run the MinGW 3.6.2 binary from Octave-Forge, don't you? There's a complete enough msys/mingw environment included with it.

Anyway your commands work for me on WinXP SP3 - see attached pic b37231.png. Also works with gnuplot, and I also tried them on Octave-3.4.3_gcc4.5.2 with success.
I don't discount your report - I do see e.g. "libstdc++-6.dll" on the crash log. But Octave can be made unstable by lots of things, especially on MinGW.
Just to be sure: did you forget to mention a few commands? Have you fiddled with Octave's setup (notably shadowing of functions etc.?

I'll leave this bug report open for a while until/unless you come up with more info; yet I'll change status to "Works for me".

(file #26457)

Philip Nienhuis <philipnienhuis>
Project Member
Thu 30 Aug 2012 11:31:28 PM UTC, original submission:

Octave version: Octave3.6.2_gcc4.6.2
MinGW version: 0.5-beta
Java: JRE 7
OS: Windows 7 SP1 (64-bit) AMD E-300 APU (CPU)

I am trying to run some queries as part of a class. Here is the command I am running:

or

hist (w)

Both of these crash, seems like an array out of bound issue. I am attaching the screen capture along with the Windows error log.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #26457:  b37231.png added by philipnienhuis (274KiB - image/png)
file #26455:  Octave_Plot_Hist_Error.png added by None (153KiB - image/png - Screen capture)

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by philipnienhuis (Updated the item)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    Fri 30 Nov 2012 09:46:54 PM UTC jordigh Dependencies- => Depends on bugs #35769
    Mon 03 Sep 2012 05:33:59 PM UTC philipnienhuis StatusWorks For Me => Duplicate
    Sat 01 Sep 2012 07:51:26 AM UTC philipnienhuis Open/ClosedOpen => Closed
        SummaryBoth plot and hist are crashing => MinGW: Both plot and hist are crashing
    Fri 31 Aug 2012 03:44:54 PM UTC philipnienhuis Attached File- => Added b37231.png, #26457
        StatusNone => Works For Me
    Thu 30 Aug 2012 11:31:28 PM UTC None Attached File- => Added Octave_Plot_Hist_Error.png, #26455

    Back to the top


    Powered by Savane 3.3