bugGNU Octave - Bugs: bug #36010, unable to load appropriate font...

 
 

bug #36010: unable to load appropriate font warning

Submitted by:  None
Submitted on:  Tue 27 Mar 2012 04:45:46 AM UTC  
 
Category:  Plotting Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Invalid Assigned to:  None
Originator Name:  Mitchal Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  3.6.1
Operating System:  GNU/Linux

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Thu 29 Mar 2012 03:19:01 PM UTC, comment #10:

As apparently this is a problem with a graphics card driver and not with Octave, I'm closing this bug report as invalid.

Jordi Gutiérrez Hermoso <jordigh>
Project Administrator
Thu 29 Mar 2012 09:00:30 AM UTC, comment #9:

It worked!!! The error is gone. So it most likely had something to do with the most recent nvidia development driver.

Thank you for your help!

Mitchal <mitchal>
Wed 28 Mar 2012 10:58:08 PM UTC, comment #8:

I changed from Windows 7 to Ubuntu last week. It won't be a big deal to reinstall, and I had to do a bit of work to install the nvidia development driver. I think I'll try it.

Mitchal <mitchal>
Wed 28 Mar 2012 07:02:03 PM UTC, comment #7:

I doubt you need to wipe the computer clean to uninstall CUDA...

You might try using nouveau instead:

http://en.wikipedia.org/wiki/Nouveau_%28software%29

Jordi Gutiérrez Hermoso <jordigh>
Project Administrator
Wed 28 Mar 2012 06:51:43 PM UTC, comment #6:

I tried alasmixergui. That seemed to work fine.

When I tried your code, another error appeared in addtion to the font error.

XRequest.137: BadWindow (invalid Window parameter)

with a hex error code at the end. The error seems to appears randomly. I have just recently installed the ubuntu operating system, so I checked the XRequest error against any software I installed. Turns out some people have trouble getting fltk and CUDA to work. CUDA is a toolkit from NVIDIA that allows direct access to the GPU using a C extended language. One of the things CUDA needs to work is a special driver, which is what the XRequest error seemed to have a problem with in all the posts I found. I looked into the XRequest erorr a bit more and some programs don't always notice when it fails, which would explain it not appearing before.

Since I recently installed Ubuntu, I thought it would be easiest to wipe the computer clean and reinstall Ubuntu, reinstall octave3.6.1, see if fltk works, then install CUDA and see if that messes it up. I think the cause would be pretty definitive if installing CUDA does mess up fltk which would mess up octave. But if CUDA doesn't mess up octave then we may never know what the problem was.

I can get pretty obsessive finding out what the error is. Before I wipe the computer clean and I can't repeat the error, do you have any other ideas?

Mitchal <mitchal>
Wed 28 Mar 2012 04:06:09 PM UTC, comment #5:

You might try changing the font to something you know exists on your system. The default font is '*' which allows the renderer to choose a suitable value, but that doesn't seem to be happening.

Sample code:

If you find a font that works you can set that as the default in your .octaverc file.

Rik <rik5>
Project Administrator
Wed 28 Mar 2012 02:27:33 PM UTC, comment #4:

Thanks, I don't see a problem in the configure output.

Hmm... I guess fltk is missing fonts... but why could that be? Your .octaverc is empty, right? Do other fltk apps work on your system? For example, dillo. Or alsamixergui. Can you try installing those and seeing if they work?

Jordi Gutiérrez Hermoso <jordigh>
Project Administrator
Tue 27 Mar 2012 06:32:01 PM UTC, comment #3:

Can you show the full output of configure? Try this:

Then gzip 36010.log and attach it to this report. Also attach config.log. I want to see if ./configure caught anything about libfontconfig or similar.

Jordi Gutiérrez Hermoso <jordigh>
Project Administrator
Tue 27 Mar 2012 06:21:16 PM UTC, comment #2:

Hi. Originator of post, but I had to create an account to respond so it might look like a different person.

I went to
ftp://ftp.gnu.org/gnu/octave/
and downlaoded
octave-3.6.1.tar.gz
Then I extracted the file, cd into the extracted directory,
./configure
make
make install
Everything seemed to go fine.

Mitchal <mitchal>
Tue 27 Mar 2012 01:35:43 PM UTC, comment #1:

How did you compile Octave?

Jordi Gutiérrez Hermoso <jordigh>
Project Administrator
Tue 27 Mar 2012 04:45:46 AM UTC, original submission:

graphics_toolkit('fltk');
x = 0:10;
y = x;
plot(x,y);

output
warning: ft_render: unable to load appropriate font

Running the above code gives teh above output for my system. It also creates an empty window with nothing in it. If the first line is omitted and gnuplot is used it works just fine.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #25481:  36010.log.tar.gz added by mitchal (14KiB - application/x-gzip)
file #25482:  config.log.tar.gz added by mitchal (108KiB - application/x-gzip)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by mitchal (Posted a comment)
  • -email is unavailable- added by jordigh (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2012-03-29 jordigh StatusNeed Info => Invalid
        Open/ClosedOpen => Closed
    2012-03-27 mitchal Attached File- => Added 36010.log.tar.gz, #25481
        Attached File- => Added config.log.tar.gz, #25482
    2012-03-27 jordigh StatusNone => Need Info

    Back to the top


    Powered by Savane 3.3