bugGNU Octave - Bugs: bug #35580, bootstrap is not portable to...

 
 

bug #35580: bootstrap is not portable to OpenBSD

Submitted by:  Edd Barrett <vext01>
Submitted on:  Tue 21 Feb 2012 07:41:00 AM UTC  
 
Category: Configuration and Build SystemSeverity: 2 - Minor
Priority: 3 - LowItem Group: Build Failure
Status: FixedAssigned to: None
Originator Name: Open/Closed: Closed
Release: devOperating System: *BSD

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Wed 21 Aug 2013 02:27:49 AM UTC, comment #9:

This is now fixed and bootstrap works on OpenBSD straight from a mercurial clone.

http://hg.savannah.gnu.org/hgweb/octave/rev/a801d0ab5830

Mike Miller <mtmiller>
Project Member
Sun 11 Aug 2013 09:05:09 PM UTC, comment #8:

The upstream gnulib bootstrap script has been fixed now to work with OpenBSD sha1.

http://git.savannah.gnu.org/cgit/gnulib.git/diff/?id=c50edd6462eaaae00f8549f9bad99d4e68b94376

I will test building Octave with an updated script. I'm aware there are some local changes we've made that need to be kept.

Also if we add SKIP_PO=true to bootstrap.conf, the new version of the bootstrap script will not even need a sha1sum program at all. Until we have gettext translations in Octave, this should be a safe change.

Mike Miller <mtmiller>
Project Member
Thu 08 Aug 2013 02:59:12 AM UTC, comment #7:

Update: the development version of Octave uses a script called bootstrap now instead of autogen.sh.

I believe this can be considered fixed. I have a successful bootstrap of a current Octave hg clone on OpenBSD 5.3, the following GNU packages are required to be installed for bootstrap to succeed: autoconf (2.69p0), automake (1.13.1), coreutils, libtool, m4.

I don't know for certain that GNU m4 is required, but I think I read in the autoconf manual at one time that it is, so I installed it and set M4=gm4 in my environment. Coreutils is required for gsha1sum only.

You can certainly follow up with gnulib upstream if you want them to consider using OpenBSD's sha1 instead of gsha1sum, but the bootstrap script currently uses the --status option that is GNU-specific.

Mike Miller <mtmiller>
Project Member
Tue 21 Feb 2012 04:01:04 PM UTC, comment #6:

No, it was a hg clone - I had forgotten that you can't bootstrap on OpenBSD...

Edd Barrett <vext01>
Tue 21 Feb 2012 03:52:31 PM UTC, comment #5:

OK.

You aren't running autogen.sh for a released version of Octave, are you? It is not needed except to build sources from the mercurial archive. If you have a tarball release, you just need to use the included configure script.

John W. Eaton <jwe>
Project Administrator
Tue 21 Feb 2012 03:45:57 PM UTC, comment #4:

I shall not be fixing this any time soon. I am going to focus my attention on getting the releases to build. When I find some time....

Edd Barrett <vext01>
Tue 21 Feb 2012 03:43:35 PM UTC, comment #3:

The error is also coming from the bootstrap script, which we should be using unmodified from gnulib. So the right place to fix this is in gnulib so that all projects using gnulib will get the fix, not just Octave.

John W. Eaton <jwe>
Project Administrator
Tue 21 Feb 2012 03:43:28 PM UTC, comment #2:

Btw, note that this problem is in gnulib, here:

http://git.savannah.gnu.org/gitweb/?p=gnulib.git;a=blob;f=build-aux/bootstrap;h=31eb651f64bd38de1e33e464c7505a6ddd6540c1;hb=54fd689b28b2f0292dfd7ca459308e0e6a008a40#l214

I'm CCing them here.

Jordi GutiƩrrez Hermoso <jordigh>
Project Administrator
Tue 21 Feb 2012 03:38:27 PM UTC, comment #1:

It's not a huge priority for autogen.sh to be portable, since it's not meant to be run by end users. This should be a simple thing to patch, though. Do you want to attempt it yourself?

Jordi GutiƩrrez Hermoso <jordigh>
Project Administrator
Tue 21 Feb 2012 07:41:00 AM UTC, original submission:

Under OpenBSD you can use sha1(1), but you won't find it as find_tool() in build-aux/bootstrap is trying, as --version only applies to GNU tools.

Edd Barrett <vext01>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by mtmiller (Posted a comment)
  • -unavailable- added by jwe (Posted a comment)
  • -unavailable- added by jordigh (Posted a comment)
  • -unavailable- added by vext01 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 11 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 21 Aug 2013 02:27:49 AM UTCmtmillerStatusNeed Info=>Fixed
      Open/ClosedOpen=>Closed
    Sun 11 Aug 2013 08:51:46 PM UTCmtmillerCarbon-CopyRemoved -unavailable-=>-
    Thu 08 Aug 2013 02:59:12 AM UTCmtmillerCategoryNone=>Configuration and Build System
      Item GroupNone=>Build Failure
      StatusConfirmed=>Need Info
      Summaryautogen.sh is not portable to OpenBSD=>bootstrap is not portable to OpenBSD
    Tue 21 Feb 2012 03:43:28 PM UTCjordighCarbon-Copy-=>Added -unavailable-
    Tue 21 Feb 2012 03:38:27 PM UTCjordighSeverity3 - Normal=>2 - Minor
      Priority5 - Normal=>3 - Low
      StatusNone=>Confirmed

    Back to the top


    Powered by Savane 3.1-cleanup