bugGNU Octave - Bugs: bug #34932, Warnings when starting Octave...

 
 

bug #34932: Warnings when starting Octave 3.4.3 in Fedora 16

Submitted by:  Richard Burton <rburton>
Submitted on:  Tue 29 Nov 2011 05:03:57 AM UTC  
 
Category:  Libraries Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  None Assigned to:  None
Originator Name:  Richard Burton Open/Closed:  Closed
Release:  3.4.3 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 16 Feb 2012 05:36:08 AM UTC, comment #4: 

This report references a deprecated version of Octave.  Closing report.

The issue may be re-opened if it can be verified on a new 3.6.X version of Octave.

Rik <rik5>
Project Administrator
Fri 02 Dec 2011 05:04:13 AM UTC, comment #3: 

>>This was a fresh install. Maybe the packages I installed had >>conflicting copies...?


But, had you done previous installs on the same machine?
It does not matter if you did someting like:
rm -rf octave
...install from octave site,
This will still have left previous Octave libraries
down the install tree.

Michael

Michael Godfrey <godfrey>
Project Member
Fri 02 Dec 2011 04:07:06 AM UTC, comment #2: 

Hi Michael,
This was a fresh install. Maybe the packages I installed had conflicting copies...?

The primary reason for reporting was so that whatever caused this could be improved in future versions.

Thanks. This gives me an idea of what to do to remove the warning.

Richard

Richard Burton <rburton>
Tue 29 Nov 2011 06:25:20 AM UTC, comment #1: 

I had a similar problem to this.  The cause turned out
to be the fact that new installs do not clean out
sufficiently in all cases.  If A function is moved
from some place like: /usr/local/share/octave/e/x/y/xxx
to another subdirectory then two copies of the functions
exist, and you get the error that you found.

If you go into /usr/local/share/octave (or the path you used)
and delete old and current versions of Octave functions
and then run make install again the problem should go away.

Michael

Michael Godfrey <godfrey>
Project Member
Tue 29 Nov 2011 05:03:57 AM UTC, original submission:  

All Octave packages installed. Started octave. Following warnings resulted.

Starting Octave...
GNU Octave, version 3.4.3

Octave was configured for "i386-redhat-linux-gnu".

>>>warning: dispatch is obsolete and will be removed from a future version of O

ctave; please use classes instead
warning: function /usr/share/octave/packages/specfun-1.0.9/erfcx.m shadows a bu
ilt-in function

      • Also QtOctave window default size which opens is much too small (Maybe good for Kindle Fire 7" display).
Richard Burton <rburton>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by godfrey (Posted a comment)
  • -email is unavailable- added by rburton (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follows 1 latest change.

    Date Changed by Updated Field Previous Value => Replaced by
    2012-02-16 rik5 Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.5